need help with my NA - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

General Miata Chat A place to talk about anything Miata

LinkBack Thread Tools
Old 10-27-2015, 04:04 PM   #1
Thread Starter
Join Date: Oct 2015
Posts: 1
Total Cats: 0
Angry need help with my NA

im having a lot of issues with my Miata for the past few months and its just gotten worse. the car "will" not move nor will it keep and idle. it has a very bad power loss and runs extremely rich to the point of obnoxious backfire(guns shots).
ive recently replaced the ecu cause there was no continuity between the o2 and the ecu and several sensors, and the problem still occurs. I added the bg fuel treatment system to my car and it made the problem even worse to the point where I cant even keep the car at idle(hot or cold). when I was able to get to idle by having throttle pressed a small amount, it began to feel restricted and backfired really loud (like gun shots). to refresh the situation "my car has a really really bad stalling, power, and idle issue" the car runs really really rich.

this is a complete list of everything replaced
O2 sensor
2 new injectors cause #3 and 4 were having a small leak
TPS(and is adjusted to spec)
fuel filter
coil pack
spark plugs and wires
fuel pressure regulator(its adjustable and when maxed out it still runs 28-30 psi with and without vacuum; this is on the return side)
brand new alternator and battery
set timing to oem spec

I have no vacuum leaks(at least that able to be heard)
I have spark
I have fuel but low on pressure to spec on the return side
again runs rich as hell but no black smoke while running or crank
burns a quart of oil at least every 2-3k miles
pistons looked fine on top besides some carbon build up(very small amount)
no crank shaft wobble
jkmack6293 is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Rev MS2 Enhanced - Car stopped starting, can't connect to ECU Hungry-R MEGAsquirt 2 10-27-2015 05:43 AM
Run boost gauge from ECU MAP? Itty MSPNP 6 09-22-2015 11:02 AM
Is my Hydra Nemesis ECU dying? (1995 Miata w/ FMII Kit) MechE Prefabbed Turbo Kits 11 08-20-2015 10:06 AM
Car won't start. ecu problems? BlenderBlast General Miata Chat 0 12-05-2011 02:32 AM
replaced Power Transistor/igniter module - now car wont start, injectors stuck closed zvonkorp MSPNP 0 08-06-2011 03:50 PM

1.6l miata, car help, diagnosis

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 03:45 PM.