I turn to you for Honda help!!! - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to Miataturbo.net   Members

Insert BS here A place to discuss anything you want

LinkBack Thread Tools Search this Thread
Old 05-06-2008, 10:01 AM   #1
Elite Member
Thread Starter
iTrader: (39)
Zabac's Avatar
Join Date: Sep 2007
Location: High Point NC
Posts: 4,858
Total Cats: 8
Default I turn to you for Honda help!!!

First, this is not me being lazy or looking to be spoonfed, mmmmk?
My GF has 2001 Honda Civic EX Automatic bone stock other than a CD player.
The turn signals gradually sarted to stop working, hazards included. All the bulbs outside are good, they do light up every now and then, they do light up with the keyless entry, and when you hit the hazards.
This has been going on for a while now and I have been trying to figure out what's going on. In my search I found that the 01's have a recal on the combination switch due to one of the prongs burning out in the connector harness and causing low beam headlight outage. So I took her car to dealer who replaced connector harness and combination switch for free. The problem is still there. All fuses are good, too.
I have spent about an hour on honda-tech this morning looking for an answer to no avail. Is it just me or do those guys only know old hondas (pre 99)? So, I gave up on over there, there seems to be a language barrier somewhere as I really don't get them.
So any of you good gentleman know what I should look for to help me diagnose this problem?
I did get a new flasher, I still can't find where it goes in the car though, so if anyone knows this as well, please do let me know.
All help from here is greatly appreciated as always.

Many Thanks,
Zabac is offline   Reply With Quote
Old 05-06-2008, 11:04 PM   #2
Senior Member
iTrader: (4)
Join Date: Aug 2007
Location: Guam (U.S Terr.)
Posts: 786
Total Cats: -2

My friend had the same problem. He bought a grounding kit from apexi and it fixed it.
mike_671 is offline   Reply With Quote
Old 05-06-2008, 11:23 PM   #3
Elite Member
iTrader: (11)
Join Date: Jun 2007
Location: Overland Park, Kansas
Posts: 5,382
Total Cats: 43

I'd check grounds too. Thats most likely what it is.

Check grounds, relay connections for corrosion, broken connections, etc.
elesjuan is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 Today 07:58 AM
Cannot set Base Timing to 10* Elfering MEGAsquirt 50 10-05-2015 08:04 AM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 09:17 AM
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 4 09-28-2015 10:10 PM
Recommended Tire Temp for best friction thumpetto007 Race Prep 4 09-27-2015 05:16 PM

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:31 AM.