Another Cooling Fan Activation Issue! - Page 2 - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

MEGAsquirt A place to collectively sort out this megasquirt gizmo

LinkBack Thread Tools
Old 09-23-2008, 05:50 PM   #21
Junior Member
Thread Starter
iTrader: (2)
Join Date: Jan 2008
Location: Chicago
Posts: 219
Total Cats: 0

So after screwing around with all the possible causes of the cooling fan not turning on I decided to give up and have a shop look at the issue. I tried everything possible but just couldn't figure out was was wrong. All the wiring was intact, replaced thermo switch, replaced relay, tested with 2 different fans to make sure the fan was working. So after the shop did all the same trouble shooting steps that I had done came to realize the relay was bad. That just pist me off. The relay was the first guess I made and had replaced it with a new unit from Autozone. The shop told me the damn realy was bad to begin with. So I am out of $217 dollars I could have well spent on something else. I guess im not sure who to yell at so am just venting here.
zarish is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 11:04 AM
Bizarre connection issue? nick470 MEGAsquirt 1 09-30-2015 10:32 PM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 01:42 PM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:31 PM.