GM Coolant Sensor Calibration Issues? - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

MEGAsquirt A place to collectively sort out this megasquirt gizmo

LinkBack Thread Tools
Old 03-29-2013, 07:48 PM   #1
Junior Member
Thread Starter
Join Date: Aug 2009
Location: Lake Jackson, TX
Posts: 158
Total Cats: 2
Default GM Coolant Sensor Calibration Issues?

I've been doing more tweaking of my tune and things are starting to shape up finally, but the other day I noticed that my coolant temperature readings were a bit whack. I spent hours (and probably gallons of fuel) letting the car warm up and cool down as I fine-tuned-and-flashed the settings with EasyTherm, and I thought I'd finally got it sorted out, but today again I noticed that the readings were substantially deviating from actual temp again.

I noticed a fair amount of green corrosion building up on the body of the sensor and I'm starting to suspect that the sensor is gone/going bad, but before I replace it I wanted to ask some stupid questions:

How important are the values of the bias resistors? *as long as the resistor on the board matches the value entered in EasyTherm* -- The reason I ask is that I purchased my board second-hand, and while I reconfigured a few things, I simply left the resistors that were there in place and changed my settings in EasyTherm. The CLT bias resistor is 2700-ohm and the IAT resistor is 1000-ohm. How significantly will this affect the use of the sensors?

And for those who have handled a few of them...
How closely are these sensors generally calibrated to the default/published specs? Are people having to make only minor adjustments in EasyTherm or are we commonly seeing the need for major calibration adjustments?

My biggest problem at the moment seems to be that it reads pretty consistently and accurately at lower temperatures, but when the car gets up to temperature it's got rather poor resolution (values seem to change in 4-degree steps) and seems to return inconsistent values from one day to the next.
jnshk is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 12:25 PM
MSPNPPro-MM0105: Coolant Temperature Output slomiata MEGAsquirt 5 10-07-2015 01:11 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 09:39 AM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 10:28 PM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:44 PM.