IAC Stuck open @ 102 steps - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to Miataturbo.net   Members

MEGAsquirt A place to collectively sort out this megasquirt gizmo

LinkBack Thread Tools
Old 05-24-2014, 12:51 AM   #1
Junior Member
Thread Starter
iTrader: (5)
Join Date: Oct 2011
Location: San Diego, CA
Posts: 392
Total Cats: 20
Default IAC Stuck open @ 102 steps

I was coming home last night and right as I was coming to a stop after getting off the freeway, my idle was crazy high. IE 4000rpm. I'm not sure if it happened while I was on the freeway or happened as I came to a stop. I tried hitting the throttle a few times and even turned off the car to reset everything to see if I could get it to come back down and no go.

Made it back home and after diagnosing it for a while, I think either my IAC is stuck open (never had any problems with it before) or something in my tune is commanding the IAC to stay open at 102 steps. Doesn't matter engine not running or running, warm or hot, it's just stuck at 102 which is around 4000rpms. Let the car sit over night and now it's at 113.

Does anyone see anything wrong with my tune? Or recommend where else to look? Planning on pulling throttle body and testing IAC with battery in a couple days if nothing is found in the tune.

Reverant 2012 era MS2e, 2004 MSM
Attached Files
File Type: msq 2014-05-22_21.38.17.msq (100.2 KB, 27 views)
slmhofy is offline   Reply With Quote
Old 05-24-2014, 12:55 AM   #2
Junior Member
Thread Starter
iTrader: (5)
Join Date: Oct 2011
Location: San Diego, CA
Posts: 392
Total Cats: 20

So I'm sitting in the car and just said F it and started it up. Idling perfectly throughout warmup. IAC seems to be working and commanding lower number as CLT increases. Will report back with updated status. Maybe leaving battery unplugged overnight helped? I can't really see how.

EDIT: Warmed up fine. Will drive car tomorrow and report back if problems.

Last edited by slmhofy; 05-24-2014 at 01:08 AM.
slmhofy is offline   Reply With Quote
Old 05-24-2014, 08:59 AM   #3
Boost Czar

iTrader: (60)
Braineack's Avatar
Join Date: May 2005
Location: Chantilly, VA
Posts: 69,648
Total Cats: 1,356

who built it?

ive seen that happen when d4 wasnt removed.
Braineack is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Need help - Stock Balancer and Fastforward overlay pulleys Frank_and_Beans Supercharger Discussion 13 09-12-2016 08:17 PM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 10:28 PM
Nuke Mars! Joe Perez Current Events, News, Politics 8 09-30-2015 04:41 PM
WTB; na6 Miata things (Canada) Jared Rowe WTB 0 09-23-2015 11:57 AM
Advanced Engine Dynamix Review (dead oil pump content) itsMikey Insert BS here 0 09-05-2015 02:56 PM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 02:03 PM.