closed loop idle suddenly screwing up? - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to   Members

MSPNP MSPNP specific Megasquirt related discussion.

LinkBack Thread Tools
Old 01-29-2013, 04:55 AM   #1
Junior Member
Thread Starter
Join Date: May 2011
Location: UK
Posts: 47
Total Cats: 0
Default closed loop idle suddenly screwing up?

i've had my MSPnP (MS1) in for a good few years now, all of a sudden in the last few months, the closed loop idle is acting crazy. sometimes when i start the car, it idles around 1000 and settles to 900rpm quickly (like before it should as it's still cold) and sometimes it starts normally but the idle rises to 2000rpm - for about 10 minutes then it goes normal.

Idle DC is set to start on 26, idle on 19, minimum 18 (TPS threshold is 2). but now it's starting, and fixed on 18 (TPS is zero). I raised the minimum to 19, and when i burnt that in, the idle DC then started to drop down and down to zero!

i can rescue it by burning open loop idle and then going back to closed loop, but it only lasts like a week before it starts going messed up again.

any ideas? should i just reburn the tune or the firmware?
skinny is offline   Reply With Quote
Old 01-29-2013, 07:39 AM   #2
Cpt. Slow
iTrader: (24)
curly's Avatar
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 11,618
Total Cats: 463

Your idle valve might be going bad. Unplug it and see if some of the symptoms go away, mostly the hunting idle. If so, just replace it.
curly is offline   Reply With Quote
Old 02-12-2013, 12:29 PM   #3
Junior Member
Thread Starter
Join Date: May 2011
Location: UK
Posts: 47
Total Cats: 0

i thought that but as soon as i switch to warm-up only, everything is fine and the idle speed responds to any changes that i then make in the settings. and when i change back to closed loop, again it's fine and responds to closed loop. then after a few days or weeks, the MS will get stuck in its rut again and doesn't respond sensibly to any changes.
skinny is offline   Reply With Quote

Related Topics
Thread Thread Starter Forum Replies Last Post
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 09:39 AM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 09:30 AM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 12:45 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 02:44 PM
Got bad Crank Angle Sensor and Random Misfire codes, but runs fine. Greasyman General Miata Chat 2 09-28-2015 10:44 AM

mspnp idle

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 11:06 AM.