Got bad Crank Angle Sensor and Random Misfire codes, but runs fine. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 09-28-2015, 02:50 AM   #1
Newb
Thread Starter
 
Join Date: Dec 2009
Posts: 9
Total Cats: 0
Default Got bad Crank Angle Sensor and Random Misfire codes, but runs fine.

My 97 has P0335 and P0300 CELS. Car runs fine. Don't really know what I should do, other than wipe the little bit of road grime off of the sensor. Can I get stranded if it suddenly goes totally bad?

The only possible symptom is a while ago while cruising at a steady speed on the highway, the car very briefly cut out, but then caught again, I didn't have to pull over or use the starter, it happened so quickly. It was like it just cut out for a couple of revolutions. It's happened twice. Would that be related to the crank sensor? Thanks.
Greasyman is offline   Reply With Quote
Old 09-28-2015, 02:55 AM   #2
Supporting Vendor
iTrader: (10)
 
Reverant's Avatar
 
Join Date: Jun 2006
Location: Athens, Greece
Posts: 5,441
Total Cats: 198
Default

Car runs fine because the crank angle sensor on the engine pulley is only used for misfire detection and nothing more. The engine pretty much runs on the CAS on the back of the head.
Reverant is offline   Reply With Quote
Old 09-28-2015, 11:44 AM   #3
Elite Member
iTrader: (5)
 
Join Date: Oct 2007
Location: Canton, Ga
Posts: 1,707
Total Cats: 19
Default

Quote:
Originally Posted by Greasyman View Post
My 97 has P0335 and P0300 CELS. Car runs fine. Don't really know what I should do, other than wipe the little bit of road grime off of the sensor. Can I get stranded if it suddenly goes totally bad?

The only possible symptom is a while ago while cruising at a steady speed on the highway, the car very briefly cut out, but then caught again, I didn't have to pull over or use the starter, it happened so quickly. It was like it just cut out for a couple of revolutions. It's happened twice. Would that be related to the crank sensor? Thanks.
Have the damper off lately? You would get these results when the trigger wheel is on backwards

Edit- like Rev said, its only misfire detection. You could unplug the crank sensor and it would still run

Last edited by Stealth97; 09-28-2015 at 11:58 AM.
Stealth97 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
01-05 Fab9 PNP COPs (used) FrankB Miata parts for sale/trade 6 09-30-2015 12:48 PM
VR6 to Miata Swap ScrapinMX5 Meet and Greet 8 09-28-2015 02:04 PM
Another Alternator thread ihiryu General Miata Chat 9 09-28-2015 11:22 AM
BP-6D on CAS only aidandj MEGAsquirt 14 09-25-2015 06:26 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:52 PM.