MSPNP2 1.6, gear engagement idle drop?? - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


MSPNP MSPNP specific Megasquirt related discussion.

Reply
 
 
 
LinkBack Thread Tools
Old 10-18-2016, 11:37 AM   #1
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2015
Location: Kennesaw, GA
Posts: 52
Total Cats: 2
Default MSPNP2 1.6, gear engagement idle drop??

Here's the what I have:
- Car idle's fine at about 1000rpm warm or cold.
- Push in clutch = idle is still normal
- select gear (ANY gear) = Idle does a dramatic drop, usually stalls if I don't blip the throttle.
- The car has a VTPS as well if that might be a source of the problem.

I am somewhat familiar with TS, but just kind of the basics. Hopefully you guys can help me figure out what the problem is.
I have a hunch it's something to do with idle settings but, like I said, not sure what.

Thanks, Dan.
Attached Files
File Type: msl 2016-16-10IDLEdrop.msl (75.1 KB, 7 views)
DanBrown is offline   Reply With Quote
Old 10-18-2016, 05:37 PM   #2
Supporting Vendor
 
Matt Cramer's Avatar
 
Join Date: Sep 2006
Posts: 2,172
Total Cats: 41
Default

This sounds like your clutch isn't fully releasing.
Matt Cramer is offline   Reply With Quote
Old 10-18-2016, 08:49 PM   #3
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2015
Location: Kennesaw, GA
Posts: 52
Total Cats: 2
Default

Quote:
Originally Posted by Matt Cramer View Post
This sounds like your clutch isn't fully releasing.
Well, the pilot bearing/TOB (cant tell which) is chirping so that could be it. Any experience on the "chirping" noise and the car acting this way?
I'm doing a motor swap soon and I am replacing the clutch and will be replacing those bits as well.
Just wanted to make sure it wasn't the tune.
DanBrown is offline   Reply With Quote
Old 10-23-2016, 10:44 PM   #4
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2015
Location: Kennesaw, GA
Posts: 52
Total Cats: 2
Default

For whom it may concern...
Turns out my slave cylinder is weeping like a ****, and I'll replace that and see if it resolves the problem.
DanBrown is offline   Reply With Quote
Old 10-30-2016, 10:25 PM   #5
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2015
Location: Kennesaw, GA
Posts: 52
Total Cats: 2
Default

Update:
Replaced the leaky slave cylinder, problem did not go away.
Going to check the clutch and neutral switches next.
DanBrown is offline   Reply With Quote
Old 11-27-2016, 10:36 AM   #6
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Jun 2015
Location: Kennesaw, GA
Posts: 52
Total Cats: 2
Default

Update:
Took out the clutch switch and did the jumper mod... Did not fix the problem.
Replacing Neutral Switch next, hopefully that works.
DanBrown is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Help me select a tow vehicle/snow plow stefanst Insert BS here 55 10-28-2016 01:49 PM
Knock light on idle jesssssssay MEGAsquirt 3 10-16-2016 02:08 PM
Boost limited to 12psi. EBC settings, boost leak, wastegate, 2.3" exhaust Rothko Engine Performance 6 10-15-2016 01:02 PM
Parts/Donor car leftovers mdc1983 Miata parts for sale/trade 0 10-11-2016 11:51 PM
1992 - Do I Buy or Don't I ? Need Advice ASAP miata-me-now Meet and Greet 20 09-28-2016 04:40 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 10:10 AM.