Mazdaspeed Front Sway Bar Collar Issue - Miata Turbo Forum -Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Suspension, Brakes, Drivetrain discuss the wondrous effects of boost and your miata...

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 09-21-2016, 04:15 AM   #1
Junior Member
Thread Starter
 
Join Date: Nov 2010
Location: Santa Monica, CA
Posts: 74
Total Cats: 1
Default Mazdaspeed Front Sway Bar Collar Issue

Just installed a 23mm Mazdaspeed front sway bar on my NB. The issue I'm running into is that somehow the collars/ stoppers are not in their usual location. Both are further inboard on the bar than they should be. Just curious if anyone can figure out the cause. Shifting from use? Mazda playing around with preload in different revisions? I'm puzzled. Red photo is how I was expecting the bar to fit, and pink photo is the issue I'm dealing with (Yes I painted it from red to pink). I have no problem throwing on a couple of split collars... just can't figure out why I have such a weird bar. Thanks
Attached Thumbnails
Mazdaspeed Front Sway Bar Collar Issue-s-l1600.jpg   Mazdaspeed Front Sway Bar Collar Issue-16884627110409553-account_id%3D1.jpg  

Last edited by customfab87; 09-21-2016 at 04:38 AM.
customfab87 is offline   Reply With Quote
Old 09-21-2016, 11:23 AM   #2
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 12,390
Total Cats: 776
Default

Is the bar flipped the right way? I was trying to install a rear bar a few weeks ago, and I had it flipped around and it caused the ends not to line up with end links correctly.
shuiend is offline   Reply With Quote
Old 09-21-2016, 12:38 PM   #3
Junior Member
Thread Starter
 
Join Date: Nov 2010
Location: Santa Monica, CA
Posts: 74
Total Cats: 1
Default

I'm not having an issue with end links. The stoppers on the bar are too far inboard from the bushings on both ends.
customfab87 is offline   Reply With Quote
Old 09-21-2016, 12:39 PM   #4
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 12,390
Total Cats: 776
Default

Quote:
Originally Posted by customfab87 View Post
I'm not having an issue with end links. The stoppers on the bar are too far inboard from the bushings on both ends.
I know that. I was just thinking out loud, that the stoppers could be in the right place, but the bar could be flipped around. Just something you can check.
shuiend is offline   Reply With Quote
Old 09-21-2016, 06:09 PM   #5
Junior Member
Thread Starter
 
Join Date: Nov 2010
Location: Santa Monica, CA
Posts: 74
Total Cats: 1
Default

Thanks but my problem is isolated on the straight piece of steel tube, and flipping it around would result in the same issue.
customfab87 is offline   Reply With Quote
Old 09-22-2016, 04:30 AM   #6
Junior Member
Thread Starter
 
Join Date: Nov 2010
Location: Santa Monica, CA
Posts: 74
Total Cats: 1
Default

Mystery solved. The previous owner had moved them inwards to mount onto his exocet. A sledge easily moved them back out. :-)
customfab87 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Permanent Battery Tender Install Guardiola General Miata Chat 7 09-26-2016 09:02 AM
New to the scene... track car... jimmy20282 General Miata Chat 22 09-23-2016 09:56 PM
Tein Flex 949 SE Coilovers 9/6 springs, FM Front Sway bar Mr. Wob Miata parts for sale/trade 6 09-17-2016 10:30 PM
MAF Sensor Issue Cococarbine3 General Miata Chat 2 09-17-2016 09:53 PM
1999 1.8L - Motor Mounts & Diff Bushings bawward WTB 0 09-16-2016 11:35 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 07:57 AM.