New WARI 4.0 and Firmware 4.0 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 05-01-2010, 03:24 PM   #1
Elite Member
Thread Starter
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default New WARI 4.0 and Firmware 4.0

http://adaptronic.com.au/downloads.html

Adaptronic recently posted new Wari and firmware. I'm not positive of the upgrades but if you're seeing some strange conditions that could be related to voltage fluctuation firmware corruption you might want to try this.
cjernigan is offline   Reply With Quote
Old 05-03-2010, 12:50 PM   #2
Elite Member
iTrader: (9)
 
Join Date: Jun 2008
Location: Houston, TX
Posts: 1,583
Total Cats: 8
Default

I'm guessing that fixed it Chad?
TravisR is offline   Reply With Quote
Old 05-03-2010, 02:28 PM   #3
Elite Member
iTrader: (15)
 
Join Date: Dec 2007
Location: San Antonio, Texas
Posts: 4,889
Total Cats: 28
Default

So I see it in the link on the downloads page, but nothing about V4 below that or on the forum. All I see is V3 info. Travis, any info on what the differences are compared to V3?
ZX-Tex is offline   Reply With Quote
Old 05-03-2010, 02:30 PM   #4
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,185
Total Cats: 2,582
Default

in for info as well
18psi is offline   Reply With Quote
Old 05-03-2010, 02:57 PM   #5
Senior Member
iTrader: (3)
 
Join Date: Aug 2005
Location: Gig Harbor, WA
Posts: 504
Total Cats: 3
Default

From the Adaptronic forum...

Quote:
Hi Everyone,

We have just released V4.000 firmware for the e420c ECU. It only has a few changes, but most importantly we fixed a bug where the VVT angle setpoint would always come from the 2D 'target angles' table based on RPM, even if you selected one of the options to use a fuel or ignition map for the VVT angle setpoint.

Cheers
Rob
TurboRoach is offline   Reply With Quote
Old 05-03-2010, 03:09 PM   #6
Elite Member
iTrader: (15)
 
Join Date: Dec 2007
Location: San Antonio, Texas
Posts: 4,889
Total Cats: 28
Default

Ahh OK I missed that Thanks.
ZX-Tex is offline   Reply With Quote
Old 05-03-2010, 03:27 PM   #7
Elite Member
Thread Starter
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Quote:
Originally Posted by TravisR View Post
I'm guessing that fixed it Chad?

Nope, it appears that the changes you mentioned took place when the built V3.000 according to the build notes on the download page.
Still dealing with the weird trim issue and the strange oscillation that takes place intermittently day to day. I can't force the car to reproduce it. No amount of heat soak, hot start, cold start causes it.
cjernigan is offline   Reply With Quote
Old 05-03-2010, 05:27 PM   #8
Junior Member
iTrader: (1)
 
Join Date: Aug 2008
Location: Granada, Spain
Posts: 336
Total Cats: 2
Default

Quote:
Originally Posted by cjernigan View Post
Nope, it appears that the changes you mentioned took place when the built V3.000 according to the build notes on the download page.
Still dealing with the weird trim issue and the strange oscillation that takes place intermittently day to day. I can't force the car to reproduce it. No amount of heat soak, hot start, cold start causes it.
Set delay before closed loop = 0
ismael_pt is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
No spark while cranking? navalhawkeye MEGAsquirt 9 10-07-2015 08:10 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
In need of base map for stock 1997 brandonbkd MEGAsquirt 0 09-29-2015 12:52 AM
MS3 Basic Connection Issues EErockMiata MEGAsquirt 6 09-24-2015 10:49 AM
ms2e No Rpm Signal Dobzeh ECUs and Tuning 5 09-17-2015 03:56 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:45 AM.