AEM
Sponsored by:
Sponsored by:

Misfire with RX7 460cc injectors

 
Old 06-13-2009, 06:37 PM
  #1  
Elite Member
Thread Starter
 
Join Date: Feb 2008
Location: Victoria, BC
Posts: 2,318
Total Cats: 12
Default Misfire with RX7 460cc injectors

Hey there, I just finished putting my new turbo setup, and included with that was a M-tuned fuel rail and some rx-7 460cc injectors. Now the car, if dead colds, idles horrible. The motor is misfiring really bad, and is shaking. As the car gets hotter, it gets better. Eventually it drives almost normal. My AFR is about 12.1 at idle, so I can't see it being the fuel map. When it is misfiring, it does it through any revs - gives a machine gun type sound.

Here's a quick what I have:

AEM EMS
97 miata motor (90 chassis) - using the 90-95 cam sensor settings
AEM 2 bar map sensor
AEM IAT
hks manifold
garrett t25 turbo

Any suggestions?
dustinb is offline  
Old 06-14-2009, 01:30 AM
  #2  
Elite Member
Thread Starter
 
Join Date: Feb 2008
Location: Victoria, BC
Posts: 2,318
Total Cats: 12
Default

Nevermind folks, turns out the igniter failed. I was only getting half the ignition pulse on cylinders 1 & 4, so I replaced the igniter and happy times.
dustinb is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Full_Tilt_Boogie
Build Threads
67
03-16-2019 08:07 PM
StratoBlue1109
Miata parts for sale/trade
21
09-30-2018 01:09 PM
90 Turbo
MEGAsquirt
19
10-19-2015 03:23 PM
Trent
WTB
2
10-01-2015 12:15 PM
The Gleas
MEGAsquirt
3
10-01-2015 09:30 AM


Thread Tools
Search this Thread
Quick Reply: Misfire with RX7 460cc injectors


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.