Another boring, unimaginative rip-off build. - Page 2 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Build Threads Building a motor? Post the progress here.

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 04-01-2014, 12:42 AM   #21
Senior Member
iTrader: (1)
 
Join Date: Jan 2012
Location: Tampa, FL
Posts: 761
Total Cats: 19
Default

Quote:
Originally Posted by GtiKyle View Post
Picked up a T25 turbo for $100 on craigslist. The impeller has side-side and fore-aft movement, so i think I'll be rebuilding it.

this is from someone not running a filter?

Not sure how well that picture shows it. Is this anything i should be concerned with, or just roll with it, since it's a $100 turbo?
It's a journal bearing turbo. It's going to have play until it has oil pressure.

Probably or just a shitty filter who knows with those skidracers.

You should be good to run it as is. Rebuilds are always nice though.
Impuls is offline   Reply With Quote
Old 04-01-2014, 02:23 AM   #22
Newb
Thread Starter
iTrader: (1)
 
Join Date: Jan 2014
Location: WA
Posts: 38
Total Cats: 25
Default

Quote:
Originally Posted by Impuls View Post
It's a journal bearing turbo. It's going to have play until it has oil pressure.

Probably or just a shitty filter who knows with those skidracers.

You should be good to run it as is. Rebuilds are always nice though.
As cheap as rebuild kits are, I'll just do it for peace of mind. Plus it's nice tearing things open to see how they work.

Thanks for the input.
GtiKyle is offline   Reply With Quote
Old 04-08-2014, 10:31 AM   #23
Newb
Thread Starter
iTrader: (1)
 
Join Date: Jan 2014
Location: WA
Posts: 38
Total Cats: 25
Default

Small update:

MS build has started.


I've never soldered PCB components, but it's going pretty well. I thought i had one screw up on Q19. My soldering from the backside was kind of ugly. I probed it with my multimeter in continuity mode, and kept getting beeps, indicating a short. I assumed i had a solder bridge, so i spent some time repairing the area. After doing a bit of research, i learned that it will SEEM like there's short, however, you need to probe it for resistance, and it checked out at ~1ohm.



Like so many other builds I've done in the past, I've changed my mind on a few things already. Not the first, won't be the last. After seeing Westfields Alt control board, i decided to order it. Much cheaper than buying an NA alternator. Also waiting on a 122pin connector to show up, so i can continue to follow Franks instructions. His guide is a lifesaver!

Another change to the schedule; I'll likely be sending off the injectors to be professionally cleaned. Upon closer inspection, i doubt this injector was working properly, nor do i think i can clean it the redneck way and feel confident:

Attached Thumbnails
Another boring, unimaginative rip-off build.-20140401_200811_zps0c4b2d09.jpg   Another boring, unimaginative rip-off build.-20140407_171220_zps57855292.jpg   Another boring, unimaginative rip-off build.-20140401_161402_zps77f8e19b.jpg  
GtiKyle is offline   Reply With Quote
Old 04-20-2014, 08:14 PM   #24
Newb
Thread Starter
iTrader: (1)
 
Join Date: Jan 2014
Location: WA
Posts: 38
Total Cats: 25
Default

So the build has been going somewhat slow. I just got the ECU connector, but it needs to be modified.

Question for those that have built their own MS3:

Following the manual, step 24:

Quote:
Put the -ve probe of you're voltmeter on pin 32 of the 40pin connector (U1) Note, this is WITHOUT the CPU card in place!
Put the +ve probe onto pin 20 (Top pin right side)
Ensure you read 5V (+- 0.1V)
I'm getting 4.5V at pin 20. Is this an issue?

Continuing on, I'm getting 4.8V at the other pins, which is closer to what i would expect.
GtiKyle is offline   Reply With Quote
Old 04-22-2014, 02:49 PM   #25
Senior Member
iTrader: (2)
 
Join Date: Jun 2012
Location: New Braunfels,TX
Posts: 1,141
Total Cats: 51
Default

Try a different volt meter or recalibrate yours.
ScottyP3821 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 10-23-2016 08:58 AM
Mazdaspeed 2.0L C-Spec ITB motor w/ accessories graexodus Miata parts for sale/trade 9 10-25-2015 04:34 PM
New supertech pistons /wiesco xx rings HHammerly Miata parts for sale/trade 5 10-17-2015 07:53 AM
K&N Intake Filter nbdooey Miata parts for sale/trade 0 09-28-2015 09:46 PM
What happened to my Dynalite? midpack Suspension, Brakes, Drivetrain 18 09-22-2015 08:52 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:58 AM.