Harold's 1999 sport build - Page 2 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Build Threads Building a motor? Post the progress here.

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 01-30-2014, 06:00 PM   #21
Senior Member
 
Join Date: Apr 2011
Location: Martin, Slovakia
Posts: 513
Total Cats: 71
Default

Fantastic fabrication Harold. The hot parts are epic!
Just curious how you sorted the ps feed. Did you use a custom fitting or somehow adapt the existing one?
sturovo is offline   Reply With Quote
Old 01-30-2014, 06:54 PM   #22
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2007
Location: Brownsburg,IN
Posts: 799
Total Cats: 58
Default

I played arownd with that fitting and ended up cutting the bend out of it, making some an addaptors for the pump and reservoir are on my to do list for next winter when i get everithing ceramic coated if there are no cracks or other issues to deal with.
Attached Thumbnails
Harold's 1999 sport build-4343d6ef-0aed-4993-b7c8-9ca2d8049b1c_1.jpg  
HHammerly is offline   Reply With Quote
Old 03-25-2014, 10:53 PM   #23
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2007
Location: Brownsburg,IN
Posts: 799
Total Cats: 58
Default

HHammerly is offline   Reply With Quote
Old 03-25-2014, 11:05 PM   #24
Senior Member
iTrader: (4)
 
2manyhobyz's Avatar
 
Join Date: Feb 2011
Location: Joliet, IL
Posts: 622
Total Cats: 16
Default

Looks great!
Got it all dialed in yet?
2manyhobyz is offline   Reply With Quote
Old 03-25-2014, 11:38 PM   #25
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2007
Location: Brownsburg,IN
Posts: 799
Total Cats: 58
Default

Got all of 65 mi on the car and it was running pretty well when it was running but the MS2 enhanced kept loosing it's firmware so after many attempts by Dimitris to fix it, checking grounds, power and on and on I ended up sending it back to MS labs, he shipped an MS3 basic last week that I hope will not have issues.
Changed the oil, did a cold compression test (165 lbs on all 4 cylinders) moved the oils pressure sender and got the turbo heat shields and insulation on the intake during the last two months that the car has been sitting without an ECU.
I was planning to have it tuned by now...
HHammerly is offline   Reply With Quote
Old 03-26-2014, 01:40 AM   #26
Elite Member
iTrader: (12)
 
Join Date: Dec 2006
Location: Taos, New mexico
Posts: 5,680
Total Cats: 232
Default

Excellent build, goodluck with the MS issues!
Fireindc is offline   Reply With Quote
Old 03-31-2014, 09:32 PM   #27
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2007
Location: Brownsburg,IN
Posts: 799
Total Cats: 58
Default

I got an MS3 basic from MS Labs ( thank you Dimitris ) last friday and the car is running again, plan on installing the GM coils on sequential sometime next weekend and will start dialing EBC in etc.
Made a turbo-down pipe heat shield that seems to work pretty well so far.
Attached Thumbnails
Harold's 1999 sport build-39f92f98-6cfc-4e01-94b6-6bc568a65e49.jpg  
HHammerly is offline   Reply With Quote
Old 04-07-2014, 05:43 PM   #28
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2007
Location: Brownsburg,IN
Posts: 799
Total Cats: 58
Default

Little progress this weekend on the car, I finished installing the MS3 between the AC evaporator and the glove box

Also worked on getting an initial EBC tuning, rigged this led test light to come on when the boost controller solenoid got power and it made it easier to see at what RPM and throttle setting is was being energized, I think that I will install a permanent led by the boost gauge.
Attached Thumbnails
Harold's 1999 sport build-98673517-4143-4cb8-ab5e-05d75e383775.jpg   Harold's 1999 sport build-a58fed1e-cb6d-4702-95bd-a2b9daaa75e9_1.jpg  
HHammerly is offline   Reply With Quote
Old 04-20-2014, 09:25 AM   #29
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2007
Location: Brownsburg,IN
Posts: 799
Total Cats: 58
Default

I had the rear brakes installed for a week but I finished installing front brakes and bleeding the old fluid with some high temp Willwood fluid last night


Installed the 15x9 wheels and notice that the front wheels and tires rub the stock springs at full steering lock, I will put some spacers up front to get trough the fist autocross next weekend, I would like to see how it handles with the stock sport suspension (+ front away bar) before changing anything, if I am happy with the handling I will put a set of 2.5" springs of the same rate with coil over adjusters
Attached Thumbnails
Harold's 1999 sport build-c94838b0-39df-41de-8e45-e1db6be50bf4.jpg   Harold's 1999 sport build-6f3fb56d-54e3-47dc-9e47-fd8aa3614f50.jpg  

Last edited by HHammerly; 04-20-2014 at 10:53 AM.
HHammerly is offline   Reply With Quote
Old 04-28-2014, 09:04 AM   #30
Newb
 
Join Date: Jun 2012
Location: Zionsville, Indiana
Posts: 17
Total Cats: 0
Default

Drove HHammerly's 99 Sport on yesterdays Indy region autocross event. The car did very well considering it was the first time autocrossing, it only blew a small water line and had the accelerator pedal stuck on the carpet on one run.. Both problems on my runs, things that can easily get corrected. The 3.30:1 rear end should help make the gearing more useful, the 3.90:1 makes the second gear almost useless and the third ends up being too tall, at least on this small slippery course. A 4.30:1 would be better on third gear but would be stupid low on first and second. Should have some GoPro vids posted soon.

Last edited by gohammer; 04-28-2014 at 09:24 AM.
gohammer is offline   Reply With Quote
Old 04-28-2014, 09:56 PM   #31
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2007
Location: Brownsburg,IN
Posts: 799
Total Cats: 58
Default

Going over the car after the first outing, change hose that slipped out - check, look at the Trotottle to see why it stuck open ... I think I know why ... Time to install a throttle stop before gohammer drives it again LOL
Attached Thumbnails
Harold's 1999 sport build-1cd37228-fd8b-4eb2-bb39-f1a953b0563a.jpg  
HHammerly is offline   Reply With Quote
Old 04-29-2014, 08:54 AM   #32
Elite Member
iTrader: (3)
 
concealer404's Avatar
 
Join Date: Aug 2011
Posts: 8,235
Total Cats: 740
Default

Hey Harold did you ever hook up with Chris?

Glad to hear the car is moving well!

I'm going to try to make a couple events in the Miata this season after i somehow find time/space to do the suspension job on it, then we can have a 2554 vs. EFR glory throwdown in SSM!
concealer404 is offline   Reply With Quote
Old 04-29-2014, 10:54 AM   #33
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2007
Location: Brownsburg,IN
Posts: 799
Total Cats: 58
Default

I did hocked up with Chris, I was still having a few issues with the car then and wanted to get everithing working well before doing the dyno work (I cannot afford to be fixing things on the dyno) the other issue I have is that he does the dyno work Saturdays and I can only take off during weekdays or Sundays so well see how to go about getting it tuned.

Having you in SSM would be great fun, right now we have 3 to 5 cars in the class, and two are Turbo Miatas , hope you get your car done soon.
HHammerly is offline   Reply With Quote
Old 06-16-2014, 10:39 PM   #34
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2007
Location: Brownsburg,IN
Posts: 799
Total Cats: 58
Default

Have done a few autocross events on 10psi and the car is not having issues so it is finally going to get tuned tomorrow, will post some dyno sheets if it does not blow up LOL

Attached Thumbnails
Harold's 1999 sport build-ff3caa75-67b8-41e3-b686-173a60a43fa2.jpg   Harold's 1999 sport build-25838012-f07c-419f-90bb-8ff2910281fc.jpg  
HHammerly is offline   Reply With Quote
Old 06-16-2014, 11:16 PM   #35
Cpt. Slow
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,071
Total Cats: 511
Default

Do not tow it like that, unless you're going less than 35mph to the tuner's shop.

The engine will swing back there like a pendulum and it'll feel quite sketchy.
curly is offline   Reply With Quote
Old 06-18-2014, 01:00 PM   #36
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2007
Location: Brownsburg,IN
Posts: 799
Total Cats: 58
Default

Tuning whent well yesterday, nothing broke and ended up with 314HP 289TQ at 21.3 PSI 249HP 213TQ at 10.5 PSI
we could not get the boost table switching to work as expected but other than that it all was fine with the car,
It sure feels pretty lively at that power 😬
Attached Thumbnails
Harold's 1999 sport build-7f9353fc-9c69-4c7c-b516-8cce6303f704.jpg  
HHammerly is offline   Reply With Quote
Old 06-18-2014, 03:39 PM   #37
Senior Member
iTrader: (4)
 
2manyhobyz's Avatar
 
Join Date: Feb 2011
Location: Joliet, IL
Posts: 622
Total Cats: 16
Default

CONGRATS!
I'm sure "lively" is an understatement.
Is the EBC working like you want now?
-JB
2manyhobyz is offline   Reply With Quote
Old 06-18-2014, 06:42 PM   #38
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2007
Location: Brownsburg,IN
Posts: 799
Total Cats: 58
Default

Aaron got ebc working well on table 1 but could not get table 2 to work, boost will oscillate on that table regardless of having high or low boost, hope to get that figured out and fixed because I want to be able to run 240hp or 280hp with a flip of a switch on the dash...
Other than that the car is just great right now.




Attached Thumbnails
Harold's 1999 sport build-pulllogpuretunfinal6172014.jpg   Harold's 1999 sport build-puretunfinal6172014.jpg   Harold's 1999 sport build-ignitionpuretunfinal6172014.jpg  
HHammerly is offline   Reply With Quote
Old 06-18-2014, 08:27 PM   #39
Elite Member
iTrader: (3)
 
Join Date: Mar 2008
Location: Granbury, TX
Posts: 5,981
Total Cats: 576
Default

"Lively." Had to prop that. LOL.
hornetball is offline   Reply With Quote
Old 08-24-2014, 10:16 PM   #40
Senior Member
Thread Starter
iTrader: (3)
 
Join Date: Dec 2007
Location: Brownsburg,IN
Posts: 799
Total Cats: 58
Default

Well, after 2k mi i started to notice a little oil smell after romping on it, took the plugs to do a copm test and noticed a little oil on 3 and some more on 4, comp test was good but desided to take the motor out to take a look.
I found that the oil was coming from the PCV line on the intake manifold and the intake charge was blowing it to the rear cylinders hens the oil on 3 and 4.

Since the engine was out i desided to look at the pistons, rings etc. and found everithing looking good exept for the rood bearrings, it looks like i did not clean the crank oil galleys well enough be ause the mains looked OK
So i decided to have Stewart Engines (a local miata engine builder) build my spare bottom end with an 02 windage plate and oil pan for added stifness and some of his tricks.
While everithing is out i installed the Mazda long duration intake cam.

Hopefully the car will be up and runing soon
Attached Thumbnails
Harold's 1999 sport build-5c560190-aee6-42c4-bd42-5383d0361daa.jpg   Harold's 1999 sport build-746f64a1-c0c7-4b0a-8c9d-e21217baa43b.jpg   Harold's 1999 sport build-35cf9a88-e0d1-442e-a66b-22a367094959.jpg  
HHammerly is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
LucaCarMods's Boosted Dutch Miata Build! LucaCarMods Build Threads 11 02-14-2016 06:13 AM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 07:18 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 09:39 AM
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 10:59 PM
VR6 to Miata Swap ScrapinMX5 Meet and Greet 8 09-28-2015 01:04 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:23 PM.