I feel like an SRT4 (backfire) - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 04-03-2009, 06:49 PM   #1
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default I feel like an SRT4 (backfire)

NOOB DIY boost question:

I am tuning my car, it is a pretty rough tune right now. It is still very rich in boost. I am getting a lot of backfiring when i let off of the gas, even when i am just in cruise (anywhere between 13.5:1 and 15.5:1 cause my shitty tune). Is it just the Unburnt fuel ignighting in the exhaust? Its really not that cool, more annoying than anything and draws a lot of attention to my otherwise low key build. Will this go away as i tune my car?

Conditions:
******* rainy.... on and off pooring.
50*F
Sealevel... about 100 KPA ambient


Specs:
FM manifold and 2.5" DP (stainless)
Sr20 T25
Custom 3" catpipe (mild steel)
3" non res. enthuza exhaust (alumanized steel)
550cc injectors
megasquirt Hi-res. (no MAF)
240_to_miata is offline   Reply With Quote
Old 04-03-2009, 08:14 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,847
Total Cats: 1,788
Default

yes. unburnt fuel = afterfire when ignited.


tune your **** and active overrun.
Braineack is offline   Reply With Quote
Old 04-03-2009, 08:22 PM   #3
Elite Member
iTrader: (8)
 
Join Date: Aug 2007
Location: Bellingham, Wa
Posts: 2,732
Total Cats: 3
Default

No answer for you but how are you liking it all so far? Just got done going for my first top-off turbo drive. Got called *** car at a light by another car full of college kids. I wonder what was discussed in the car after I pulled away sounding like a jet taking off.

Also, how does that exhaust sound? I'm still debating on 2.5" vs 3".
wayne_curr is offline   Reply With Quote
Old 04-03-2009, 10:19 PM   #4
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

I love it all but i still need to work out the kinks.

I do have overun on.... it backfires durring overrun.

I have a HORRIBLE idle, its pretty rough off boost down in the low rpms...even got a missfire light on cyl 3 (flashing CEL)

I think i may have fouled a plug. I am going to pull the plugs 2morro and do a compression test too.
240_to_miata is offline   Reply With Quote
Old 04-04-2009, 01:38 AM   #5
Elite Member
iTrader: (17)
 
Join Date: May 2007
Location: NY
Posts: 1,614
Total Cats: 2
Default

Quote:
Originally Posted by wayne_curr View Post
Also, how does that exhaust sound? I'm still debating on 2.5" vs 3".
3" /end debate/
TonyV is offline   Reply With Quote
Old 04-04-2009, 01:54 AM   #6
Elite Member
iTrader: (2)
 
Join Date: Jun 2006
Location: ABQ, NM
Posts: 1,850
Total Cats: -8
Default

urlean
BenR is offline   Reply With Quote
Old 04-04-2009, 10:17 AM   #7
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

Quote:
Originally Posted by -Patrick- View Post
prolly so man
Patrick... Every single one of your ******* 28 posts are the most useless things i have ever read. stop responding with stupid phrases and start adding to the topic and quoting the things you are refrencing.

AKA: stop ******* trying to get ur post count up
240_to_miata is offline   Reply With Quote
Old 04-04-2009, 10:50 AM   #8
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

make sure you have the correct o2 sensor settings in MLV and the configurator. Watch the enrichments too because they must be adjusted with your huge injectors.

Aside from that, wtf is so difficult about tuning fuel?
hustler is offline   Reply With Quote
Old 04-04-2009, 10:51 AM   #9
meatbag
iTrader: (50)
 
gospeed81's Avatar
 
Join Date: Nov 2008
Location: Houston, TX
Posts: 7,357
Total Cats: 26
Default

I'm getting some of it too. Won a BMW VTPS the other day, hoping to fix some of it with that through accel/decel enrichments.
gospeed81 is offline   Reply With Quote
Old 04-04-2009, 11:20 AM   #10
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Quote:
Originally Posted by gospeed81 View Post
I'm getting some of it too. Won a BMW VTPS the other day, hoping to fix some of it with that through accel/decel enrichments.
You should be able to win without the vtps...my **** has worked fine on 2 different motors. Try by also pulling lots of fuel in the decel VE cells.
hustler is offline   Reply With Quote
Old 04-04-2009, 11:31 AM   #11
meatbag
iTrader: (50)
 
gospeed81's Avatar
 
Join Date: Nov 2008
Location: Houston, TX
Posts: 7,357
Total Cats: 26
Default

Quote:
Originally Posted by hustler View Post
You should be able to win without the vtps...my **** has worked fine on 2 different motors. Try by also pulling lots of fuel in the decel VE cells.
I can do that, but the thing is already on it's way...

For $30 plus shipping, and three wires to install, it's hard to lose on this deal.

I'm used to tuning Power Commanders on bikes by TPS, and using MAP based accel/decel enrichments seems like tuning off of an effect and not a cause. I understand that pressure change should be instantaneous, but we are talking about milliseconds here.

You're right though, I've got all kinds of stuff wacky with my tune. I'm so glad I got MS in nearly 6 weeks before I expected to see boost.

So you're saying just make the really low vac cells hella lean? I thought if it was too lean you could misfire, and then backfire the unburnt fuel...
gospeed81 is offline   Reply With Quote
Old 04-04-2009, 01:56 PM   #12
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

All problems solved.

A bad injector O ring on cylinder 3 wasnt allowing the fuel to vaporize correctly. therefor i was tuning the engine all weird cause the 3 cylinders were going lean but cyl 3 was dumping so much fuel that the wideband saw rich.

I solved this by pulling the plugs and seeing 3 white tips and one completely black tip. Threw in an old O ring from my stock injectors and it ran great. No more backfire or lumpy idle.

I also did a compression test and went to colder plugs. The test netted nice even results, but still low.

Full throttle on a warm engine w/ all plugs out for about 7-10 strokes : 170-175 on all 4 cylinders


Now i can tune like normal people (and yes hustler, tuning fuel is easy).
240_to_miata is offline   Reply With Quote
Old 04-04-2009, 02:02 PM   #13
meatbag
iTrader: (50)
 
gospeed81's Avatar
 
Join Date: Nov 2008
Location: Houston, TX
Posts: 7,357
Total Cats: 26
Default

I may need to check this out...

I've run nearly 50 datalogs on 3 different AFR tables, and still get VE table changes in the 5-10 range for every analysis.

Who'da thunk? Pull the plugs...now I feel dumb.

Of course I had ordered the injector O-ring/lower seal kits from O'Really's but when I went to pick it up they tried to hand me four INJECTORS, and couldn't locate the $7 kits I had ordered. Dumbasses, probably why I can't tune my car for ****.



Glad to hear you got it all fixed.
gospeed81 is offline   Reply With Quote
Old 04-04-2009, 02:59 PM   #14
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

anytime you are having engine issues you should check ur plugs!! lol.

definetly worth a try. wiggle the injectors with the engine running, see if it changes anything.
240_to_miata is offline   Reply With Quote
Old 04-04-2009, 04:42 PM   #15
I EAT CUM
iTrader: (6)
 
Join Date: Sep 2008
Location: Redneck, Texas
Posts: 1,218
Total Cats: -1
Default

I'm getting very, very loud backfires. Usually around third gear when letting off the gas it will gurgle a little then let out an extremely loud bang...reminds me of my old srt. I am running open downpipe so that could be why...I kind of like it though...brings me back.
Turbo_4 is offline   Reply With Quote
Old 04-04-2009, 04:58 PM   #16
Elite Member
iTrader: (8)
 
Join Date: Aug 2007
Location: Bellingham, Wa
Posts: 2,732
Total Cats: 3
Default

So did your leaky o-ring cause a hissing sound near the fuel rail? Since installing my 550s, i hear that and kinda just assumed that it was the new, larger injectors. This is just with the fuel pump on, engine doesn't have to be running.
wayne_curr is offline   Reply With Quote
Old 04-04-2009, 05:09 PM   #17
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

yeah a slight hissing sound. i wiggled the injector and it started pissing out fuel. It was the o-ring on the top...where it goes into the fuel rail.
240_to_miata is offline   Reply With Quote
Old 04-04-2009, 05:10 PM   #18
Elite Member
iTrader: (8)
 
Join Date: Aug 2007
Location: Bellingham, Wa
Posts: 2,732
Total Cats: 3
Default

Huh...is the hissing gone now?
wayne_curr is offline   Reply With Quote
Old 04-04-2009, 05:12 PM   #19
Hittin' Boost & Cones
Thread Starter
iTrader: (2)
 
240_to_miata's Avatar
 
Join Date: May 2007
Location: Cromwell, Connecticut
Posts: 2,572
Total Cats: 11
Default

yeah all i hear now is the sexy sound of big injectors clicking... and now with a pretty decent tune it PULLS nicely. Its at 7psi (just wastegate) but its creeping to 10 in hard 1-3 gear pulls.

I wanna turn up the boost and tune spark now, lol.
240_to_miata is offline   Reply With Quote
Old 04-04-2009, 05:17 PM   #20
Elite Member
iTrader: (8)
 
Join Date: Aug 2007
Location: Bellingham, Wa
Posts: 2,732
Total Cats: 3
Default

**** i gotta investigate this. I really dont want it to unexpectedly start pissing fuel.

Yea, i'm ready to start going beyond the wastegate pressure myself. Fuel is tuned in pretty well for mysetup...still quite rich but i'm not too upset with that.

Have you checked out your 4th gear spool data yet? Mine kinda sucks right now I think mostly because of my stock exhaust.
wayne_curr is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
1991 special edition with hard top full part out JC, NJ russian Miata parts for sale/trade 6 10-08-2015 04:01 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:45 AM.