my set-up - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 10-30-2007, 09:02 PM   #1
I'm Miserable!
Thread Starter
iTrader: (5)
 
bryantaylor's Avatar
 
Join Date: Dec 2006
Location: jacksonville, fl
Posts: 1,720
Total Cats: 0
Default my set-up

i know you guys are probally sick of seeing me start threads, but here is another.



sleeper intercooler?



details in sig. also open downpipe, and AEM wideband. i will summerize my problems again to see if anyone has any input. had the 310s in, ran ok, just crazy rich. 12.5-13 cruise. as soon as you lean into the throttle, peged out 10:1. put the stock injectors bad in, barley runs. doesnt want to idle unless the afm screw is all the way in, then stalls alot. anything more than 1/4 throttle and it starts missing and sputtering. but i think i found atleast one reason it sucking. the ECU plugs have a couple of coroded wires, and atleast 1 wire is broke, a blue wire IIRC. i will splice in some new plugs and see if it helps. and if not, try a new AFM and injectors. i opened the ecu, everything looked good inside.
bryantaylor is offline   Reply With Quote
Old 10-31-2007, 02:16 AM   #2
Elite Member
iTrader: (21)
 
paul's Avatar
 
Join Date: Jun 2006
Location: Point Pleasant, NJ
Posts: 2,957
Total Cats: 2
Default

interesting heatshield
paul is offline   Reply With Quote
Old 10-31-2007, 09:51 AM   #3
Elite Member
iTrader: (9)
 
TurboTim's Avatar
 
Join Date: Jun 2006
Location: Chesterfield, NJ
Posts: 6,482
Total Cats: 248
Default

I just threw away two license plates. I think they belonged to an old roommate.
TurboTim is offline   Reply With Quote
Old 10-31-2007, 10:10 AM   #4
Elite Member
iTrader: (2)
 
Join Date: Jan 2007
Location: Lexington, SC
Posts: 2,084
Total Cats: 0
Default

500th POST
bondo that crack in the bumper its already primered :gay:
and are you using a saab intercooler?
(nvm, saw it was a probe)
should you still wrap the lines around the turbo? because nothing is protecting the lines behind it
whoa and that isn't a piece of pvc on the hotside pipes is it?
mazda/nissan is offline   Reply With Quote
Old 10-31-2007, 10:13 AM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

aw, it's so cute, tiny intercooler and tiny turbo.


9,725 POST! oh shnap! I have no life.
Braineack is offline   Reply With Quote
Old 10-31-2007, 02:14 PM   #6
Elite Member
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

Does your car have a rattle can spray job? Pics if so.
Saml01 is offline   Reply With Quote
Old 10-31-2007, 03:01 PM   #7
I'm Miserable!
Thread Starter
iTrader: (5)
 
bryantaylor's Avatar
 
Join Date: Dec 2006
Location: jacksonville, fl
Posts: 1,720
Total Cats: 0
Default

its not rattle can, its actually sprayed satin black. and there is no pvc anywhere, but they are some couplers for pvc pipe from home depot. i only have 400-500 in the whole setup too.
bryantaylor is offline   Reply With Quote
Old 10-31-2007, 03:06 PM   #8
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

so does it idle? it doesn't seem like the idle valve has much of an air source :gay:
Braineack is offline   Reply With Quote
Old 10-31-2007, 03:17 PM   #9
I'm Miserable!
Thread Starter
iTrader: (5)
 
bryantaylor's Avatar
 
Join Date: Dec 2006
Location: jacksonville, fl
Posts: 1,720
Total Cats: 0
Default

Quote:
Originally Posted by Braineack View Post
so does it idle? it doesn't seem like the idle valve has much of an air source :gay:
a little low, but not bad. i still need to get something better for that
bryantaylor is offline   Reply With Quote
Old 10-31-2007, 07:46 PM   #10
I'm Miserable!
Thread Starter
iTrader: (5)
 
bryantaylor's Avatar
 
Join Date: Dec 2006
Location: jacksonville, fl
Posts: 1,720
Total Cats: 0
Default

fixed the IAC hose, idles better now. and spliced in a new ECU plug to replace the fuged up one. it helped a ton, still studders some. going to put in a rx7 AFM this weekend. i go 6 clicks counter clockwise on the clock spring for stock injectors, right? how many clicks which way for 310s? just want to be sure.
bryantaylor is offline   Reply With Quote
Old 11-01-2007, 01:48 PM   #11
Elite Member
iTrader: (2)
 
Join Date: Jan 2007
Location: Lexington, SC
Posts: 2,084
Total Cats: 0
Default

it should be in the faq
mazda/nissan is offline   Reply With Quote
Old 11-01-2007, 02:05 PM   #12
Junior Member
 
Join Date: May 2007
Posts: 119
Total Cats: 0
Default

hey how does that bov work for you i have the same one but haven't heart it yet?
mxdrift is offline   Reply With Quote
Old 11-01-2007, 04:29 PM   #13
I'm Miserable!
Thread Starter
iTrader: (5)
 
bryantaylor's Avatar
 
Join Date: Dec 2006
Location: jacksonville, fl
Posts: 1,720
Total Cats: 0
Default

Quote:
Originally Posted by mazda/nissan View Post
it should be in the faq
negative ghost rider

and the BOV works fine. just an ebay knock off, its a couple years old now. i was usuing it on my old probe too. everyone in the area knows your turbo when it goes off
bryantaylor is offline   Reply With Quote
Old 11-01-2007, 04:42 PM   #14
Elite Member
iTrader: (2)
 
Join Date: Jan 2007
Location: Lexington, SC
Posts: 2,084
Total Cats: 0
Default

oh, well i thought it was in the faq at one time, as for the clicks just go trial and error, i've heard goin 5 for a starting point and then from there fine tune it
mazda/nissan is offline   Reply With Quote
Old 11-01-2007, 05:12 PM   #15
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,833
Total Cats: 1,786
Default

there's no set point

iirc i was 3 clicks with the rx7 afm with 305s. 7-8 with 230s.
Braineack is offline   Reply With Quote
Old 11-01-2007, 07:36 PM   #16
I'm Miserable!
Thread Starter
iTrader: (5)
 
bryantaylor's Avatar
 
Join Date: Dec 2006
Location: jacksonville, fl
Posts: 1,720
Total Cats: 0
Default

10-4 man. i got a wideband, i will figure it out
bryantaylor is offline   Reply With Quote
Old 11-03-2007, 07:59 PM   #17
I'm Miserable!
Thread Starter
iTrader: (5)
 
bryantaylor's Avatar
 
Join Date: Dec 2006
Location: jacksonville, fl
Posts: 1,720
Total Cats: 0
Default

i think my car hates me. put in the rx7 afm, and tried another set up stock injectors. the AFRs are all over the place, it will just randomly go full rich, bog, studder, and so on. i will try the 310s again with only 3 clicks on the afm and see if it helps. could my ECU be ******* up?
bryantaylor is offline   Reply With Quote
Old 11-03-2007, 08:18 PM   #18
Junior Member
 
Join Date: May 2007
Posts: 119
Total Cats: 0
Default

nice on the bov.. i wanted one that would be really loud.haha but still perform good i want to upgrade to the hks ssq one hope fully when i get my car turbo.
mxdrift is offline   Reply With Quote
Old 11-05-2007, 05:45 PM   #19
I'm Miserable!
Thread Starter
iTrader: (5)
 
bryantaylor's Avatar
 
Join Date: Dec 2006
Location: jacksonville, fl
Posts: 1,720
Total Cats: 0
Default

ok, i have now decided that my car does in fact hate me. 310cc injectors, rx7 afm set at 3 clicks looser. and the car is still running like crap. pig rich at idle, started the car with the afm cover off, at idle its almost halfway open. i dont know what the deal is. i am thinking about just selling the FMU and AFM and going megasquirt. there is no reason the car should be running as bad as it is
bryantaylor is offline   Reply With Quote
Old 11-05-2007, 05:51 PM   #20
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Do it.
cjernigan is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Koni/GC/Eibach combo with spare springs hector Miata parts for sale/trade 1 08-31-2015 08:26 PM
AHHH E-manage, bandaids, ms whitemiata ECUs and Tuning 2 01-03-2010 10:25 PM
day n night railz DIY Turbo Discussion 33 06-22-2009 01:49 AM
1.8l turbo ?'s troy DIY Turbo Discussion 12 02-16-2009 03:40 PM
STILL having problems with the car bryantaylor DIY Turbo Discussion 4 11-28-2007 08:38 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:55 AM.