Narrowband Reads Wrong - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 08-14-2008, 07:04 PM   #1
Hear me Meow
Thread Starter
iTrader: (3)
 
skidude's Avatar
 
Join Date: Apr 2008
Location: Outside Portland Maine
Posts: 1,994
Total Cats: 13
Default Narrowband Reads Wrong

My narrowband has decided to stop reading rich. Ever.

it reads 14.7 a lot, and it reads lean a lot, but it never reads rich.

I know the car runs rich sometimes because I just switched to 460cc injectors from the stock 1.8 ones, and I started it once before I changed the req fuel. Still no rich reading. I also have played with settings to make it run really rich just to test the sensor, and still nothing.

Is the sensor dead, or is there a setting somewhere I accidentally changed that would cause this?

btw, I have an LC-1 but I can't find anybody to weld the bung into the stock exhaust without charging me an hour of labor, and I'm replacing the whole thing with a new exhaust soon anyway so I can't justify the expense.
skidude is offline   Reply With Quote
Old 08-14-2008, 07:05 PM   #2
Elite Member
iTrader: (1)
 
Join Date: Jun 2007
Location: VA, Germany, Afghanistan
Posts: 2,967
Total Cats: 3
Default

Wow, a narrowband that doesn't read right? who'd have ever thought?
KPLAFIN is offline   Reply With Quote
Old 08-14-2008, 07:08 PM   #3
Elite Member
iTrader: (21)
 
paul's Avatar
 
Join Date: Jun 2006
Location: Point Pleasant, NJ
Posts: 2,957
Total Cats: 2
Default

is the car turbo'd? or are you using the factory header in which the o2 bung is too close to the engine to swap the WB for NB?
paul is offline   Reply With Quote
Old 08-14-2008, 07:27 PM   #4
I'm Miserable!
iTrader: (5)
 
bryantaylor's Avatar
 
Join Date: Dec 2006
Location: jacksonville, fl
Posts: 1,720
Total Cats: 0
Default

Quote:
Originally Posted by KPLAFIN View Post
Wow, a narrowband that doesn't read right? who'd have ever thought?
i know, shocking
bryantaylor is offline   Reply With Quote
Old 08-14-2008, 07:29 PM   #5
Elite Member
iTrader: (4)
 
Join Date: Sep 2006
Location: Charlotte, NC
Posts: 3,049
Total Cats: 5
Default

this just in Russia invades Georgia!!
Efini~FC3S is offline   Reply With Quote
Old 08-14-2008, 08:43 PM   #6
Hear me Meow
Thread Starter
iTrader: (3)
 
skidude's Avatar
 
Join Date: Apr 2008
Location: Outside Portland Maine
Posts: 1,994
Total Cats: 13
Default

I know, I'm not excited that it's narrowband either.

Nope, not turboed yet. Stock header. I tried to get the old sensor out to stick the WB in there for a couple weeks until I put the new exhaust but the old one is too stuck. I broke a borrowed O2 removal tool in my attempts, so I gave up. It didn't even pretend it was interested in budging.

Looks like I'm sensorless until I go FI and have the correct sensor, eh?

What confused me is that it would read alright for a while, but then it just stopped reading rich, ever. I've been tuning off and on so I didn't know if I just changed some setting somewhere without noticing that it killed the reading or something. Guess I won't worry about it too much then. I'm running pretty rich everywhere right now I think. The plugs are pretty black. I don't really want to change anything with no feedback though.

Ugh. I hate living in a place with no decent shops. Honestly. An hour to weld in a bung? I don't even care if it leaks a little, since the whole exhaust is shot and I'm ripping it out in 2 weeks anyway.
skidude is offline   Reply With Quote
Old 08-14-2008, 09:35 PM   #7
Elite Member
iTrader: (21)
 
paul's Avatar
 
Join Date: Jun 2006
Location: Point Pleasant, NJ
Posts: 2,957
Total Cats: 2
Default

you want a free stock 94-97 without an o2 sensor stuck in it? you pay shipping.
paul is offline   Reply With Quote
Old 08-15-2008, 09:12 AM   #8
Hear me Meow
Thread Starter
iTrader: (3)
 
skidude's Avatar
 
Join Date: Apr 2008
Location: Outside Portland Maine
Posts: 1,994
Total Cats: 13
Default

Quote:
Originally Posted by paul View Post
you want a free stock 94-97 without an o2 sensor stuck in it? you pay shipping.
Thank you, but I think I won't bother. Between the shipping and the installation it's just more than I want to bother with. I ordered all the new exhaust pieces already it's just going to end up being a matter of when my friend can help me weld it all up.
skidude is offline   Reply With Quote
Old 08-15-2008, 09:35 AM   #9
Junior Member
iTrader: (1)
 
Join Date: Apr 2008
Location: Bristol
Posts: 442
Total Cats: 0
Default

I'll take it please, if its going.
Duckie_uk is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
Bizarre connection issue? nick470 MEGAsquirt 1 09-30-2015 11:32 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:55 PM.