No power at 2700 rpm sputter sputter HELP! - Page 2 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 01-19-2014, 10:03 PM   #21
Newb
Thread Starter
 
Join Date: Jan 2014
Posts: 18
Total Cats: -1
Default

Checked the wires they are good can't pull the plugs till I get to work tomorrow plug socket at work.
bajaboy169 is offline   Reply With Quote
Old 01-20-2014, 02:43 AM   #22
Newb
 
Join Date: Mar 2012
Location: SEBRING!
Posts: 9
Total Cats: -24
Default

Check everything related to ignition first. If it threw a coil code it's could be wiring, intermittent ecu issues, or other randomness.
miata25psi is offline   Reply With Quote
Old 01-20-2014, 11:51 AM   #23
Newb
Thread Starter
 
Join Date: Jan 2014
Posts: 18
Total Cats: -1
Default

plugs look great clean and tight at .032 reset the light cleaned the air filter. fired it up test drove. A little different now if I am easy on the throttle it responds good till around 4000 rpm. If I gun it half pedal it is missing and the engine light comes back on. #3 miss fire I pulled the plug again cleaned it unscrewed to cap on the plug 1/2 turn to insure good contact. reset the light test drove again same as described above.
bajaboy169 is offline   Reply With Quote
Old 01-20-2014, 11:57 AM   #24
Elite Member
iTrader: (5)
 
Erat's Avatar
 
Join Date: Oct 2011
Location: Detroit
Posts: 4,196
Total Cats: 260
Default

I think you found your problem. It seems to just have a misfire on #3.
Erat is offline   Reply With Quote
Old 01-20-2014, 12:39 PM   #25
Elite Member
iTrader: (17)
 
Join Date: Aug 2007
Location: Fort Myers, FL
Posts: 2,791
Total Cats: 129
Default

I'd bet that spending $8 on a new set of NGK BKR7E (part #4644) spark plugs would fix the problem.
pdexta is offline   Reply With Quote
Old 01-20-2014, 10:30 PM   #26
Moderator
iTrader: (11)
 
sixshooter's Avatar
 
Join Date: Nov 2008
Location: Tampa, Florida
Posts: 15,664
Total Cats: 1,560
Default

Fouled
sixshooter is online now   Reply With Quote
Old 01-27-2014, 11:23 AM   #27
Newb
Thread Starter
 
Join Date: Jan 2014
Posts: 18
Total Cats: -1
Default

Sorry had to go out of state for a while. Pulled the plugs they look great perfect gap good spark. Checked for leaks no leaks . next?
bajaboy169 is offline   Reply With Quote
Old 01-27-2014, 11:50 AM   #28
Moderator
iTrader: (11)
 
sixshooter's Avatar
 
Join Date: Nov 2008
Location: Tampa, Florida
Posts: 15,664
Total Cats: 1,560
Default

Plugs can look fine and be fouled. Buy plugs.
sixshooter is online now   Reply With Quote
Old 01-29-2014, 04:28 AM   #29
Newb
Thread Starter
 
Join Date: Jan 2014
Posts: 18
Total Cats: -1
Default

Ok I have $10 I will get them when the snow melts in a day or two.
bajaboy169 is offline   Reply With Quote
Old 02-03-2014, 11:44 AM   #30
Newb
Thread Starter
 
Join Date: Jan 2014
Posts: 18
Total Cats: -1
Default

Sorry had to go to Texas, just got back. Alright different symptoms now when cold it runs great for 10 seconds then if I feather the throttle lightly it performs as it should including the turbo. If I gun it, it bogs down. Any suggestions on what it could be? I checked the wires and plugs Thanks
bajaboy169 is offline   Reply With Quote
Old 02-03-2014, 12:54 PM   #31
Moderator
iTrader: (11)
 
sixshooter's Avatar
 
Join Date: Nov 2008
Location: Tampa, Florida
Posts: 15,664
Total Cats: 1,560
Default

Fuel pump. Or metering problem.
sixshooter is online now   Reply With Quote
Old 02-06-2014, 10:43 PM   #32
Newb
Thread Starter
 
Join Date: Jan 2014
Posts: 18
Total Cats: -1
Default

No it doesn't lage at high rpm if I am light on the throttle
bajaboy169 is offline   Reply With Quote
Old 02-07-2014, 09:00 AM   #33
Junior Member
 
Join Date: Jan 2010
Location: Anderson, SC
Posts: 149
Total Cats: 6
Default

He's suggesting you may be getting enough fuel at idle, and with gentle throttle input, but when you give it more throttle input the stumble comes from there not being enough fuel getting introduced into the mixture.

Check fuel pressure when you're doing these throttle input experiments.

Last edited by sharkythesharkdogg; 02-07-2014 at 07:44 PM.
sharkythesharkdogg is offline   Reply With Quote
Old 02-07-2014, 03:19 PM   #34
Moderator
iTrader: (11)
 
sixshooter's Avatar
 
Join Date: Nov 2008
Location: Tampa, Florida
Posts: 15,664
Total Cats: 1,560
Default

And still change the ******* spark plugs even if you think they look fine.
sixshooter is online now   Reply With Quote
Old 02-08-2014, 02:59 AM   #35
Newb
Thread Starter
 
Join Date: Jan 2014
Posts: 18
Total Cats: -1
Default

Quote:
Originally Posted by sixshooter View Post
And still change the ******* spark plugs even if you think they look fine.
yes six shooter I change the f****** plugs!!!!
bajaboy169 is offline   Reply With Quote
Old 02-08-2014, 03:00 AM   #36
Newb
Thread Starter
 
Join Date: Jan 2014
Posts: 18
Total Cats: -1
Default

Thank you for all your help it turned out that I got a bad coil from the factory brought it back to advance auto parts replaced it with another new one and all is good.
bajaboy169 is offline   Reply With Quote
Old 02-09-2014, 09:38 PM   #37
Moderator
iTrader: (11)
 
sixshooter's Avatar
 
Join Date: Nov 2008
Location: Tampa, Florida
Posts: 15,664
Total Cats: 1,560
Default

Yay!
sixshooter is online now   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:18 PM.