DIY Turbo Discussion greddy on a 1.8? homebrew kit?
Sponsored by:
Sponsored by:

oil pressure issue/ turbo leaking/burning!

 
Old 08-21-2018, 06:27 PM
  #1  
Newb
Thread Starter
 
Join Date: Aug 2018
Location: Ventura CA
Posts: 23
Total Cats: -31
Default oil pressure issue/ turbo leaking/burning!

Sorry if this is a big multi-pieced question, normally I would normally just try to find a thread where someone has answered my question but I feel that I should involve myself in the community of the car I so dearly love. I'm having a few issues since I've installed my DIY turbo setup. The tricky part of all of this is that the TURBO, WASTEGATE, MANIFOLD, DOWNPIPE, BOV, & CATCH CAN, were all previously installed in my roomates 1.6l '92 before he literally flipped it in the local canyons. we both have slightly different versions of Megasquirt that we built. Both are 1.6L but ill get into the differences below.

MY SETUP:
ISR Performance T25
BEGI Manifold
Custom shop made downpipe w/o flexpipe
Turbo Smart Kompact BOV
Mishimoto IC


Some differences between his set up and mine:
HIS:
-had the pre-existing factory hi pressure oil feed on the exhaust side of the block. (US ENGINE)
-never ran the turbo without the BOV
-got up to 10 psi max with no ping no issues
The turbo ran perfectly for ~ 1k-3k miles until he flipped the car, then it went to mine.

MINE:
-my engine is a japanese import engine, no factory oil feed on exhaust side of block.
-had to run an oil filter sandwich with oil feed line for turbo.
-ran for ~500 miles without BOV before installing BOV
-encountering issues currently at 6psi

PROBLEM:
-Turbo is burning oil and smoking at idle after hitting any boost.
-Increased oil consumption. (~50mi drive consumed/burned ~1L of oil after fresh 10W-30 change, BOSCH filter. some filters lower oil pressure from what I've heard?)
-Oil pressure is at about 60psi on a cold start, 40psi at warm IDLE and if i get on the throttle at all it pretty quickly shoots up to 90psi by like 4k rpm

HYPOTHESIS:
#1 -running the turbo without a bov wounded some of the seals & so now oil is seeping past the seals & being burned?
#2 -the oil filter sandwich is somehow supercharging oil feed pressure? doesn't make any sense to me.. but ISR says not to run a -4an fitting to the turbo w/o an oil restrictor; both instructions my roommate apparently ignored, or maybe he thought his -4an to -3an fitting adapter was restricting oil pressure. either way, he was NOT having any issues when this was on his car.

SOLUTION(S):
-I ordered an oil restrictor banjo fitting (.060). hopefully this will solve my issue. But I have a feeling it won't, IF that doesn't fix the issue, what would you guys suggest I try to resolve the issue?
-If the restrictor doesn't help, should I rebuild the turbo for the guarantee of the seals being good?

Aaron

oil pressure issue/ turbo leaking/burning!-drifty.jpgoil pressure issue/ turbo leaking/burning!-turbo1.jpgoil pressure issue/ turbo leaking/burning!-turbo.jpgoil pressure issue/ turbo leaking/burning!-whoops-.jpgoil pressure issue/ turbo leaking/burning!-sale-.jpgoil pressure issue/ turbo leaking/burning!-brads-alive-.jpg
aaronrossta is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
aaronrossta
DIY Turbo Discussion
17
08-28-2018 02:19 PM
satisfied
Suspension, Brakes, Drivetrain
5
06-21-2015 10:34 AM
Dlaitini
MEGAsquirt
8
09-24-2013 09:34 PM
acusido2
General Miata Chat
2
11-17-2010 08:37 PM
Faeflora
General Miata Chat
18
08-24-2010 11:35 AM


Thread Tools
Search this Thread
Quick Reply: oil pressure issue/ turbo leaking/burning!


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.