Overboost Issue - Page 3 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 12-18-2013, 06:21 PM   #41
Elite Member
iTrader: (5)
 
Erat's Avatar
 
Join Date: Oct 2011
Location: Detroit
Posts: 4,201
Total Cats: 260
Default

Quote:
Originally Posted by ScottyP3821 View Post
No I searched "overboost"
Yeah. After going back and looking at my thread, everyone except for torque zombie gave me all the wrong ideas / answers.
Erat is offline   Reply With Quote
Old 12-18-2013, 07:53 PM   #42
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2012
Location: New Braunfels,TX
Posts: 1,141
Total Cats: 51
Default

If they made a ball bearing turbo for my application with a built in bov I'd be all over it. I did lots of searching them and I heard good things from the wrx and Nissan crowd. I just figured the wga was good as a lot of their turbos come with them. I already taken mine apart and it seems to be very high quality and very easily serviceable. Not to side track from the thread but I'm happy with especially considering the price of a garrett can replacement from BEGi.
ScottyP3821 is offline   Reply With Quote
Old 01-17-2014, 01:26 PM   #43
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2012
Location: New Braunfels,TX
Posts: 1,141
Total Cats: 51
Default

UPDATE** So my buddy already has the tools to port the WG. My question is while I have the FM header and 2560 apart is there anything else I should look into porting? Maybe something like this as well

Attached Thumbnails
Overboost Issue-37462d1201072683-ported-vs-stock-turbo-srt-4-neon-turbo-port-work-002.jpg  
ScottyP3821 is offline   Reply With Quote
Old 01-17-2014, 02:22 PM   #44
Senior Member
 
Join Date: Dec 2010
Location: Auckland, NZ
Posts: 783
Total Cats: 23
Default

I may be wrong but my guess is that was done with a machine of some sort....

edit: maybe not, it's not as perfectly round as i first thought BUT i would say whoever did that was pretty experienced...
mx5-kiwi is offline   Reply With Quote
Old 01-17-2014, 04:02 PM   #45
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2012
Location: New Braunfels,TX
Posts: 1,141
Total Cats: 51
Default

I think I will focus on porting the waste gate first and if I have enough confidence I may attempt it.
ScottyP3821 is offline   Reply With Quote
Old 01-17-2014, 08:08 PM   #46
Elite Member
iTrader: (5)
 
Erat's Avatar
 
Join Date: Oct 2011
Location: Detroit
Posts: 4,201
Total Cats: 260
Default

Yes.

I ported everything hotside on my setup. It wasn't any huge gains, but i could tell a bit of difference from the butt dyno.











I'm almost positive i have before and after photos in my build thread.
Attached Thumbnails
Overboost Issue-dsc04283.jpg   Overboost Issue-dsc04280.jpg   Overboost Issue-dsc04275.jpg   Overboost Issue-dsc04274.jpg  
Erat is offline   Reply With Quote
Old 01-19-2014, 05:32 PM   #47
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2012
Location: New Braunfels,TX
Posts: 1,141
Total Cats: 51
Default



So I ported my wastegate and it helped a ton. Especially after putting on my enthuza exhaust this week. Before porting with the new exhaust I was hitting 15psi @ 5k and would hit my overboost before going higher. Now I hit 10 psi but experience slight drop in boost momentarily when digging out of 3 or in 4. It will go from 10 than 6 then crawl it's way up to 10. I'm using out on a mbc and still no change. I'm wondering if I may need more preload on my wastegate actuator. Thoughts? Vacuum is good -21 at idle.
Attached Thumbnails
Overboost Issue-image.jpg  
ScottyP3821 is offline   Reply With Quote
Old 01-19-2014, 05:38 PM   #48
Elite Member
iTrader: (5)
 
Erat's Avatar
 
Join Date: Oct 2011
Location: Detroit
Posts: 4,201
Total Cats: 260
Default

Where is the boost controller hooked up? Is it a good boost controller?
Erat is offline   Reply With Quote
Old 01-19-2014, 06:06 PM   #49
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2012
Location: New Braunfels,TX
Posts: 1,141
Total Cats: 51
Default

Quote:
Originally Posted by Erat View Post
Where is the boost controller hooked up? Is it a good boost controller?
It's a turbo smart boost t and it's routed between the wastegate and compressor. And mounted on my intake heat sheild. Very short amount of vaccum line.
ScottyP3821 is offline   Reply With Quote
Old 01-19-2014, 06:11 PM   #50
Elite Member
iTrader: (5)
 
Erat's Avatar
 
Join Date: Oct 2011
Location: Detroit
Posts: 4,201
Total Cats: 260
Default

Take off the MBC and run the vacuum line straight from the intake manifold to the WG. See what that does. If things work, reattach the boost controller, see what it does. If no change then you can move on to other things.
Erat is offline   Reply With Quote
Old 01-19-2014, 06:24 PM   #51
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2012
Location: New Braunfels,TX
Posts: 1,141
Total Cats: 51
Default

So cap the compressor vaccum fiiting and run a line from wastegate to throttle body. Then if it goes away run the mbc between the intake manifold and wastgate and see where I stand?

I read in the wiki about this but haven't been led to do so.
ScottyP3821 is offline   Reply With Quote
Old 01-19-2014, 06:33 PM   #52
Elite Member
iTrader: (5)
 
Erat's Avatar
 
Join Date: Oct 2011
Location: Detroit
Posts: 4,201
Total Cats: 260
Default

Yeah. That's what everyone says to do...
Erat is offline   Reply With Quote
Old 01-19-2014, 06:52 PM   #53
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2012
Location: New Braunfels,TX
Posts: 1,141
Total Cats: 51
Default

Ok cool thanks Dillon. I'll be trying this tonight. I saw it on the wiki but didn't follow it as some of the stuff I have followed in the past was incorrect.
ScottyP3821 is offline   Reply With Quote
Old 01-20-2014, 01:05 AM   #54
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2012
Location: New Braunfels,TX
Posts: 1,141
Total Cats: 51
Default

We'll so I just got back and took a log and it looks like I peaked at 11.5psi at 46 deg outside with MAT temps in the 50. That was with vaccum line ran from intake to wastegate and no bc. I didn't noticed the dips in boost as much but they were there barely. If anything now it's not really fluctuations as it is lag. I'll put the mbc on tomorrow and see how it goes. I have a diy ebc solenoid but that was a bitch to try and tune last time I tried then again that was around the time I killed my old clutch.
ScottyP3821 is offline   Reply With Quote
Old 01-20-2014, 02:37 AM   #55
Newb
 
Join Date: Mar 2012
Location: SEBRING!
Posts: 9
Total Cats: -24
Default

Excessive carbon buildup combined with airflow inconsistencies will deffinately do it.
miata25psi is offline   Reply With Quote
Old 01-20-2014, 09:46 AM   #56
Senior Member
Thread Starter
iTrader: (2)
 
Join Date: Jun 2012
Location: New Braunfels,TX
Posts: 1,141
Total Cats: 51
Default

Quote:
Originally Posted by miata25psi View Post
Excessive carbon buildup combined with airflow inconsistencies will deffinately do it.
Wth do you mean. I'm not following you.
ScottyP3821 is offline   Reply With Quote
Old 01-20-2014, 10:10 AM   #57
Elite Member
iTrader: (5)
 
Erat's Avatar
 
Join Date: Oct 2011
Location: Detroit
Posts: 4,201
Total Cats: 260
Default

I think that's a spam bot.
Erat is offline   Reply With Quote
Old 01-20-2014, 01:11 PM   #58
Destroyer of Inconel
iTrader: (37)
 
EO2K's Avatar
 
Join Date: Apr 2010
Location: In ur driveway, abusin' ur WPA
Posts: 9,642
Total Cats: 954
Default

Post TB source seems like a bad idea, at least according to the logic dropped by Mr Perez: https://www.miataturbo.net/diy-turbo...eed-ebc-47532/

Yes I know that thread is about sag, but the post IC pre TB location seems like a solid idea as long as you are trying things out. Can't hurt anyway
EO2K is offline   Reply With Quote
Old 01-20-2014, 03:49 PM   #59
Junior Member
iTrader: (1)
 
Meeners's Avatar
 
Join Date: Jul 2008
Posts: 194
Total Cats: 0
Default

These are just the situational woes with internally gated setups. It's simple and dependable (especially for low boost), but it's tough to get a precise boost balance/control when in high and low exhaust flow situations without creep up top with all the variable factors and turning it up.

Usually in the winter I have had to turn boost down on previous cars... I usually just dealt with it and set it when it was cold and left it alone and ran lower levels when warmer on my daily. I had a lot of issues with a t28 and a new forge internal actuator for a long while... so I said eff it.

If electronic boost control isn't in your future, Have you looked into going externally gated in the future? I admit I got sucked into EBC's a few years back, but ive had good luck with tial in the past. I don't really see guys running external gate on the smaller frame turbos, but this year I'm running an off brand ewg for the miata and going to see how it does on the 2560r. Just welded the flap shut and discarded all the internal gate stuff.

Meeners is offline   Reply With Quote
Old 01-20-2014, 03:54 PM   #60
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,206
Total Cats: 2,587
Default

you're gonna wanna brace that if you want it to not crack off
18psi is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
Bizarre connection issue? nick470 MEGAsquirt 1 09-30-2015 11:32 PM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:24 AM.