Post your warm oil pressures - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 04-10-2010, 10:02 PM   #1
Want fries with that?
Thread Starter
iTrader: (3)
 
Join Date: Oct 2009
Location: Twin Cities, Minnesota
Posts: 2,023
Total Cats: -1
Default Post your warm oil pressures

Just installed my gauge and I'm wondering if it's not reading correctly, given my results.

Idle: 19-21psi
2,000: 30psi
4,000+ just sticks at 41 (occasionally changes), which is why I think there's something wrong. Well, there IS something wrong, if it's just sticking at 41.

Any advise, or is this normal (which I doubt)?

EDIT: Even though my old oil pressure connector thing isn't hooked up to anything, it's still a bit more than halfway up my gauge. WTF?

Last edited by rider384; 04-10-2010 at 11:33 PM.
rider384 is offline   Reply With Quote
Old 04-10-2010, 10:45 PM   #2
Junior Member
iTrader: (1)
 
Join Date: Aug 2008
Location: Granada, Spain
Posts: 336
Total Cats: 2
Default

idle 30psi warm - 20 psi hot

3000+ 60 psi warm - 50-55 psi hot
ismael_pt is offline   Reply With Quote
Old 04-10-2010, 11:34 PM   #3
Junior Member
iTrader: (2)
 
Join Date: Oct 2007
Location: Lisle, IL
Posts: 296
Total Cats: 0
Default

Quote:
Originally Posted by ismael_pt View Post
idle 30psi warm - 20 psi hot

3000+ 60 psi warm - 50-55 psi hot
Just about identical on my '90...a little bit higher hot at highway cruise (4K-4.5K).

OP, FWIW my readings are based on the '90 OEM gauge, I have never bothered to hookup a mechanical gauge to verify the accuracy of the OEM electric gauge. What sort of gauge are you using that is "sticking" at 41psi?? Have you checked your car with a know good mechanical gauge?
sn95 is offline   Reply With Quote
Old 04-11-2010, 08:46 AM   #4
I'm Miserable!
 
Join Date: Jun 2009
Location: albany, ga
Posts: 1,869
Total Cats: 3
Default

Quote:
Originally Posted by rider384 View Post
Just installed my gauge and I'm wondering if it's not reading correctly, given my results.

Idle: 19-21psi
2,000: 30psi
4,000+ just sticks at 41 (occasionally changes), which is why I think there's something wrong. Well, there IS something wrong, if it's just sticking at 41.

Any advise, or is this normal (which I doubt)?

EDIT: Even though my old oil pressure connector thing isn't hooked up to anything, it's still a bit more than halfway up my gauge. WTF?
you getting the results from the stock oil pressure guage? iirc after a certain year its no longer a true pressure guage and just more of a dummy light,

Try cleaning off any electrical connections that maybe dirty at the sensor.
Techsalvager is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Moroso Air Oil Separator Catch Can Aroundcorner Miata parts for sale/trade 2 10-01-2015 04:20 PM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:18 AM.