Power lag between Gear Shifts - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 12-20-2014, 03:02 PM   #1
Senior Member
Thread Starter
 
Join Date: Dec 2010
Location: Auckland, NZ
Posts: 783
Total Cats: 23
Default Power lag between Gear Shifts

Just looking for some suggestions and thoughts....

I seem to have a small micro lag when I change gear....it feels like 1/2 a second of nothing but in reality is probably much less but still noticeable...

I have looked at logs and boost drops inline with throttle and comes back on again to the same value it was before so I don't "think" it is a boost/spool issue....and the time lag between re applying throttle and boost returning on the graph seems minuscule.

Is this something that the blow off valve could be affecting?

Too big perhaps?

Would a recirculating BV help with this type of issue?

I have accel enrichment off in the ecu but figure at the 5k rev range i'm operating in this shouldn't be the issue.....

Perhaps this is just normal for a 14-16 psi boosted 1600cc engine?

Please note this is only apparent on track/racing etc. It is there on the road too (only once I felt the problem on track) but not noticeably a problem...where any throttle at that boost is WAY too much for the environment when 100% accelerating between gears like that

Any thoughts or suggestions?
mx5-kiwi is offline   Reply With Quote
Old 12-20-2014, 04:51 PM   #2
Elite Member
iTrader: (3)
 
Join Date: Mar 2008
Location: Granbury, TX
Posts: 6,010
Total Cats: 583
Default

Can you post a log of parameters vs. throttle position? Like MAP vs. TP, etc.
hornetball is online now   Reply With Quote
Old 12-20-2014, 06:57 PM   #3
Senior Member
Thread Starter
 
Join Date: Dec 2010
Location: Auckland, NZ
Posts: 783
Total Cats: 23
Default

Unfortunately my usb cable and ports are a bit finicky so getting decent logs from the ms2 is a pain....

Which, by the way, I would like to see someone's solution for....a screw in rs232 / VGA type plug for USB would be much better....professional even!

I can post up graphs of each as recorded by the AIM EVO4 unit though?

Last edited by mx5-kiwi; 12-20-2014 at 11:21 PM.
mx5-kiwi is offline   Reply With Quote
Old 12-21-2014, 04:45 AM   #4
Senior Member
Thread Starter
 
Join Date: Dec 2010
Location: Auckland, NZ
Posts: 783
Total Cats: 23
Default

not sure if this is going to help......
Attached Thumbnails
Power lag between Gear Shifts-datalog-gear-changing-up.jpg  
mx5-kiwi is offline   Reply With Quote
Old 12-21-2014, 04:45 AM   #5
Senior Member
Thread Starter
 
Join Date: Dec 2010
Location: Auckland, NZ
Posts: 783
Total Cats: 23
Default

Unlikely, too low a resolution from the file size limitation.
mx5-kiwi is offline   Reply With Quote
Old 12-21-2014, 10:35 AM   #6
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,899
Total Cats: 1,792
Default

lack of tuning.
Braineack is offline   Reply With Quote
Old 12-21-2014, 01:42 PM   #7
Elite Member
iTrader: (3)
 
Join Date: Mar 2008
Location: Granbury, TX
Posts: 6,010
Total Cats: 583
Default

Well, I zoomed into that graphic and eyeballed the best I could (which was pretty hard). I don't see what you're complaining about. The best example is the throttle application around 0.06 seconds (I was looking for a throttle event that went to 100%TP and I'm assuming what's on the bottom is in seconds). Time lag from closed throttle to minimum MAP is:

.058 - .056 = .002

Time lag from open throttle to full MAP (including some respool time) is:

.067 - .064 = .003

Not sure what the main loop speed is for the MS2, but .002 seconds is 50Hz which is a pretty common main loop speed for embedded devices. Bottom line, data doesn't show any lag whatsoever.

If you want quicker power application after a shift, maybe you should try the flatshift feature?
hornetball is online now   Reply With Quote
Old 12-21-2014, 01:45 PM   #8
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,199
Total Cats: 2,584
Default

Quote:
Originally Posted by Braineack View Post
lack of tuning.
this

throttle tip in, accel enrichments, poorly tuned ve table, injector dead times, etc etc etc all have potential to lead to the symptoms you're describing.

You'll need to post the tune file and proper logs if you want any help at all.
18psi is offline   Reply With Quote
Old 12-21-2014, 02:05 PM   #9
Senior Member
Thread Starter
 
Join Date: Dec 2010
Location: Auckland, NZ
Posts: 783
Total Cats: 23
Default

Thanks Hornetball for trying. This is the problem, it really doesn't show up on the graph at all, what is felt when driving. In fact the graph was a real shock to me, I thought it was going to stand out like dogs *****.

Brain, 18psi. Will post the msq and try and get a log together.

You won't believe the issues we dealt with that day, the knock retard kept ramping up, had a misfire, water temp starting climbing, a bad set of plugs with serious misfire ....all on a loan engine.

Trying to resolve the USB plug staying in the port was low on the agenda at that point.

But is a serious requirement now....with 2 big meetings coming up. A 3 day Meting at Taupo A1 track on 9-11 Jan which I entered our National Superlap competition in addition to the Classic Japanese we normally run.

Our Superlap runs a street, pro street (with Cages) i.e us and then Pro. From looking at the times we have a chance to place in Pro Street, especially if any one has a problem (which they seem to do regularly...)

And we got accepted to run at Rod Millen's (of Pikes Peak Fame) 3 day Leadfoot festival, which is a huge display, show and competition up his 1 mile long purpose built "driveway".....sort of our southern hemisphere equivalent of Brooklands etc.

Anyway, your guys help is much appreciated.
mx5-kiwi is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 10-23-2016 08:58 AM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:09 AM.