Standalone options for '99 NB? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 03-23-2008, 03:04 AM   #1
Senior Member
Thread Starter
 
Join Date: Jun 2005
Location: WA
Posts: 500
Total Cats: 0
Default Standalone options for '99 NB?

Alright so I got my new engine in and it just doesn't want to run the way I want it, especially idle and low throttle, my current engine management is EMU with 550cc injectors and FM dual feed fuel rail. And I'm running a built engine with ETD racing rods and JE 9:1 CR pistons, stock cams though. So I'm thinking I need a standalone ecu. What do you guys think I should be saving up for AEM, hydra, maybe even megasquirt? Are there any other ones available?

Or help me get those 550's under control with my EMU, would actually prefer this option
RusMan is offline   Reply With Quote
Old 03-23-2008, 03:11 AM   #2
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

I can help you with a MS for your 99 if it comes down to that. Hopefully some EMU people can help you out though. Otherwise I think you're off to the world of Hydra, Tec, Motec and other bajillion dollar EMSs.
cjernigan is offline   Reply With Quote
Old 03-23-2008, 03:29 AM   #3
Guest
 
Join Date: Apr 2005
Posts: 28
Total Cats: 0
Default

Quote:
Originally Posted by RusMan View Post
Alright so I got my new engine in and it just doesn't want to run the way I want it, especially idle and low throttle, my current engine management is EMU with 550cc injectors and FM dual feed fuel rail. And I'm running a built engine with ETD racing rods and JE 9:1 CR pistons, stock cams though. So I'm thinking I need a standalone ecu. What do you guys think I should be saving up for AEM, hydra, maybe even megasquirt? Are there any other ones available?

Or help me get those 550's under control with my EMU, would actually prefer this option
I use a sds-em4f from sdsefi.com ('99 engine)
sergei is offline   Reply With Quote
Old 03-23-2008, 02:00 PM   #4
Senior Member
 
Join Date: Nov 2005
Location: Baltimore Maryland
Posts: 1,010
Total Cats: 8
Default

My hydra is nice, but a bit funny at times. The software hates windows vista (though I found a fix for that), and my cold starts have been a PITA.
airbrush1 is offline   Reply With Quote
Old 03-23-2008, 05:23 PM   #5
y8s
2 Props,3 Dildos,& 1 Cat
iTrader: (8)
 
y8s's Avatar
 
Join Date: Jun 2005
Location: Fake Virginia
Posts: 19,037
Total Cats: 406
Default

a megasquirt at least has the support of everyone here. an sds will be a rare thing to see on a miata.
y8s is offline   Reply With Quote
Old 03-23-2008, 05:24 PM   #6
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,793
Total Cats: 247
Default

I'm running MS II piggyback, but could just as well be running standalone. AbeFM runs MS II piggyback, and so does Arga.
patsmx5 is offline   Reply With Quote
Old 03-23-2008, 07:12 PM   #7
Senior Member
Thread Starter
 
Join Date: Jun 2005
Location: WA
Posts: 500
Total Cats: 0
Default

I kinda want to stay with a piggyback because I need to pass OBDII inspection. what are you controlling with your megasquirt patsmx5? fuel and timing? What injectors are you running with it.

I have 550cc injectors and I've tried almost everything I can think off and I just can't get them to idle properly, can't bring the idle lower than 1800rpm and sometimes it just starts jumping from 1200 to 1800 randomly, kinda like rotaries do sometimes. Do you guys think it's the injectors or some mechanical problem that I'm having?
RusMan is offline   Reply With Quote
Old 03-23-2008, 07:23 PM   #8
Elite Member
iTrader: (15)
 
patsmx5's Avatar
 
Join Date: Aug 2007
Location: Houston, TX
Posts: 8,793
Total Cats: 247
Default

Correction, me and Arga run piggyback, AbeFM runs his standalone. Anyway...

Right now my MSII is running fuel and the cooling fans. I need to switch over to spark eventually. I'm running stock injectors right now. I'm gonna wire up two switches so I can switch fuel and spark control from "stock ecu" "off" or "MS II". If you did so, flip two switches and you can pass OBD II inspection.
patsmx5 is offline   Reply With Quote
Old 03-23-2008, 07:26 PM   #9
Senior Member
iTrader: (4)
 
Join Date: Aug 2007
Location: Omaha, NE
Posts: 619
Total Cats: 0
Default

Quote:
Originally Posted by airbrush1 View Post
My hydra is nice, but a bit funny at times. The software hates windows vista (though I found a fix for that), and my cold starts have been a PITA.
Second the wierdness with the Hydra. I never could find a fix to get it working with Vista so I am now dual booting with XP. What a pain. And my cold starts are rough as well. I find if I key on for a second or two without trying to start the car, it seems to help.
posidon42 is offline   Reply With Quote
Old 03-23-2008, 07:32 PM   #10
Elite Member
iTrader: (12)
 
Join Date: Sep 2007
Location: Charlotte, NC
Posts: 6,868
Total Cats: 66
Default

i have a Hydra in my car a love it. Now and then it runs rough for a second after a cold start...but it clears up within 1-2 seconds and thats it. I know it doesn't like to be fired up and then driven immidately...so i usually let it run for a few minutes before i take off anywhere.

I use a 2nd laptop just for tuning...running XP Pro....problem free!
Doppelgänger is offline   Reply With Quote
Old 03-23-2008, 09:05 PM   #11
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

My rx7 550s idle smooth at 13:1 running MSI with hi-res. No other fuel modifications done besides the injector swap.
If I had a good rear O2 sensor right now I could go pass OBDII inspection. You don't need to be able to switch back to the stock ECU, that would be a PITA swapping in stock injectors just to do that once a year or every two years. My OBDII codes scan just fine like they did before, cutting the wires for injectors and coils doesn't cause any issues that I know of.
What AFR are you trying to idle your 550s at? Are they RCs? Low or high impedance.
cjernigan is offline   Reply With Quote
Old 03-23-2008, 09:19 PM   #12
Senior Member
Thread Starter
 
Join Date: Jun 2005
Location: WA
Posts: 500
Total Cats: 0
Default

I have the plug and play 550cc red top injectors from rx7, I think they're high impedence, part number ending in 2020. I'm trying to stay at stoich ~14.7 but I can't get them to work at any afr, changes on the emu don't seem to do anything, I can hear the tone changing for a second but then it goes to crazy idle again, I really don't know what's going on. The factory screw that adjusts the idle doesn't seem to do anything, I turn it and it doesn't do anything, the car just dies when I go too far and that's it. I'll try to take a video of what I'm talking about. Could it be a bad 02 sensor?

This is a brand new engine so there might be something wrong with that but I checked all the connectors, checked for vacuum leaks and couldn't find anything wrong.
RusMan is offline   Reply With Quote
Old 03-23-2008, 09:38 PM   #13
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

I'll tell you right now that you wont get them to idle at 14.7, especially on an NB. Mine won't idle leaner than 13.5 without going to crap. Richen your idle and make sure you have it setup right for your injectors.

Sometimes I wish i knew the EMU, then I realize i'm very glad i never went that route.
cjernigan is offline   Reply With Quote
Old 03-24-2008, 12:04 AM   #14
Elite Member
iTrader: (15)
 
Join Date: Dec 2007
Location: San Antonio, Texas
Posts: 4,889
Total Cats: 28
Default

Quote:
Originally Posted by cjernigan View Post
I'll tell you right now that you wont get them to idle at 14.7, especially on an NB. Mine won't idle leaner than 13.5 without going to crap. Richen your idle and make sure you have it setup right for your injectors.
Same deal with me with my setup which is very close to Chad's: '99, turbo, MS hi-res, RX-7 550 injectors. I have to run rich at idle but since I do not drive in stop and go traffic much at all it is not a big deal for me.
ZX-Tex is offline   Reply With Quote
Old 03-24-2008, 12:23 AM   #15
Senior Member
Thread Starter
 
Join Date: Jun 2005
Location: WA
Posts: 500
Total Cats: 0
Default

I see, I'll try to make it a bit reacher and see if that helps any.
EMU has a setting where you type in the new injector size and it's supposed to do some adjustments for idle etc. but if I put in 550cc as the new size the car won't start when hot so I have to put in that I'm using 330's and work the maps from there, that also might be why I'm thinking.
RusMan is offline   Reply With Quote
Old 03-24-2008, 12:44 AM   #16
y8s
2 Props,3 Dildos,& 1 Cat
iTrader: (8)
 
y8s's Avatar
 
Join Date: Jun 2005
Location: Fake Virginia
Posts: 19,037
Total Cats: 406
Default

Quote:
Originally Posted by airbrush1 View Post
My hydra is nice, but a bit funny at times. The software hates windows vista (though I found a fix for that), and my cold starts have been a PITA.
Quote:
Originally Posted by posidon42 View Post
Second the wierdness with the Hydra. I never could find a fix to get it working with Vista so I am now dual booting with XP. What a pain. And my cold starts are rough as well. I find if I key on for a second or two without trying to start the car, it seems to help.
OT, sorry!

Use Jeremy's defaults if you dont already. Check his map against your: start primer, coolant temp trim, and cranking enrichment. Here's my most recent map. It starts fine in 20 degree weather. It's for 550cc injectors.
http://y8spec.com/nemesis/maps/20071121_warmupidle.s20

RusMan, the EMU may be trying to use too much cranking enrichment with it set to "550s" when it's hot. is there a way to back it down to about 60% of what it scales to? (330/550 = .60)
y8s is offline   Reply With Quote
Old 03-24-2008, 02:10 AM   #17
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Another small thing to take into account Rus is that those injectors are rated at 550, but many of the 550s flow more than that, and that is at like 43.5 psi of fuel pressure. We run more like 60-65 constant fuel pressure so we're more realistically running like 600cc injectors. Sorry i don't know more about the EMU and how it deals with fuel.
cjernigan is offline   Reply With Quote
Old 03-24-2008, 10:14 AM   #18
y8s
2 Props,3 Dildos,& 1 Cat
iTrader: (8)
 
y8s's Avatar
 
Join Date: Jun 2005
Location: Fake Virginia
Posts: 19,037
Total Cats: 406
Default

Chad, is the returnless fuel pressure really that high? do you have a gauge?
y8s is offline   Reply With Quote
Old 03-24-2008, 11:12 AM   #19
Guest
 
Join Date: Apr 2005
Posts: 28
Total Cats: 0
Default

Quote:
Originally Posted by y8s View Post
a megasquirt at least has the support of everyone here. an sds will be a rare thing to see on a miata.
You're right that it is not the most popular choice, but they (sdsefi.com) have an incredible support, and this setup is so easy to use...
Here is other projects with SDS:
http://sdsefi.com/features/july03miata.htm
http://sdsefi.com/features/aaron.htm
There is also couple tuners who use it on M.net.

I just love my SDS
sergei is offline   Reply With Quote
Old 03-24-2008, 11:23 AM   #20
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Quote:
Originally Posted by y8s View Post
Chad, is the returnless fuel pressure really that high? do you have a gauge?
I don't have a gauge and the info i posted is just what I have read from Corky and MarkP I believe, maybe just Corky.
Here is what the FSM is saying though.
cjernigan is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Toyota Pickup Engine Swap B.S. Monk Build Threads 24 12-11-2016 03:21 PM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
Looking for some EMS4 help E=MC^2 DIY Turbo Discussion 29 10-20-2015 01:03 AM
New to Miatas cheeseclock Meet and Greet 15 09-12-2015 09:53 AM
Project DDoS: '99 "Budget" boost build ProjectDDoS Build Threads 1 09-09-2015 02:52 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:29 AM.