Wierd spool issue. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


DIY Turbo Discussion greddy on a 1.8? homebrew kit?

Reply
 
 
 
LinkBack Thread Tools
Old 10-04-2012, 10:28 AM   #1
Junior Member
Thread Starter
iTrader: (1)
 
Sentic's Avatar
 
Join Date: Feb 2008
Location: Sweden
Posts: 435
Total Cats: 5
Default Wierd spool issue.

So, since I put my shanghai-s on I've had this wierd issue.

I suffer from slow spool, or rather, it spools to 3,5psi at 3000 rpm and then at 4500-5000 rpms it suddenly rises to 7 psi. 5th gear it is rather reluctant to get to 7psi, it likes to stay at about 5. Good vacuum on gauge when in idle/cruising.

AFR's are ~11.5 when flooring it, EMB, rx8 420s, divorced gases downpipe, t2856 churbo. Wastegate actuator is tight.

I'll be FMIC'ing it this weekend, but this ramping, jumping late spooling is so wierd I thought i would ask the pro's.

No ms because I had an e-manage and only have a power goal of 200-220rwhp.

Please help, This issue is confusing, is it as easy as a boost leak? Why then the different boost levels?
Sentic is offline   Reply With Quote
Old 10-04-2012, 10:34 AM   #2
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,174
Total Cats: 2,575
Default

1st do a boost leak test.
Then make sure the wga flapper moves freely and is not obstructed.
18psi is offline   Reply With Quote
Old 10-04-2012, 12:51 PM   #3
Hear me Meow
iTrader: (3)
 
skidude's Avatar
 
Join Date: Apr 2008
Location: Outside Portland Maine
Posts: 1,993
Total Cats: 13
Default

Is your target 3.5psi or 7psi? I can't imagine you're shooting for 3.5psi, but there are some strange people out there.

I would say it sounds like a leak at the wastegate, like it's not closing all the way. Just beacuse the actuator is tight doesn't mean the actual flapper is covering the hole. Also check for exhaust leaks, though one big enough to cause this issue would be pretty easy to hear I think.
skidude is offline   Reply With Quote
Old 10-04-2012, 03:55 PM   #4
Junior Member
Thread Starter
iTrader: (1)
 
Sentic's Avatar
 
Join Date: Feb 2008
Location: Sweden
Posts: 435
Total Cats: 5
Default

Sadly I dont have an air compressor, my first though was WG, I'll check the flapper during the weekend. Thanks.

Target 7psi, 12 on sunday
Sentic is offline   Reply With Quote
Old 10-04-2012, 04:23 PM   #5
Senior Member
 
Join Date: Apr 2011
Location: Martin, Slovakia
Posts: 513
Total Cats: 71
Default

I had a similar issue when my recirc valve was not holding at mid boost levels. The valve would start to recirc at about 5 psi and then close again at higher boost /rpm.
A different recirc valve fixed in my case.
sturovo is offline   Reply With Quote
Old 10-04-2012, 09:51 PM   #6
Junior Member
iTrader: (1)
 
Join Date: Apr 2011
Posts: 119
Total Cats: 1
Default

Quote:
Originally Posted by Sentic View Post
Sadly I dont have an air compressor, my first though was WG, I'll check the flapper during the weekend. Thanks.

Target 7psi, 12 on sunday
I do my boost leak tests using the air compressor at the gas station.
event is offline   Reply With Quote
Old 10-08-2012, 02:51 AM   #7
Junior Member
Thread Starter
iTrader: (1)
 
Sentic's Avatar
 
Join Date: Feb 2008
Location: Sweden
Posts: 435
Total Cats: 5
Default

Fixed this yesterday, seems like a sticking flapper in the wg was the issue, same as the problem levnubhin had.
However, this only showed when the car was hot.
Dremel - issue solved.
Sentic is offline   Reply With Quote
Old 10-17-2012, 11:45 AM   #8
Junior Member
Thread Starter
iTrader: (1)
 
Sentic's Avatar
 
Join Date: Feb 2008
Location: Sweden
Posts: 435
Total Cats: 5
Default

Apparently not completely solved (see spool thread) now higher thresholds, but stll not building boost consistently.

Going to check both wg again as well as try to disconnect the blow off valve to try to find the culprit.
Sentic is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
An Old Driver but a newbie in Miata Patriarca Meet and Greet 17 10-13-2015 02:34 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM
The "other" spool question stefanst DIY Turbo Discussion 44 09-28-2015 08:16 PM
MS3 Basic Connection Issues EErockMiata MEGAsquirt 6 09-24-2015 10:49 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:00 PM.