550 RX7 Injectors - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


E-Manage Post your questions about greddy e-manage installation and tuning here.

Reply
 
 
 
LinkBack Thread Tools
Old 03-23-2008, 06:16 PM   #1
Junior Member
Thread Starter
 
Join Date: Feb 2007
Location: Austria
Posts: 47
Total Cats: 0
Default 550 RX7 Injectors

Now, i have installed my new (used) RX7 injectors in my 91 Miata Turbo. I am running an EMU. So i have set up the size in the EMU. The AFR is about 14,7. But when the engine is getting warm, the idle is bad. The rpm changes up and down from 600 rpm to 900rpm. Is that normal?

Should i tune the lag time?
jonny is offline   Reply With Quote
Old 03-24-2008, 12:31 AM   #2
Senior Member
iTrader: (7)
 
Join Date: Mar 2005
Location: VT
Posts: 939
Total Cats: 0
Default

I don't have an EMU, But you might want to try richening up your idle AFR to 13.1-13.6.
Jefe is offline   Reply With Quote
Old 03-24-2008, 02:24 AM   #3
Junior Member
Thread Starter
 
Join Date: Feb 2007
Location: Austria
Posts: 47
Total Cats: 0
Default

That also not the solution I have already tryed AFR 13 at idle. The rpm also sways up and down. Somethimes from 500 - 900 rpm and a few sekonds later, only 700 - 800 rpm. When i step on the gas, the engine runs fine. Only at idle, the engine runs lumpy.

Has anyone he also the 550 RX7 with the number 195500 - 2020 with an EMU in his engine running? Please give me an answer.
jonny is offline   Reply With Quote
Old 03-24-2008, 03:01 AM   #4
Elite Member
iTrader: (13)
 
cjernigan's Avatar
 
Join Date: Oct 2006
Location: Atlanta, GA
Posts: 8,147
Total Cats: 6
Default

Do you have a vacuum leak?
Yes other people have used the -2020 550cc injectors with the EMU it is a semi-common setup.
cjernigan is offline   Reply With Quote
Old 03-24-2008, 03:43 AM   #5
Junior Member
Thread Starter
 
Join Date: Feb 2007
Location: Austria
Posts: 47
Total Cats: 0
Default

Quote:
Originally Posted by cjernigan View Post
Do you have a vacuum leak?
Yes other people have used the -2020 550cc injectors with the EMU it is a semi-common setup.
I donīt think so, with the 360cc injectors, it will run fine. Its only with the 550cc, when the engine is warm.
jonny is offline   Reply With Quote
Old 03-24-2008, 12:14 PM   #6
Senior Member
 
Join Date: Jun 2005
Location: WA
Posts: 500
Total Cats: 0
Default

I've got same 550s and even though I have '99 I'm having the same problems it seems, but my idle seems to jump from 1200 to 1800rpm. Check out my thread here:

https://www.miataturbo.net/forum/showthread.php?t=18672
RusMan is offline   Reply With Quote
Old 03-24-2008, 07:01 PM   #7
Junior Member
iTrader: (3)
 
Join Date: Apr 2007
Location: Charlottesville, VA
Posts: 177
Total Cats: 0
Default

did you tune your VE tables properly?
f1luva92 is offline   Reply With Quote
Old 03-24-2008, 07:02 PM   #8
Junior Member
iTrader: (3)
 
Join Date: Apr 2007
Location: Charlottesville, VA
Posts: 177
Total Cats: 0
Default

nevermind, i thought this was in the megasquirt section so ignore that last comment for i know NOTHING about e-managed
f1luva92 is offline   Reply With Quote
Old 03-24-2008, 10:40 PM   #9
Senior Member
iTrader: (2)
 
Join Date: Aug 2007
Location: North Cackalackey
Posts: 716
Total Cats: 2
Default

you have to play with your lag times and get them right. what is your before and after injector size? lag times?
musanovic is offline   Reply With Quote
Old 03-24-2008, 11:56 PM   #10
Senior Member
 
Join Date: Jun 2005
Location: WA
Posts: 500
Total Cats: 0
Default

I put in 280cc as before and 330cc as after injectors and richened the idle mixture to around 13.5 and it idles fine now. Try doing that.
RusMan is offline   Reply With Quote
Old 03-25-2008, 12:50 AM   #11
Senior Member
iTrader: (2)
 
Join Date: Aug 2007
Location: North Cackalackey
Posts: 716
Total Cats: 2
Default

Quote:
Originally Posted by RusMan View Post
I put in 280cc as before and 330cc as after injectors and richened the idle mixture to around 13.5 and it idles fine now. Try doing that.
just noticed you got two threads going lol . i got mine to work fine idles good i am thinking about getting 550's but dont have the money now
musanovic is offline   Reply With Quote
Old 03-25-2008, 04:37 PM   #12
Senior Member
 
Join Date: Jun 2005
Location: WA
Posts: 500
Total Cats: 0
Default

Well, I just posted my findings here to maybe help this guy out.
RusMan is offline   Reply With Quote
Old 03-25-2008, 05:15 PM   #13
Elite Member
iTrader: (39)
 
Zabac's Avatar
 
Join Date: Sep 2007
Location: High Point NC
Posts: 4,854
Total Cats: 8
Default

wie ghets jonny?
as musanovic says, you just need to play with the lag times until you get it right
Zabac is offline   Reply With Quote
Old 03-25-2008, 06:29 PM   #14
Junior Member
Thread Starter
 
Join Date: Feb 2007
Location: Austria
Posts: 47
Total Cats: 0
Default

Quote:
Originally Posted by musanovic View Post
you have to play with your lag times and get them right. what is your before and after injector size? lag times?
Quote:
Originally Posted by whaaamx5 View Post
wie ghets jonny?
as musanovic says, you just need to play with the lag times until you get it right
@whaaamx5: Danke, es geht mir gut!

You have right, the solution ist the lag time. I have tryed different lag times and now, the idle is much better. My lag settings are now ... 0.64 (before) and 0.74 (after). Now, the idle is in the area of 800 - 900 rpm.

Witch Lag settings do you use? Please post your lag settings here to draw a comparison.
jonny is offline   Reply With Quote
Old 03-25-2008, 07:14 PM   #15
Senior Member
 
Join Date: Jun 2005
Location: WA
Posts: 500
Total Cats: 0
Default

Hey, what did you put in for your before and after injector size?
RusMan is offline   Reply With Quote
Old 03-25-2008, 08:24 PM   #16
Junior Member
Thread Starter
 
Join Date: Feb 2007
Location: Austria
Posts: 47
Total Cats: 0
Default

Quote:
Originally Posted by RusMan View Post
Hey, what did you put in for your before and after injector size?
205 and 530
jonny is offline   Reply With Quote
Old 03-25-2008, 08:40 PM   #17
Senior Member
 
Join Date: Jun 2005
Location: WA
Posts: 500
Total Cats: 0
Default

Alright, I'll try using your settings, see how it runs
RusMan is offline   Reply With Quote
Old 03-25-2008, 11:29 PM   #18
Senior Member
iTrader: (2)
 
Join Date: Aug 2007
Location: North Cackalackey
Posts: 716
Total Cats: 2
Default

lag time is important as well. very important for idling. i am using .58 for lag time for 460cc idles good not perfect but good
musanovic is offline   Reply With Quote
Old 03-25-2008, 11:32 PM   #19
Senior Member
iTrader: (2)
 
Join Date: Aug 2007
Location: North Cackalackey
Posts: 716
Total Cats: 2
Default

Quote:
Originally Posted by RusMan View Post
Hey, what did you put in for your before and after injector size?
he has a 1.6 though . there is a difference there
musanovic is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 58 12-13-2017 10:04 PM
Changing from 460cc to flow force 610cc in diypnp 90 Turbo MEGAsquirt 19 10-19-2015 04:23 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 01:15 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 05:54 PM.