Emu not letting obd2 readiness set - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


E-Manage Post your questions about greddy e-manage installation and tuning here.

Reply
 
 
 
LinkBack Thread Tools
Old 02-29-2012, 07:05 PM   #1
Junior Member
Thread Starter
 
Join Date: Jan 2005
Location: Fort Worth, Texas
Posts: 242
Total Cats: -1
Default Emu not letting obd2 readiness set

Wont let egr, evap, or cat monitors set. Any suggestions? Reset egr and cat when I unplugged it but throws a p0171 lean code. I am n/a right now so no extra air is coming in. 2003 ls. Has a boomslang harness.
fwMiata is offline   Reply With Quote
Old 02-29-2012, 11:21 PM   #2
y8s
2 Props,3 Dildos,& 1 Cat
iTrader: (8)
 
y8s's Avatar
 
Join Date: Jun 2005
Location: Fake Virginia
Posts: 19,038
Total Cats: 407
Default

Here are the readiness requirements for each monitor to run (generally speaking).

Remember you can have one (or two depending on your state) that haven't run but all the rest MUST have run and you must not be displaying a check engine light.



You can look in the FSM for the OBDII drive cycle. It's a pain in the *** and very involved. It will take a day or two to fully run all the tests IF You do it by the book.
Attached Images
File Type: png obd2readiness.png (78.8 KB, 68 views)
y8s is offline   Reply With Quote
Old 03-01-2012, 12:08 AM   #3
Junior Member
Thread Starter
 
Join Date: Jan 2005
Location: Fort Worth, Texas
Posts: 242
Total Cats: -1
Default

kinda helpful. Like i said i got it to pass (one not ready in tx). But why is the emu not letting them set, but also not throwing a CEL? EMU shouldnt do anyhting with EGR, or EVAP, but I know CAT moniter has to set before those will.

I did the drive cycle a bunch of times and it never set. but as soon as it was unhooked, it set two (but threw cel for lean if i went over 3k rpms)

will a bad rear o2 sensor do this? it has a spliced in replacement one from sometime before I got it. (weak heater circuit that hasnt failed completely??
fwMiata is offline   Reply With Quote
Old 03-01-2012, 11:10 AM   #4
y8s
2 Props,3 Dildos,& 1 Cat
iTrader: (8)
 
y8s's Avatar
 
Join Date: Jun 2005
Location: Fake Virginia
Posts: 19,038
Total Cats: 407
Default

if the monitors aren't ready, they wont ever throw a code...

you're doing ALL of the drive cycles from the 2003 FSM?

If any of the sensors required are out of range, the ECU wont run the monitor.

Does the EMU connect to the MAF?

Having O2 sensors way out of range could be another issue.
y8s is offline   Reply With Quote
Old 03-01-2012, 05:26 PM   #5
Junior Member
Thread Starter
 
Join Date: Jan 2005
Location: Fort Worth, Texas
Posts: 242
Total Cats: -1
Default

Yes the whole drive cycle. Many times.I'm assuming that the maf is being controlled. I will have to pin alot the boomslang and see what all is. From what I have read the others won't set until the cat sets do I guess Ill start working through that system first. Any way to tell if the sensors are out of whack easily?
fwMiata is offline   Reply With Quote
Old 06-15-2012, 01:15 AM   #6
Junior Member
Thread Starter
 
Join Date: Jan 2005
Location: Fort Worth, Texas
Posts: 242
Total Cats: -1
Default

update. the primary o2 sensor was crapped out. replaced it and all the rediness set. and it runs better too...
fwMiata is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 10-23-2016 08:58 AM
Changing from 460cc to flow force 610cc in diypnp 90 Turbo MEGAsquirt 19 10-19-2015 04:23 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
WTB HPDE miata - Texas Voltwings Cars for sale/trade 0 09-27-2015 07:40 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:50 AM.