ECUs and Tuning Discuss Engine Management, Tuning, & Programming
Sponsored by:
Sponsored by:

1994 Miata misfire (video inside)

 
Old 11-20-2015, 05:34 PM
  #1  
Newb
Thread Starter
 
Join Date: Sep 2015
Posts: 14
Total Cats: 0
Default 1994 Miata misfire (video inside)

Stock Ecu, Mafs, injectors, etc

The car has done this since I owned it...... After sitting all night, when I start her up in the morning and start to drive her she will start to miss horribly just before becoming fully warmed up. She'll throw a tantrum for maybe 10-15 seconds and then she will idle/drive fine. The only other time she will start to miss out is when I give her more than 1/4 throttle..... The video doesn't show the cold miss since I had already driven her that day and she only does that after sitting over night. So far I've replaced:

Plugs NGK bkr7 @.025"
NGK blue wires
Coil packs
Swapped the CAS with one from a good running car
Checked/clean grounds in engine bay
fuel pressure gauge hooked up (pressure is steady during miss)
Wiggle all the wires/connectors
Check timing

The only codes the Ecu is throwing are for the egr and purge solenoids (previous owner removed and blocked off). I am curious if the stock Ecu will cut fuel if the Mafs reads too high of voltage or something???? From what I've read it doesn't. I have bigger injectors and an AEM but don't want to add those until I have a good running car with no issues.

Any ideas?


Last edited by nelson8708; 11-20-2015 at 05:48 PM.
nelson8708 is offline  
Old 11-20-2015, 08:26 PM
  #2  
Senior Member
 
Join Date: May 2007
Location: Atlanta
Posts: 657
Total Cats: 104
Default

Long video is long. So - to clarify - you're running a turbo with how much boost with stock injectors and ECU?

Sounds to me like whoever built it sold off the ECU/Injectors separate.

Honestly to me, it looks like it's just running out of fuel.

Edit: just to say - looking at the video, 1:16, you're hitting 15:1 AFR just as you're building boost.

Stop driving. Seriously. You're probably killing the engine.

Last edited by gooflophaze; 11-21-2015 at 08:34 AM.
gooflophaze is offline  
Old 11-21-2015, 09:05 PM
  #3  
Newb
Thread Starter
 
Join Date: Sep 2015
Posts: 14
Total Cats: 0
Default

All issues are happening out of boost. Seems like there are plenty of miatas out there running stock Ecu/injectors/mafs on 5ish psi and no issues..... I want to know why mine hits a wall before I even get into boost? Even more curious is why the car has a horrible miss for 10-15 seconds before becoming fully up to temperature......

I made/installed the turbo setup.... I'm not killing the engine yet, hard to do that while still showing vacuum on the gauge.
nelson8708 is offline  
Old 11-22-2015, 04:41 AM
  #4  
Senior Member
 
Join Date: May 2007
Location: Atlanta
Posts: 657
Total Cats: 104
Default

At 3:20ish - you're showing 19:1AFR before you can hear the audible breakup.

Wire the wastegate open - Despite your gauge, I'm fairly certain you're building boost. Granted, it's been awhile since I've driven an NA car but the acceleration sounds boosted to me.
gooflophaze is offline  
 
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
psyber_0ptix
Engine Performance
34
12-10-2016 08:51 PM
nigelt
Miata parts for sale/trade
22
12-20-2015 11:16 AM
slmhofy
Engine Performance
11
11-21-2015 03:36 PM
90 Turbo
Engine Performance
0
11-19-2015 11:21 AM


Thread Tools
Search this Thread
Quick Reply: 1994 Miata misfire (video inside)


Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.