after Link MK1 install quirks - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


ECUs and Tuning Discuss Engine Management, Tuning, & Programming

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 11-02-2008, 10:24 AM   #1
Newb
Thread Starter
 
Join Date: Nov 2008
Location: Newark, DE
Posts: 31
Total Cats: 0
Default after Link MK1 install quirks

hey all

so i just installed a link mk1 with mk2 upgrades it runs fine and everything

however i have 2 problems right now

1 - on the screen "IDLE" where the * and n are supposed to be shown, i only get the *....trying to figure out how and why its not there...it says in the manual the neutral switch isnt being read...i know there is one on the clutch, and one on the tranny....but neither are being read?

also the manual said it wont idle right or store without either the * and/or the n....but it idles and stores fine...should i be worried?

2 - when i rev out, any gear, when i hit 4000rpm i hit a CEL that stays solid until i get lower in the range....but it doesnt store so i cant check the code....anyone have any clues?

also remembered something small.....when i hit adjust up on the controller, it is supposed to show TEMP A and TEMP C....i only see TEMP C, where the hell is TEMP A?

car details: stock motor, just running the link as preparation to upgrade later
EOD-5 is offline   Reply With Quote
Old 11-02-2008, 12:32 PM   #2
Elite Member
iTrader: (5)
 
m2cupcar's Avatar
 
Join Date: Jan 2005
Location: Atlanta
Posts: 7,244
Total Cats: 291
Default

push the clutch in- do you get the *? yes - then it's just the trans, no - it's both

I wouldn't worry about the idle if you're happy. Make some changes, save and then shut down, repower and see if your changes are there. If they are, don't worry.

Not familiar with the CEL issue.

I don't run a keypad, I use an old palm 500 with the free plink software (linked in my sig). The advantages are numerous, but the disadvantage is it's hard to follow the FM manual when it references the keypad if you're just grasping the ecu tuning process.
m2cupcar is offline   Reply With Quote
Old 11-02-2008, 03:59 PM   #3
Newb
Thread Starter
 
Join Date: Nov 2008
Location: Newark, DE
Posts: 31
Total Cats: 0
Default

well i dont get the N in any variation....the * is on unless i press throttle

it idles fine and saves fine...i just know the manual said it wont do either if the N is not present....however it works fine, and no N
EOD-5 is offline   Reply With Quote
Old 11-02-2008, 04:57 PM   #4
Elite Member
iTrader: (5)
 
m2cupcar's Avatar
 
Join Date: Jan 2005
Location: Atlanta
Posts: 7,244
Total Cats: 291
Default

My bad- the * is for the TPS. The N is for the clutch and neutral switches. If you don't get the N at all then neither switch appears to be working. Sounds like your tps is ok. In my experience the N causes an incredibly high idle- the car never enters idle control, so it's not regulating the idle valve. It usually causes stalling when the car is taken out of gear for coming to a stop... a droop prevention. If you don't have problems I wouldn't worry about it, but it may surface later when something else changes.
m2cupcar is offline   Reply With Quote
Old 11-02-2008, 05:03 PM   #5
Newb
Thread Starter
 
Join Date: Nov 2008
Location: Newark, DE
Posts: 31
Total Cats: 0
Default

thanks for the help...ill check them out and test them to see whats up

i also just noticed my knock sensor isnt reading values ... ugh!
EOD-5 is offline   Reply With Quote
Old 11-02-2008, 05:45 PM   #6
Elite Member
iTrader: (14)
 
Join Date: Mar 2006
Location: Edmonton, AB
Posts: 4,921
Total Cats: 0
Default

The CEL could be wired for a shift light. As far as I know that is the only thing the link will use the CEL light for. The tuning or install manual describe setting this up, should be pretty easy to verify.
jayc72 is offline   Reply With Quote
Old 11-02-2008, 06:47 PM   #7
Newb
Thread Starter
 
Join Date: Nov 2008
Location: Newark, DE
Posts: 31
Total Cats: 0
Default

it says you can add an external....cant find any info on CEL acting as one.... any help there?
EOD-5 is offline   Reply With Quote
Old 11-02-2008, 11:49 PM   #8
Newb
Thread Starter
 
Join Date: Nov 2008
Location: Newark, DE
Posts: 31
Total Cats: 0
Default

ok so i fixed the 4000 shift light thing, its labeled as AUX RPM in the controller, it was set at 3900 (?)

still no readin on the knock sensor but ill check connections tomorrow, when i check the neutral switches for conductivity

also still no TEMP A, can anyone advise me where to look?

also i cant find QINJ for wiring into sequential injector mode, i havent done the wiring on that yet so its ok, but still not visible

i think that my software is older than the manual maybe, mine says 4-26-2005, but the manual says 12-15-2005.. im not sure...i know in the instructions it says to access ZONEF mode and my controller says ZF....is that any indication?

thanks!
EOD-5 is offline   Reply With Quote
Old 11-03-2008, 09:58 AM   #9
Elite Member
iTrader: (5)
 
m2cupcar's Avatar
 
Join Date: Jan 2005
Location: Atlanta
Posts: 7,244
Total Cats: 291
Default

I'm not gonna be much help with the keypad. There's a reason I quit using it - it's incredibly cryptic when it doesn't need to be. Get a palm and a serial link, sell the keypad and make your life with the LINK simple. You'll need the serial link to tune anyway. I can't remember what version the latest is- you can check with FM. I'll post it here when I find out.
m2cupcar is offline   Reply With Quote
Old 11-03-2008, 10:10 AM   #10
Newb
Thread Starter
 
Join Date: Nov 2008
Location: Newark, DE
Posts: 31
Total Cats: 0
Default

i gotta order something from them today so ill ask when i call

ill look on ebay for the palm, does any version work?
EOD-5 is offline   Reply With Quote
Old 11-03-2008, 10:22 AM   #11
Elite Member
iTrader: (5)
 
m2cupcar's Avatar
 
Join Date: Jan 2005
Location: Atlanta
Posts: 7,244
Total Cats: 291
Default

M500 works for sure (or the IBM equivalent - Workpad C500). That's what the software was written for. It's assumed it'll work with other palms using the same OS, but nobody I know of has tried it.
m2cupcar is offline   Reply With Quote
Old 11-03-2008, 10:30 AM   #12
Newb
Thread Starter
 
Join Date: Nov 2008
Location: Newark, DE
Posts: 31
Total Cats: 0
Default

just bought one on ebay...25 shipped

does it charge from the ide cable too? that would be great
EOD-5 is offline   Reply With Quote
Old 11-03-2008, 11:56 AM   #13
Elite Member
iTrader: (5)
 
m2cupcar's Avatar
 
Join Date: Jan 2005
Location: Atlanta
Posts: 7,244
Total Cats: 291
Default

It could. The guy who wrote the software had his set up that way. It's just a matter of sending the 5v up the correct lead in the palm cable. I just never got around to it. Honestly the palm has never run out of juice on me, but I don't take the car on long drives either. But it's laid around the house for days without sitting on the charger and been used in the car multiple times w/o recharging. I guess that's why I never messed with it.
m2cupcar is offline   Reply With Quote
Old 11-09-2008, 03:31 PM   #14
Newb
Thread Starter
 
Join Date: Nov 2008
Location: Newark, DE
Posts: 31
Total Cats: 0
Default

fixed it...thanks for all the help
EOD-5 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Buzzing from driver side of engine bay? (MS3 install) nick470 MEGAsquirt 7 06-16-2017 02:53 PM
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:12 AM.