Engine Management Question - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


ECUs and Tuning Discuss Engine Management, Tuning, & Programming

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 05-15-2010, 10:34 PM   #1
Junior Member
Thread Starter
iTrader: (10)
 
Join Date: May 2010
Location: Gainesville, GA
Posts: 106
Total Cats: -3
Default Engine Management Question

I'm a noob to this forum, my car, & to turbo cars in general. I got my 1993 Miata with a unknown turbo on it. Kit looks DIY. Anyway, it has the Link Engine Management system & from the literature that came with it, it looks to be an older unit. I know absolutely nothing about the thing except what I read in the manual & since I don't know too much about these turbo cars...much of it might as well have been Greek. Here's the deal. The guy I got the car from said that he is running it in "safe" mode, whatever the hell that means. I guess from my reading he just did a RELOAD & set back to default settings. The car runs ok but if you stomp the throttle or if you rev it up much past 4K RPM it cuts out. Previous owner said he was running it with about 6 or 7 PSI boost & the boost gauge seems to comfirm this. Does anyone have a map I can run in this thing to stop this cutting out problem until such time that I can afford to properly tune this thing on the dyno? See, told you I was a Thanks in advance.
fastnfurious7 is offline   Reply With Quote
Old 05-23-2010, 03:45 PM   #2
Junior Member
 
Join Date: May 2006
Location: Vancouver Canada
Posts: 104
Total Cats: 0
Default

http://www.flyinmiata.com/support/in...ECU_tuning.pdf

Check out item 4 on page 6, sounds like there is either a problem with the intake air temp sensor or it is purposly disconnected.

If you want to figure out that car, you will have to learn a bit more, and read and understand that manual. Going through the initial car setup stuff again would be a good idea as well.
matttheniceguy is offline   Reply With Quote
Old 05-23-2010, 03:56 PM   #3
Junior Member
Thread Starter
iTrader: (10)
 
Join Date: May 2010
Location: Gainesville, GA
Posts: 106
Total Cats: -3
Default

Thanks for the reply, Matt. I did read that whole manual up to the more detailed stuff in Section 8. I will re-read it keeping in mind your suggestion about the intake air temp sensor. I also have not had a chance to try to set the car up because I have to recruit someone to help take notes in the passenger seat to do it. The other problem is that I don't know all of the mods on the car. I don't know what type or brand of turbo is on there. I also don't know which size injectors are in there. They say RC Racing (I think) on them but I don't know if they are the 440cc or the 550cc. Any easy way to find out? I am also assuming that the upgrades to the MiataLink system have been made but that also may not be the case. You are very correct, I need to learn a bunch more about the car to solve this problem. Any assistance on how to identify what I have on the vehicle will be greatly appreciated.
fastnfurious7 is offline   Reply With Quote
Old 05-23-2010, 04:29 PM   #4
Junior Member
Thread Starter
iTrader: (10)
 
Join Date: May 2010
Location: Gainesville, GA
Posts: 106
Total Cats: -3
Default

Okay. I answered my own question on the injectors...DUH. They are either SL4-440's or SL4-550's. I don't have the car with me so I will take a look @ that when I get home on Tuesday. Obviously by my signature you can tell that I assumed that they were 440's but I need to check to make 100% sure. The PO did say that the injectors were already set up for sequential injection which is good.
fastnfurious7 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
Changing from 460cc to flow force 610cc in diypnp 90 Turbo MEGAsquirt 19 10-19-2015 04:23 PM
Expected intake temps on the track? tazswing Race Prep 20 10-03-2015 12:04 PM
VR6 to Miata Swap ScrapinMX5 Meet and Greet 8 09-28-2015 02:04 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:50 PM.