Help with Link ECU - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


ECUs and Tuning Discuss Engine Management, Tuning, & Programming

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 02-12-2011, 03:49 PM   #1
Newb
Thread Starter
 
Join Date: Nov 2007
Posts: 22
Total Cats: 0
Default Help with Link ECU

my screen is acting up on my link ecu and am looking for any suggestions on how to fix it. I have resoldered all the wires going to the ecu, resoldered both the ecu and the screen and have replaced the ribbon cable between the ecu and the screen with no luck.

When i turn the key on, the first half of the screen is totally pixelated and the other half is blank. Every once and a while it will display random numbers and letters on the first half of the screen. The second half does light up on occasion and will also show random numbers/letters.
slyfox03 is offline   Reply With Quote
Old 02-14-2011, 11:39 PM   #2
Newb
Thread Starter
 
Join Date: Nov 2007
Posts: 22
Total Cats: 0
Default

in order to narrow down the variables I have sent out the screen and ribbon wire to Flyin' Miata. They are going to test the wire and the screen in hopes of pinpointing where the issue lies. The techs at FM have been fantastic to deal with and seem very knowlegable about their products.
slyfox03 is offline   Reply With Quote
Old 02-15-2011, 12:20 AM   #3
Elite Member
 
Join Date: Jul 2007
Location: Little Rock, AR
Posts: 3,110
Total Cats: 127
Default

I think spoolin2bars has link stuff for sale.
jacob300zx is offline   Reply With Quote
Old 02-16-2011, 12:27 AM   #4
Junior Member
 
Join Date: Apr 2009
Location: Auckland, New Zealand
Posts: 50
Total Cats: 0
Default

hi if it only does this after turning the ignition off then back on within about 30 seconds dont worry about give it at least 50 seconds before turning the ignition back on
mine does it all the time
i talked to the guys at link electro direct they say sometimes the key pads start holding a charge and will do that if it is repowered without letting the residual carge dissapate
you can also unplug the keypad and that will reset it
sprsta is offline   Reply With Quote
Old 02-16-2011, 10:43 AM   #5
Newb
Thread Starter
 
Join Date: Nov 2007
Posts: 22
Total Cats: 0
Default

Thanks, i just sent spoolin2bars a PM. I should find out the results from FM today on my screen and ribbon wire.

SPRSTA, it doesn't seem to matter how long I wait or unplug the system; still the same results.
slyfox03 is offline   Reply With Quote
Old 02-16-2011, 10:57 AM   #6
Elite Member
iTrader: (5)
 
m2cupcar's Avatar
 
Join Date: Jan 2005
Location: Atlanta
Posts: 7,240
Total Cats: 290
Default

You can use Plink on an old palm. I do- I've never had a LINK keypad.
m2cupcar is offline   Reply With Quote
Old 02-17-2011, 07:03 PM   #7
Newb
Thread Starter
 
Join Date: Nov 2007
Posts: 22
Total Cats: 0
Default

Quote:
Originally Posted by jacob300zx View Post
I think spoolin2bars has link stuff for sale.
do you happen to know him? I sent him a PM on supermiata forum but haven't received a response.
slyfox03 is offline   Reply With Quote
Old 03-28-2012, 09:08 AM   #8
Junior Member
iTrader: (2)
 
Join Date: Oct 2009
Location: Port Saint Lucie, FL
Posts: 96
Total Cats: 0
Default

So you ever figure this out?

I'm guessing mine looks the same
Attached Thumbnails
Help with Link ECU-0591741c.jpg  
mx-p5 is offline   Reply With Quote
Old 12-27-2012, 11:33 AM   #9
Junior Member
iTrader: (2)
 
Join Date: Oct 2009
Location: Port Saint Lucie, FL
Posts: 96
Total Cats: 0
Default

sorry took so long to post again, but it turned out to be a kink in the cable

Stretched it out and it works fine now
mx-p5 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 11:59 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:47 PM.