Injector dead (lag) time - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


ECUs and Tuning Discuss Engine Management, Tuning, & Programming

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 05-06-2010, 10:15 AM   #1
Newb
Thread Starter
 
Join Date: Apr 2010
Location: England
Posts: 19
Total Cats: 0
Default Injector dead (lag) time

Hello,

Could you please tell me the injector deadtime (lag time) for the 23250-74090 440cc injectors that were fitted to MR2 and Celica GT4 Turbo's as I am using these in my Supercharged Mazda MX5 project?

Thanks

John
John90_UK is offline   Reply With Quote
Old 05-06-2010, 12:09 PM   #2
Elite Member
iTrader: (7)
 
samnavy's Avatar
 
Join Date: Apr 2006
Location: VIRGINIA BEACH, VA
Posts: 6,020
Total Cats: 175
Default

#14 on this page... does that help?
http://www.williams.co.tt/s15/inj_side-en.htm
samnavy is offline   Reply With Quote
Old 05-06-2010, 07:49 PM   #3
Newb
Thread Starter
 
Join Date: Apr 2010
Location: England
Posts: 19
Total Cats: 0
Default

Brilliant thanks mate
John90_UK is offline   Reply With Quote
Old 05-06-2010, 08:48 PM   #4
Senior Member
iTrader: (3)
 
Join Date: Aug 2005
Location: Gig Harbor, WA
Posts: 504
Total Cats: 3
Default

Those injectors appear to be side feed. How are you going to adapt them to the mx5 which uses top feed?
TurboRoach is offline   Reply With Quote
Old 05-07-2010, 03:55 AM   #5
Newb
Thread Starter
 
Join Date: Apr 2010
Location: England
Posts: 19
Total Cats: 0
Default

Oh maybe they are not the ones then, mine are the top feed ones I think

They haven't arrived yet but they are listed here as being plug and play?

http://www.mazda-spe...hp?topic=9692.0

Last edited by John90_UK; 05-07-2010 at 06:26 AM.
John90_UK is offline   Reply With Quote
Old 05-10-2010, 06:14 PM   #6
Newb
Thread Starter
 
Join Date: Apr 2010
Location: England
Posts: 19
Total Cats: 0
Default

You were quite right, many thanks, I have now changed them to these

23250-42010 - 440cc low impedance injectors used in the Toyota MR2 (3SGTE) TURBO (Black Top)?


Does anyone know the dead/lag time for these please?

Thanks
John

Last edited by John90_UK; 05-10-2010 at 06:49 PM.
John90_UK is offline   Reply With Quote
Old 06-04-2010, 09:19 PM   #7
Former Vendor
 
Join Date: Oct 2008
Location: Oklahoma City
Posts: 395
Total Cats: 4
Default

If you are using a low impedance injector, make sure you get the resistors to run with them!
Deatschwerks is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
LucaCarMods's Boosted Dutch Miata Build! LucaCarMods Build Threads 11 02-14-2016 07:13 AM
Someone help me with AE ihiryu MEGAsquirt 33 10-08-2015 05:56 PM
Missing/knock at idle, can someone point me in the right direction? Mikel MEGAsquirt 4 09-28-2015 05:46 PM
why is my car running like pewp? (tune/datalog) itsMikey MSPNP 3 09-28-2015 07:40 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:34 AM.