Link ECU + MP62... RPM spike at 1700rpm??? goes up and down like a Yo Yo! - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


ECUs and Tuning Discuss Engine Management, Tuning, & Programming

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 04-19-2010, 07:14 PM   #1
Newb
Thread Starter
 
Join Date: Jan 2009
Posts: 5
Total Cats: 0
Default Link ECU + MP62... RPM spike at 1700rpm??? goes up and down like a Yo Yo!

Bit of a strange one here, and wonder if anyone can help?

Ive installed a link recently and have a strange RPM Spike.

The car run perfectly fine in boost and general driving

BUT

If I am in Neutral and raise the RPM to about 1700, the car sundenly revs up and down between 1700 and 2300rpm even if I hold the throttle in the same postion?

Has anyone had the same problem?

I have set the Idle and TPS as per the Link Instructions

And tried to reset it again and again, and also swapped the IAC and the TPS, but still have the same problem?


Can anyone help please.

Thank
Jibberingloon is offline   Reply With Quote
Old 04-19-2010, 07:23 PM   #2
Newb
Thread Starter
 
Join Date: Jan 2009
Posts: 5
Total Cats: 0
Default

Thanks in advance for your responses, as it is really getting on my ****!
Jibberingloon is offline   Reply With Quote
Old 04-19-2010, 08:31 PM   #3
Junior Member
 
Join Date: Aug 2007
Location: Dallas, Tx
Posts: 224
Total Cats: 0
Default

I would suggest not driving your again until you post up in the Meet and Greet section...

Then after that I would suggest not reving your motor and holding it at 1700 RPM

Then after that you can tell us more about your setup.

Intercooler ?

Injector sizes ?

Staged Non-Staged injection?

Cold side hotside?

Location of the throttle body?

did you set idle using the diagnostic box?

ect. ect. ect.

and buy a turbo
miatamike is offline   Reply With Quote
Old 04-20-2010, 04:52 AM   #4
Newb
Thread Starter
 
Join Date: Jan 2009
Posts: 5
Total Cats: 0
Default

Meet & Greet posted



Idle was set as per FM Link instructions, and the TB is on the Charger, Hotside kit,


and to answer questions spec of car is:

G-Ltd
1.8

MP62 Standard Boost
TDR Intercooler
FM Link ECU
550CC RC Injectors
Mazdaspeed 4-2-1
De-Cat
Mazdaspeed Exhaust
Green Cotton Air Filter


TEIN Flex EDFC
Tarox 6 Pot Brake
FM ARB's
Rota RB 15x8
Federal Track Tyres

Carbon RS Seats
Mazdaspeed Roll Bar

+

Lots more!!!


So if anyone could help me I would appreciate it.

Thanks
Jibberingloon is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Raleigh: Fiberglass headlight scope, 1.6L ECU, AFM, Hardtop latches, more bigmackloud Miata parts for sale/trade 13 09-22-2017 01:34 PM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:21 AM.