Idle Issues and hesitation with m45 - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 03-26-2009, 05:26 PM   #1
Junior Member
Thread Starter
 
Join Date: Jul 2007
Location: Chitown Illinois
Posts: 55
Total Cats: 0
Default Idle Issues and hesitation with m45

Hello all,
I have been having an idle issue with my 1.6 with m45 sc, basically the car will idle fine and then randomly the vacuum will go from normal 20 down to around 17 and lower, the afr will go very lean past the limit of the wd. During this time the car will almost studder and sometimes even die. When i drive the car it will sometimes hesitate and leans out quickly, but will resume normal driving seconds later.I have replaced the iscv and fpr as well as rewired the emanage and loaded maps into it again. I have also checked for vacuum leaks, and replaced injector seals, and i dont believe there are vacuum leaks. I am puzzled, any suggestion?

Last edited by tpod; 03-26-2009 at 06:07 PM.
tpod is offline   Reply With Quote
Old 03-26-2009, 06:12 PM   #2
Junior Member
Thread Starter
 
Join Date: Jul 2007
Location: Chitown Illinois
Posts: 55
Total Cats: 0
Default

was working on it just a minute ago and it started to idle rough and died. I checked the codes right after it died and it seems to be throwing code 1 for ignition pulse, i checked the igniter and it seems to have resistances very close to spec..
tpod is offline   Reply With Quote
Old 03-26-2009, 11:55 PM   #3
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

hustler is offline   Reply With Quote
Old 03-27-2009, 12:27 AM   #4
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,192
Total Cats: 2,583
Default

18psi is offline   Reply With Quote
Old 03-27-2009, 03:02 AM   #5
Elite Member
iTrader: (1)
 
NA6C-Guy's Avatar
 
Join Date: Feb 2008
Location: Birmingham Alabama
Posts: 8,038
Total Cats: 43
Default

Good lord, thats rough. To the OP, I have no suggestions.
NA6C-Guy is offline   Reply With Quote
Old 03-27-2009, 09:33 AM   #6
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

paging johnwag...oh wait, he's at buttonwillow. You might want to try contacting TDR, Gary knows everything about superchargers.
hustler is offline   Reply With Quote
Old 03-29-2009, 01:30 PM   #7
Junior Member
Thread Starter
 
Join Date: Jul 2007
Location: Chitown Illinois
Posts: 55
Total Cats: 0
Default

any constructive idea?
tpod is offline   Reply With Quote
Old 03-30-2009, 07:43 AM   #8
Elite Member
iTrader: (1)
 
Join Date: Jun 2006
Location: Warrington/Birmingham
Posts: 2,658
Total Cats: 39
Default

probably a vac leak, check all your connections.

Hustler, you really are a tool.
richyvrlimited is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Need help - Stock Balancer and Fastforward overlay pulleys Frank_and_Beans Supercharger Discussion 13 09-12-2016 09:17 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Bizarre connection issue? nick470 MEGAsquirt 1 09-30-2015 11:32 PM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:10 PM.