No power past 4k - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 01-23-2011, 01:45 PM   #1
Newb
Thread Starter
 
Join Date: Oct 2010
Posts: 12
Total Cats: 0
Default No power past 4k

So yesterday after i set up the fuel and ignition maps on my 1.6 using the F/IC, the car was running fine. No detonation issues nothing, but today when i started the car and took it for a drive. The engine light was on and wasn't making any power past 4000 rpm's, and when i came to a stop after 10 min of driving i smelled burning oil coming from the back of the motor, and from some exhaust leaks. Id hate for it to be bad rings or i fried the pistons i just had a rebuild done w/wiesco 8.5 pistons. Any advice?
H3br3WHAmm3R92na is offline   Reply With Quote
Old 01-23-2011, 03:10 PM   #2
Elite Member
iTrader: (2)
 
miata2fast's Avatar
 
Join Date: Aug 2009
Location: Dover, FL
Posts: 2,894
Total Cats: 109
Default

Is the engine running smooth at higher rpms, or is the engine making a different sound. If you lost a cylinder, you should hear it.

Start out with the basics, and pull the spark plugs first. If one plug looks different than the others, you know to start evaluating what is wrong with that cylinder. If all of them are the same, than you have a problem with the engine management.
miata2fast is online now   Reply With Quote
Old 01-23-2011, 03:29 PM   #3
Senior Member
iTrader: (2)
 
Join Date: Sep 2008
Location: ON
Posts: 523
Total Cats: 2
Default

Year of car? (short nose crank)
inferno94 is offline   Reply With Quote
Old 01-23-2011, 03:45 PM   #4
Newb
Thread Starter
 
Join Date: Oct 2010
Posts: 12
Total Cats: 0
Default

It revs the same in neutral, but under load (in gear) it starts creeping rpms to redline. It's a 92, and i have the map hooked up but i haven't done anything with that map at all. O2 isn't hooked up either. I'll try removing the spark plugs and get back to you on that.
H3br3WHAmm3R92na is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
3rd Time's a Charm...hopefully. zephyrusaurai Meet and Greet 2 09-28-2015 11:59 PM
wiring wideband ground to battery terminal btabor ECUs and Tuning 10 09-28-2015 06:33 PM
VR6 to Miata Swap ScrapinMX5 Meet and Greet 8 09-28-2015 02:04 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:22 PM.