No start weird cranking problem after head gasket replacement - Miata Turbo Forum - Boost cars, acquire cats.

Go Back  Miata Turbo Forum - Boost cars, acquire cats. > Performance & Tuning > Engine Performance
Reload this Page >

No start weird cranking problem after head gasket replacement

Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

No start weird cranking problem after head gasket replacement

Old 01-03-2019, 07:29 PM
  #1  
Newb
Thread Starter
 
Join Date: Dec 2017
Posts: 41
Total Cats: 0
Default No start weird cranking problem after head gasket replacement

Hello everyone.

I just finished a head gasket job on my 92í miata with a 1.8 swap and megasquirt PNP2. Before the head gasket job it would start up fine, cranking was never a problem, has a new battery, cranked strong. Finished connecting everything and cranked without injectors or spark to build oil pressure, everythingís good, cranked strong. Plugged in spark and fuel for a first attempt at starting and it cranks for a little bit... then dies.... then cranks for a little bit.... then dies. So this only started after i plugged in the injectors and spark. I messed with it a little and with just spark plugged in it does it about 3 times then cranks freely, then with both spark and fuel plugged in it will just keep doing it.
Hereís a link to a video of my most recent attempt to start

start attempt:
https://drive.google.com/file/d/1XLH...w?usp=drivesdk

I have CAS signal, RPM is registering, composite log looked fine, i tested spark with megasquirt and it works, spark plugs were wet when pulled. I havenít got a clue whatís going on. I didnít touch a single thing electrically. I thought the battery was low so i charged it for a little, same thing.

In the video it sputtered like it was going to start, that was the first time that had happened, I havenít changed anything in attempts to start, and after that attempt it wonít do the weird cranking thing anymore.

Ive got nothing, any suggestions? The car only sat for about a week while doing the head.

Thanks for your help!!!

AJ
ActionJackson is offline  
Old 01-03-2019, 09:41 PM
  #2  
Junior Member
 
Join Date: Aug 2017
Location: Lansing, MI
Posts: 137
Total Cats: -4
Default

You pulled the head. Did you make sure everything was set to their respective tdc marks? Did you verify that your ignition timing was correct with megasquirt?
WigglingWaffles is offline  
Old 01-03-2019, 11:29 PM
  #3  
Newb
Thread Starter
 
Join Date: Dec 2017
Posts: 41
Total Cats: 0
Default

Originally Posted by WigglingWaffles View Post
You pulled the head. Did you make sure everything was set to their respective tdc marks? Did you verify that your ignition timing was correct with megasquirt?
YES. Thanks for the suggestion I realized I biffed up the timing belt reassembly. Fixed it and still have the same problem as I displayed in the video. Which is odd because it went away right after i took the video.

AJ
ActionJackson is offline  
Old 01-04-2019, 01:02 AM
  #4  
Cpt. Slow
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,594
Total Cats: 615
Default

You can’t set timing if it doesn’t run. Chances are the CAS is off a bit. Change your cranking advance by +5 or -5 (try both), I bet one will solve your problem.
curly is offline  
Old 01-04-2019, 03:07 PM
  #5  
Newb
Thread Starter
 
Join Date: Dec 2017
Posts: 41
Total Cats: 0
Default

Originally Posted by curly View Post
You canít set timing if it doesnít run. Chances are the CAS is off a bit. Change your cranking advance by +5 or -5 (try both), I bet one will solve your problem.
BINGO! Thank you Curly!
ActionJackson is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
silverstorm
MEGAsquirt
1
11-06-2017 05:19 PM
mackey
General Miata Chat
14
03-21-2016 06:03 PM
thomas18a
Engine Performance
32
06-15-2012 12:06 PM
kaboshe
Engine Performance
3
06-19-2011 10:07 AM
minileprechaun
MEGAsquirt
0
04-26-2011 12:06 PM


Thread Tools
Search this Thread
Quick Reply: No start weird cranking problem after head gasket replacement


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.