Power loss 3K-4.5k - Ideas? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 12-19-2008, 05:18 PM   #1
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Sep 2008
Location: Sandy, Utah
Posts: 175
Total Cats: 0
Default Power loss 3K-4.5k - Ideas?

I have a 95 1.8, still N/A running stock ECU/spark/fuel.

I reinstalled the engine about a week ago and have been driving it around just a little bit. It is having some pretty noticeable hesitation between 3000 and 4500 RPMs. Before and after that rev range it pulls solid and normally, but feels starved in between.

I have a NBO2 gauge installed by the PO, and it reads fairly lean while it's lacking power. I don't know how much to believe a narrow band sensor though...

Before I pulled the engine for oil leak fixing (no more leaks by the way) it was running fine.

My first thought was timing, but I am seeing about 11*-12* btdc which I think is ok. My next thought is a fuel filter. I'll probably replace the fuel filter anyways, but thought it would be something else because it didn't hesitate before. It was only out of commission for about 3 weeks, and I put brand new gas in it as soon as it was back on the road.

Anyone else have any other ideas or things I should check? I'll also be replacing the plugs. They don't look too bad, but I don't know when they were replaced and they are cheap and easy.

I'm trying to get it running great before I install the MS and compound the difficulty in trouble shooting. Any help appreciated.

Last edited by Cpt_Slow; 12-19-2008 at 05:19 PM. Reason: Noob grammar error
Cpt_Slow is offline   Reply With Quote
Old 12-23-2008, 11:00 AM   #2
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Sep 2008
Location: Sandy, Utah
Posts: 175
Total Cats: 0
Default



Here is a quick video clip of the tach and NBO2 gauge in 2nd gear at WOT. There's definitely a correlation between the O2 readings and loss of power. Every time the gauge dips to the lean side there is a noticeable loss in power. I would assume at WOT that the stock ECU would have that thing pegged on the rich side, but that's not what is happening.

Just before the video was shot I put in new NGKs and a fuel filter. I haven't tested the fuel pressure yet, but can't see why it would suddenly be low. If I can't find a solution really soon I'm just going to put in the 460 injectors, LC-1 and MS so I can at least better diagnose the issue.

Cpt_Slow is offline   Reply With Quote
Old 12-23-2008, 11:20 AM   #3
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,899
Total Cats: 1,792
Default

Quote:
Every time the gauge dips to the lean side there is a noticeable loss in power.
I found your problem. now fix it.
Braineack is offline   Reply With Quote
Old 12-23-2008, 11:42 AM   #4
Junior Member
Thread Starter
iTrader: (2)
 
Join Date: Sep 2008
Location: Sandy, Utah
Posts: 175
Total Cats: 0
Default

Quote:
Originally Posted by Braineack View Post
I found your problem. now fix it.
LOL - Thanks Brain. I only pointed that out because I wasn't sure how much to trust a narrow band sensor. Still... the symptom is the lean fuel and power loss. Still looking for the problem.
Cpt_Slow is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 Yesterday 09:00 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Nuke Mars! Joe Perez Current Events, News, Politics 8 09-30-2015 05:41 PM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:41 PM.