Small random misses (perhaps only when first started) - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 10-20-2012, 10:21 PM   #1
Junior Member
Thread Starter
 
Join Date: Aug 2012
Location: Vista, CA
Posts: 49
Total Cats: 0
Default Small random misses (perhaps only when first started)

Okay so. Last month as some of you may remember I burnt a piston. Well I replaced that and the faulty fuel injector. I have had a few minor problems just from putting the engine back in. But nothing I couldn't fix. But I noticed that when the car is idling (for the most part only on a cold start) it misses a beat. Its not loud or anything just a small miss. unfortunately the car has a Bipes ACU timing unit. Which is a piece of ****, I messed with it and got it running a little better. But it still seems to have small misses. So the question is, should I not worry to much, or do I need to upgrade my injectors or rip out the bipes and throw in a mega squirt ASAP?
Murph is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM
Missing/knock at idle, can someone point me in the right direction? Mikel MEGAsquirt 4 09-28-2015 05:46 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:46 PM.