Suddenly running lean. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 08-27-2016, 11:35 PM   #1
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Dec 2015
Location: Brisbane
Posts: 175
Total Cats: -12
Default Suddenly running lean.

So.

00' 1.8 wrx turbo, 640cc inj, stock pump and everything else.

Car was running fine. Was very low on fuel. Nearly completely.
I filled up and drove away. About 15 minutes later i started stalling on idle.

Pulled over had a look, IAT was fine, no leaks, car looked good. Not overheating...
Tweaked the idle till it was steady.

Started driving again and noticed my AFR's started bouncing around and getting high. across the board it seemed 3-4 higher. (17 instead of 14)
Car started misfiring, conking out a few times and being generally ****.

My idle fuel 'target' is 60, boost is around 110-130.
To overcome this i added 20 across the whole table so i was running slightly rich. And drove/limped 40 minutes home.
Last 10 minutes in the drive it was misfiring like crazy and i noticed the fuel was jumping around. Holding same throttle and AFR bounced from 13-> 17 -> 13.
Keep in mind i'm already throwing extra fuel in at this time.

Looking at the logs there's fuel pressure.... Can a clogged filter do this? No idea when it was last changed...

ideas?

Latest log is the last 10 minutes of the drive home. It was playing up bad for the start of the log. I then drove 10 minutes up a mountain and it behaved alot better....
Yesterdays log was when it started and i ramped up the fuel and drove it a few blocks into a mates garage.

I filled up with 98 Fuel which is what the cars tuned on. (USA 93 RON?)
Could this be **** fuel? Edit: no. may run **** and start having timing issues but it wouldn't be lean. hmm.
Attached Files
File Type: msl 2016-08-28_12.32.33.msl (4.46 MB, 32 views)
File Type: msl 2016-08-27_17.28.11.msl (4.80 MB, 46 views)
adryargument is offline   Reply With Quote
Old 08-28-2016, 12:02 AM   #2
Senior Member
iTrader: (1)
 
Onyxyth's Avatar
 
Join Date: May 2013
Location: Boyertown, PA
Posts: 665
Total Cats: 51
Default

Since you mentioned being low on fuel, my first thought is your fuel pump strainer grabbed a bunch of **** and is now a bit clogged. It's not too hard to check, I'd start there.
Onyxyth is online now   Reply With Quote
Old 08-29-2016, 06:32 PM   #3
Newb
 
Join Date: Nov 2015
Posts: 6
Total Cats: 1
Default

I agree with Onyx. Fuel filter is a very likely candidate here. Contaminates collect in your gas tank and settle to the bottom don't normally get sucked up, but when you run it so low they work their way into the fuel system.
Rshannon1 is offline   Reply With Quote
Old 08-29-2016, 10:33 PM   #4
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Dec 2015
Location: Brisbane
Posts: 175
Total Cats: -12
Default

Yeah I picked up a filter and will give that a go.
Strainer on pump will be next.
adryargument is offline   Reply With Quote
Old 08-30-2016, 05:53 AM   #5
Junior Member
Thread Starter
iTrader: (1)
 
Join Date: Dec 2015
Location: Brisbane
Posts: 175
Total Cats: -12
Default

Changed filter and AFR at idle went from 14.8 to 10.6.
Misfires are gone and she's all sunshine and rainbows.

I truly didn't expect a filter to make that much of a difference, that quickly!
Cheers.
adryargument is offline   Reply With Quote
Old 08-30-2016, 11:24 AM   #6
Senior Member
 
Join Date: Oct 2013
Location: NorthWest NJ
Posts: 948
Total Cats: 41
Default

I guess I should actually get around to putting the filter that I have on...
x_25 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
slight misfire Twibs415 Hydra 7 04-05-2016 10:11 AM
1.8 BEGI Turbo Kit, Xedi Engine Management, 3" Exhaust AdrianD2 Miata parts for sale/trade 4 04-03-2016 09:27 PM
Turbo Miata rough start, poor idle and weak acceleration Ruined_miata General Miata Chat 6 03-13-2016 09:33 AM
Car won't start :(. No spark. IAmCman DIY Turbo Discussion 0 07-08-2006 01:40 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 07:31 PM.