Vacuum leak at injector seals - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 04-14-2013, 08:03 AM   #1
Junior Member
Thread Starter
iTrader: (10)
 
Join Date: Jun 2011
Location: Detroit Burbs
Posts: 300
Total Cats: 3
Default Vacuum leak at injector seals

I just got my 1.8L swap running in the last week or so. I used RX-8 yellow injectors for my build, and noticed a vacuum leak at one of the injector seals to the cylinder head. I sprayed brakeclean at the seal when at idle, and could hear idle speed change, and saw the engine go rich on the Wideband sensor.

I remember when I was assembling the fuel rail - I used brand new (parts store aftermarket) injector seals, and they seemed really loose on the RX-8 injectors. Not exactly hot-dog-in-a-hallway loose, but certainly looser than the stock injectors.

Since I used brand new seals, what should I do to fix this issue? Buy a different brand of seals?? Use rtv during installation? Add a extra O-ring to the stackup?
Frank_and_Beans is offline   Reply With Quote
Old 04-14-2013, 09:21 AM   #2
Senior Member
iTrader: (7)
 
RedCarmel's Avatar
 
Join Date: Oct 2011
Location: Horse and Buggy, PA
Posts: 689
Total Cats: 18
Default

You could double check this but I seem to recall FM turbo install directions saying that stacking two could be done. I can't remember if that was in reference to auto parts store Mazda seals or generic Ford seals that could be substituted.
RedCarmel is offline   Reply With Quote
Old 04-14-2013, 10:34 AM   #3
Slowest Progress Ever
iTrader: (26)
 
thirdgen's Avatar
 
Join Date: Oct 2007
Location: The coal ridden hills of Pennsylvania
Posts: 5,806
Total Cats: 183
Default

If you had the huge stock pintle type injectors, and you went to the Bosch type (rx 8 injectors), the grommets are slightly different. Use grommets that were on '99 stock injectors.
thirdgen is offline   Reply With Quote
Old 04-14-2013, 11:52 AM   #4
Junior Member
Thread Starter
iTrader: (10)
 
Join Date: Jun 2011
Location: Detroit Burbs
Posts: 300
Total Cats: 3
Default

Ahh - sounds like this is my problem. I am using the seals from a NA 1.8L. Looks like I need NB seals.
Frank_and_Beans is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
OTS Bilstein to motorsports ASN conversion stoves Suspension, Brakes, Drivetrain 5 04-21-2016 04:00 PM
Changing from 460cc to flow force 610cc in diypnp 90 Turbo MEGAsquirt 19 10-19-2015 04:23 PM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 01:15 PM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 11:23 AM.