Why no more power??? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


Engine Performance This section is for discussion on all engine building related questions.
Sponsored by:
Sponsored by:

Reply
 
 
 
LinkBack Thread Tools Search this Thread
Old 08-07-2012, 12:38 AM   #1
Newb
Thread Starter
 
Join Date: Feb 2012
Location: Québec, Canada
Posts: 19
Total Cats: 0
Question Why no more power???

Like the title says, my car has recently developed a power problem. I drive a 1999 miata with an MP62 supercharger (please don't hate, I bought the car like that).

Here is my problem: A week ago I went shopping and when I came back and started the car, a new rattle started. It sounded like rocks in the exhaust. Then, after the engine was hot, I tried a WOT pull and i noticed it lacked power considerably and I could hear what sounded like a boost leak... when I arrived at my house, the rattle had disappear but the engine still lacked a lot of power.

Since then I've checked all vacuums for leaks, I took off the s/c and it was in perfect condition as was the bypass valve, checked the timing, the engine compression, took off the intake manifold to make sure there really was no vacuum leak and checked the piggyback, still for leaks. I have just taken my exhaust off to see if my catalytic converter was broken but I can only see the intake side of it and it is not clogged and the exhaust doesn't rattle when I gently hit it with a rubber mallet.

Tomorrow i'll try to run it straight pipe after the down pipe to make sure that the catalytic converter is not clogged.

Does anyone have a clue what i could be? Cause I don't....
Any help would be very very appreciated!
Attached Images
 
David603 is offline   Reply With Quote
Old 08-07-2012, 01:37 AM   #2
Senior Member
 
Join Date: Dec 2010
Location: Auckland, NZ
Posts: 783
Total Cats: 23
Default

nhot great if true but rattle of rocks sound could be serious detonation problem.....
mx5-kiwi is offline   Reply With Quote
Old 08-07-2012, 01:41 AM   #3
Slowest Progress Ever
iTrader: (26)
 
thirdgen's Avatar
 
Join Date: Oct 2007
Location: The coal ridden hills of Pennsylvania
Posts: 5,812
Total Cats: 187
Default

What AFR does it run at at full throttle?
thirdgen is offline   Reply With Quote
Old 08-07-2012, 02:14 AM   #4
Elite Member
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,133
Total Cats: 599
Default

2 questions, whats the boost gauge say and what does the AFR gauge say during boost?

If you cant answer those 2 questions, then FIX those 2 issues and then worry about your wot power.
triple88a is offline   Reply With Quote
Old 08-07-2012, 08:50 AM   #5
Elite Member
iTrader: (1)
 
Leafy's Avatar
 
Join Date: Jun 2012
Location: NH
Posts: 9,093
Total Cats: 90
Default

What was the compression and did you do a leak down test?
Leafy is offline   Reply With Quote
Old 08-07-2012, 09:15 AM   #6
Newb
Thread Starter
 
Join Date: Feb 2012
Location: Québec, Canada
Posts: 19
Total Cats: 0
Default

Compression on hot engine was 1-200 2-200 3-200 4-201
Don't have a boost gauge...
Don't have AFR gauge...
Didn't do a leak test...

But I do have OBD2 and on such detonation levels I am pretty shure a CEL would have appered. I also heard the rattle at idle and now that it has disappeared the engine has the same power issues.
David603 is offline   Reply With Quote
Old 08-07-2012, 09:17 AM   #7
Elite Member
iTrader: (1)
 
Leafy's Avatar
 
Join Date: Jun 2012
Location: NH
Posts: 9,093
Total Cats: 90
Default

Wait, how is this tuned...
Leafy is offline   Reply With Quote
Old 08-07-2012, 09:37 AM   #8
mkturbo.com
iTrader: (24)
 
shuiend's Avatar
 
Join Date: May 2006
Location: Charleston SC
Posts: 13,780
Total Cats: 1,106
Default

Quote:
Originally Posted by David603 View Post
Compression on hot engine was 1-200 2-200 3-200 4-201
Don't have a boost gauge...
Don't have AFR gauge...
Didn't do a leak test...

But I do have OBD2 and on such detonation levels I am pretty shure a CEL would have appered. I also heard the rattle at idle and now that it has disappeared the engine has the same power issues.
Buy a wideband O2 sensor and gauge before you drive the car again. There is absolutely no excuse for you not to have one. I am guessing you are going lean and detonating.
shuiend is offline   Reply With Quote
Old 08-07-2012, 09:41 AM   #9
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,205
Total Cats: 2,586
Default

Guys,

I have a car. It has problems. I don't want to do anything to monitor its vitals, I just know that recently it started making a noise.

Please help me.

Thanks
18psi is offline   Reply With Quote
Old 08-07-2012, 10:10 AM   #10
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

Quote:
Originally Posted by mx5-kiwi View Post
nhot great if true but rattle of rocks sound could be serious detonation problem.....
or when the SC goes...
Braineack is offline   Reply With Quote
Old 08-07-2012, 03:18 PM   #11
Elite Member
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,133
Total Cats: 599
Default

Quote:
Originally Posted by David603 View Post
But I do have OBD2 and on such detonation levels I am pretty shure a CEL would have appered. I also heard the rattle at idle and now that it has disappeared the engine has the same power issues.
Well the stock computer has no idea what the hell boost is nor does it know what to do with the timing at all. Don't be so shure that it would toss a cell especially since you're running tons of bandaids to confuse the sensors in the first place. While i was tunning my turbo with the xede before i finally got the ***** to go standalone i heard it ping because of lean more than once and it never popped a cell. Speaking of lean it has no clue how much fuel to add...worst yet the narrow band will not show what afr you're running. Hell you could be at 13.5 afr at 8 or 10 psi, 22 some degrees of spark and the stock computer dont give a ---- and since you have no gauges you have no clue either.
triple88a is offline   Reply With Quote
Old 08-07-2012, 03:20 PM   #12
Elite Member
iTrader: (3)
 
concealer404's Avatar
 
Join Date: Aug 2011
Posts: 8,465
Total Cats: 784
Default

Guise!

Car!!!

HALP!!!!
concealer404 is offline   Reply With Quote
Old 08-07-2012, 03:54 PM   #13
I'm Miserable!
 
Join Date: Jun 2009
Location: albany, ga
Posts: 1,869
Total Cats: 3
Default

Does the car have a cat converter on it?
nvm it does
Take it off and test if you have a straight pipe or with it off
Techsalvager is offline   Reply With Quote
Old 08-07-2012, 06:13 PM   #14
Senior Member
 
Join Date: Aug 2010
Location: Arl. Texas
Posts: 937
Total Cats: 23
Default

The DET sensor will pick up on the knock and ping. It will tell the computer to change your timming around. Becareful, this will cause you to be late everywhere you go.
Miater is offline   Reply With Quote
Old 08-07-2012, 10:19 PM   #15
Senior Member
iTrader: (1)
 
Join Date: Sep 2008
Location: Tucson, Arizona
Posts: 889
Total Cats: 55
Default



welcome to miataturbo bro! it's like totally sweet. Don't worry bro we drive *** cars it's supposed to not have any power bro.
Attached Thumbnails
Why no more power???-hello_this_is_bro.jpg  
krissetsfire is offline   Reply With Quote
Old 08-07-2012, 11:05 PM   #16
Newb
 
Join Date: Feb 2012
Posts: 30
Total Cats: -1
Default

I bet the cat is clogged, most of the time if the cat is clogged it will turn cherry red ofter a good drive. Take it around the block (around a big block) and take a look under the car.
ramos157 is offline   Reply With Quote
Old 08-07-2012, 11:26 PM   #17
Newb
 
Join Date: Feb 2012
Posts: 30
Total Cats: -1
Default

Another way to test is put your hand at the tail pipe and check for exhaust flow.
ramos157 is offline   Reply With Quote
Old 08-07-2012, 11:36 PM   #18
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,205
Total Cats: 2,586
Default

/\ Listen to this guy. He's a professional. If you can't feel it with your hand, stick your ***** in there
18psi is offline   Reply With Quote
Old 08-07-2012, 11:49 PM   #19
Elite Member
iTrader: (2)
 
triple88a's Avatar
 
Join Date: Apr 2006
Location: Chicago, IL
Posts: 9,133
Total Cats: 599
Default

Now only if you can do that while going 30-50 mph at wot.
triple88a is offline   Reply With Quote
Old 08-08-2012, 10:40 AM   #20
Elite Member
iTrader: (3)
 
concealer404's Avatar
 
Join Date: Aug 2011
Posts: 8,465
Total Cats: 784
Default

It helps if you have floppy *****.
concealer404 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 12-15-2017 09:00 PM
Garrett Turbo, 1.8 Oil Pan, & Misc. Stuff nbdooey Miata parts for sale/trade 9 08-30-2017 10:50 PM
1994 Spec Miata Race Car SM/SM2/SSM For Sale Quinn Cars for sale/trade 6 10-23-2016 08:58 AM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:19 AM.