91 tachometer problems - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 07-20-2010, 12:40 AM   #1
Junior Member
Thread Starter
 
Join Date: Nov 2008
Location: Dallas, GA
Posts: 48
Total Cats: 0
Default 91 tachometer problems

I have a 91 miata with a 99NB guage cluster everything seems to be working EXCEPT my Rpm's They dont work at all. The only reason I can think for this is because 91's get there tach reading from the ignitor where as newer models get their readings from some sort of module....Any suggestions?
This is how I have it wired right now:
91 (from Dash) - 99 (from cluster)
Ignitor (Yellow/Blue) - Green/Orange
Ignitor Switch (Black/Blue) - Violet
flash13783 is offline   Reply With Quote
Old 07-20-2010, 01:51 AM   #2
Tour de Franzia
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

My only suggestion is to put in an NA cluster.
hustler is offline   Reply With Quote
Old 07-20-2010, 09:23 AM   #3
Junior Member
Thread Starter
 
Join Date: Nov 2008
Location: Dallas, GA
Posts: 48
Total Cats: 0
Default

I hate to do that when I've gone through the work to do the entire Nb interior swap the guages just top it off...
Does anyone know where the 99 gauge gets it's signal from maybe I can just run a seperate wire to the guage?
flash13783 is offline   Reply With Quote
Old 07-20-2010, 09:42 AM   #4
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,872
Total Cats: 1,790
Default

99 = digital speed sensor
91 = speedo gear cable
Braineack is offline   Reply With Quote
Old 07-20-2010, 02:05 PM   #5
Elite Member
iTrader: (4)
 
MartinezA92's Avatar
 
Join Date: Aug 2009
Location: Mountain View, CA
Posts: 1,702
Total Cats: 28
Default

Quote:
Originally Posted by Braineack View Post
99 = digital speed sensor
91 = speedo gear cable
He said tach.
MartinezA92 is offline   Reply With Quote
Old 07-20-2010, 02:16 PM   #6
Junior Member
Thread Starter
 
Join Date: Nov 2008
Location: Dallas, GA
Posts: 48
Total Cats: 0
Default

yea I already swapped the speed sensor to digital.
flash13783 is offline   Reply With Quote
Old 07-20-2010, 02:35 PM   #7
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,872
Total Cats: 1,790
Default

Quote:
Originally Posted by MartinezA92 View Post
He said tach.
oh yeah.
Braineack is offline   Reply With Quote
Old 07-21-2010, 12:52 AM   #8
Junior Member
Thread Starter
 
Join Date: Nov 2008
Location: Dallas, GA
Posts: 48
Total Cats: 0
Default

ok tell me what yall think this is what Ive came to the conclusion after searching and searching...
This is a chart I found of colors.
Wire colors. The tach signal is the same color at the ECU.
Ground Power Tach signal
1990-93 Black (2D) Black/yellow stripe (2K) Yellow/blue stripe (1H)signal
1994-97 Black (2D) Black/yellow stripe (2K) Black/white stripe (1H)signal
1999-05 Black (3J) Black/yellow stripe (1C) Green/orange stripe (2K)signal

You would think yellow/blue goes with green/orange well that didnt work, and I dont have a black/white..

So I found the attached picture of the ignition ...

So If I ran a wire from the black/white, and connected the three colors (yellow/blue, green/orange, and black/white) together into one that it would work?
flash13783 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
Leaky Wilwoods mx592 Suspension, Brakes, Drivetrain 1 10-01-2015 01:45 AM
Odd Steering issue interestedofold Suspension, Brakes, Drivetrain 5 09-29-2015 02:42 PM
Annoying little leaks AlwaysBroken Engine Performance 5 09-06-2015 01:53 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:18 AM.