can injectors just go bad? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 10-27-2007, 10:17 PM   #1
I'm Miserable!
Thread Starter
iTrader: (5)
 
bryantaylor's Avatar
 
Join Date: Dec 2006
Location: jacksonville, fl
Posts: 1,720
Total Cats: 0
Default can injectors just go bad?

heres the deal. im tired of trying to get the 310s to run right, so i went to put the stock injectors back in. they worked fine when i took them out. but now, the car doesnt want to idle and if you give the car more than 1/4 throttle, it studders, pops, and just plain sucks. i put the 310s back in, ran like it did with the 310s before, put the stockers back in, and doesnt want to idle and studders and **** again. sprayed wd-40 all over the intake mani, idle doesnt change, so there isnt a vac leak. i might go to the junkyard tomorow and pull some stock injectors and see if it helps. any idea what the deal is?
bryantaylor is offline   Reply With Quote
Old 10-27-2007, 10:23 PM   #2
Ben
Supporting Vendor
iTrader: (33)
 
Ben's Avatar
 
Join Date: Jul 2006
Location: atlanta-ish
Posts: 12,689
Total Cats: 99
Default

maybe you fucked up the afm.
Ben is offline   Reply With Quote
Old 10-27-2007, 10:29 PM   #3
I'm Miserable!
Thread Starter
iTrader: (5)
 
bryantaylor's Avatar
 
Join Date: Dec 2006
Location: jacksonville, fl
Posts: 1,720
Total Cats: 0
Default

i dont see how. if different injectors dont work, i might try and snag another afm to try.
bryantaylor is offline   Reply With Quote
Old 10-27-2007, 11:10 PM   #4
jif
Junior Member
 
Join Date: Mar 2007
Location: Auckland, NZ
Posts: 49
Total Cats: 0
Default

they can get gunked up if they sit dry for too long ..?
jif is offline   Reply With Quote
Old 10-27-2007, 11:27 PM   #5
I'm Miserable!
Thread Starter
iTrader: (5)
 
bryantaylor's Avatar
 
Join Date: Dec 2006
Location: jacksonville, fl
Posts: 1,720
Total Cats: 0
Default

Quote:
Originally Posted by jif View Post
they can get gunked up if they sit dry for too long ..?
it was a week
bryantaylor is offline   Reply With Quote
Old 10-28-2007, 09:59 AM   #6
:(
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

you want a rx7 afm that has worked for me in the past 50$ + shipping lemme know.
magnamx-5 is offline   Reply With Quote
Old 10-28-2007, 11:27 AM   #7
I'm Miserable!
Thread Starter
iTrader: (5)
 
bryantaylor's Avatar
 
Join Date: Dec 2006
Location: jacksonville, fl
Posts: 1,720
Total Cats: 0
Default

Quote:
Originally Posted by magnamx-5 View Post
you want a rx7 afm that has worked for me in the past 50$ + shipping lemme know.
that might be an option, need to call back my rx7 friend to see if he has an extra too.
bryantaylor is offline   Reply With Quote
Old 10-29-2007, 12:05 AM   #8
Elite Member
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

How do you know if its all of them? What if its just one? Can you tell if its a particular one?
Saml01 is offline   Reply With Quote
Old 10-29-2007, 04:00 AM   #9
Senior Member
 
Join Date: Mar 2007
Location: Denver, CO
Posts: 564
Total Cats: 0
Default

Quote:
Originally Posted by Saml01 View Post
Can you tell if its a particular one?
Pull each injector plug and see if there's a difference in how it runs.
jwarriner is offline   Reply With Quote
Old 10-29-2007, 04:44 AM   #10
Elite Member
iTrader: (24)
 
Join Date: Jul 2007
Location: Cypress, TX
Posts: 3,778
Total Cats: 35
Default

^What Jwarriner said.

Just based off the title, yes injectors can go bad. I had one on my Eclipse start intermittently (30 seconds over and hour of driving) failing then become progressively worse over the course of 2 months until it completely failed.
Bryce is offline   Reply With Quote
Old 10-29-2007, 10:15 AM   #11
Elite Member
iTrader: (9)
 
Saml01's Avatar
 
Join Date: Jul 2007
Location: NYC
Posts: 5,730
Total Cats: 2
Default

Quote:
Originally Posted by jwarriner View Post
Pull each injector plug and see if there's a difference in how it runs.
Thats safe at idle right?

I ask because, I have some 460's on the way and even though the guy said they were cleaned and flow tested 500 miles ago they havent been used for a while, so I need a way to make sure they are all in order.
Saml01 is offline   Reply With Quote
Old 10-29-2007, 11:22 AM   #12
I'm Miserable!
Thread Starter
iTrader: (5)
 
bryantaylor's Avatar
 
Join Date: Dec 2006
Location: jacksonville, fl
Posts: 1,720
Total Cats: 0
Default

oh, forgot to add, the only way i can get it to idle with the stock injectors now, is with the afm screw almost all the way turned in.
bryantaylor is offline   Reply With Quote
Old 10-29-2007, 12:37 PM   #13
Junior Member
iTrader: (1)
 
Join Date: Jan 2007
Location: Canton, GA
Posts: 116
Total Cats: 0
Default

I had the same thing happen with the same size injectors and FMU. You more than likely fouled your plugs due to a super rich condition. Swap back to the old injectors, install new plugs, and see what happens.
kcbhiw is offline   Reply With Quote
Old 10-29-2007, 01:33 PM   #14
I'm Miserable!
Thread Starter
iTrader: (5)
 
bryantaylor's Avatar
 
Join Date: Dec 2006
Location: jacksonville, fl
Posts: 1,720
Total Cats: 0
Default

the problem is with the 310s, it runs ok, just really rich everywhere. and the stock injectors, it doesnt want to run for ****. i have swaped back and forth several times. is there a way to test the AFM?
bryantaylor is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 Yesterday 09:00 PM
Changing from 460cc to flow force 610cc in diypnp 90 Turbo MEGAsquirt 19 10-19-2015 04:23 PM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 01:15 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Walbro 255lph Fuel Pump $50 lsc224 Miata parts for sale/trade 2 10-01-2015 10:17 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 10:38 PM.