Car running rich all of the sudden - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 03-09-2009, 01:49 PM   #1
Elite Member
Thread Starter
iTrader: (41)
 
Join Date: Jan 2006
Location: Seabrook, TX
Posts: 2,409
Total Cats: 19
Default Car running rich all of the sudden

My car:1992 with 2.0L, BEGi series 4 (2860rs), Link, RX7 550 high imp injectors.

Ok, so i have had this car tuned and running fine, but now it is having some problems. When i start it up it sounds like it is running on 3 cylinders, but not as pronounced when i am driving. It also shows it idling at rediculous numbers like 8.0. When i go into boost it shows it getting incredibly rich as well, sometimes in the neighborhood of 8.5-9.0. I have parked the car because I don't want a gallon of fuel mixed in with my oil after it washes my cylinder walls.

Any suggestions on where to start? I was thinking of a stuck open injector. If it is that how do i check? Do i just pull out the spark plug and see if it is wet? Could it be the fpr?

I am going to be looking at it tonight so any suggestions would be great. Hopefully I can get this all sorted out.
rharris19 is offline   Reply With Quote
Old 03-09-2009, 02:49 PM   #2
Junior Member
 
Join Date: Jan 2008
Posts: 272
Total Cats: 0
Default

Im thinking your IAT is disconnected if you have one.
Sleeper_MX5 is offline   Reply With Quote
Old 03-09-2009, 03:59 PM   #3
Former Vendor
 
Join Date: Oct 2008
Location: Oklahoma City
Posts: 395
Total Cats: 4
Default

There is a way to check for a leaking injector, its not fullproof though. Start the car, unplug your injectors, one at a time from the harness. If the injector is good the car will run poorer, if there is no noticable difference in the way the car is idling after you unplug the injector, good chance that that is your bad one. Like i said this is just a basic way to check. It doesnt always work if you have a more complicated injector problem, but it finds the leakers most of the time
Deatschwerks is offline   Reply With Quote
Old 03-09-2009, 04:49 PM   #4
Elite Member
Thread Starter
iTrader: (41)
 
Join Date: Jan 2006
Location: Seabrook, TX
Posts: 2,409
Total Cats: 19
Default

Quote:
Originally Posted by Sleeper_MX5 View Post
Im thinking your IAT is disconnected if you have one.
If the IAT gets disconnected from the link it won't let you go into boost at all. It will just start to buck like there is a fuel cut right when you go from vacuum to boost.
rharris19 is offline   Reply With Quote
Old 03-09-2009, 04:50 PM   #5
Elite Member
Thread Starter
iTrader: (41)
 
Join Date: Jan 2006
Location: Seabrook, TX
Posts: 2,409
Total Cats: 19
Default

Quote:
Originally Posted by Deatschwerks View Post
There is a way to check for a leaking injector, its not fullproof though. Start the car, unplug your injectors, one at a time from the harness. If the injector is good the car will run poorer, if there is no noticable difference in the way the car is idling after you unplug the injector, good chance that that is your bad one. Like i said this is just a basic way to check. It doesnt always work if you have a more complicated injector problem, but it finds the leakers most of the time
Simple enough. I will try that. I have some 750cc from you that i need to put in but i need to make sure that these aren't messed up before i put them in my other car and have the same problem.
rharris19 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Rotrex cooling issue gsyk59 Engine Performance 49 11-22-2015 05:11 AM
Looking for some EMS4 help E=MC^2 DIY Turbo Discussion 29 10-20-2015 01:03 AM
FS/FT: 03.5 Mazdaspeed Protege leatherface24 Cars for sale/trade 15 10-16-2015 12:35 PM
Compression test results Colipto General Miata Chat 3 09-11-2015 02:44 PM
ME221 Now has Autotune and Long Term Fuel Trim Tables Motorsport-Electronics ECUs and Tuning 0 09-05-2015 09:02 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:47 PM.