Crap, I broke something - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 11-10-2009, 03:34 PM   #1
I EAT CUM
Thread Starter
iTrader: (6)
 
Join Date: Sep 2008
Location: Redneck, Texas
Posts: 1,218
Total Cats: -1
Default Crap, I broke something

I was wiring up my aem wideband and I think in the process something got shorted out but I can't seem to find the exact fuse. Turning the key yields nothing, the radio doesn't work, the a/c doesnt work, the headlights don't work but the turn signals do. I'm assuming I just popped something but none of the fuses are blown so wtf? I think this all happened whenever I wired in the ignition part of the gauge.
Turbo_4 is offline   Reply With Quote
Old 11-10-2009, 03:48 PM   #2
Cpt. Slow
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,105
Total Cats: 518
Default

Did you check both fuse boxes? By the clutch pedal and under the hood?
curly is offline   Reply With Quote
Old 11-10-2009, 05:17 PM   #3
I EAT CUM
Thread Starter
iTrader: (6)
 
Join Date: Sep 2008
Location: Redneck, Texas
Posts: 1,218
Total Cats: -1
Default

Turns out the battery was deader beyond dead...it's all good now. Thanks.
Turbo_4 is offline   Reply With Quote
Old 11-10-2009, 06:23 PM   #4
Senior Member
iTrader: (5)
 
Join Date: Jan 2008
Location: Central, TX / Bay area, CA
Posts: 1,272
Total Cats: 3
Default

so you popped the battery
Gotpsi? is offline   Reply With Quote
Old 11-12-2009, 05:22 PM   #5
I EAT CUM
Thread Starter
iTrader: (6)
 
Join Date: Sep 2008
Location: Redneck, Texas
Posts: 1,218
Total Cats: -1
Default

I only drive the car once every couple weeks so it keeps dying.
Turbo_4 is offline   Reply With Quote
Old 11-16-2009, 03:21 PM   #6
Newb
 
Join Date: Nov 2009
Posts: 4
Total Cats: 0
Default

Same here, I installed a battery cut off to prevent it. Only $3, harbor freight
regs is offline   Reply With Quote
Old 11-21-2009, 02:43 AM   #7
I EAT CUM
Thread Starter
iTrader: (6)
 
Join Date: Sep 2008
Location: Redneck, Texas
Posts: 1,218
Total Cats: -1
Default

I need to get one of those...Battery is already dead again...Thanks.
Turbo_4 is offline   Reply With Quote
Old 11-21-2009, 03:10 AM   #8
MT Pony Underground
iTrader: (6)
 
Nagase's Avatar
 
Join Date: May 2009
Posts: 1,811
Total Cats: 0
Default

Better solution: Drive the car more!
Nagase is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Transmission Heat Shield Thread patsmx5 General Miata Chat 46 06-06-2016 11:27 AM
Help multi issues here! ReallyRottenTurbo MEGAsquirt 4 09-22-2015 01:49 PM
Squiblez 1996 Montego blue Squiblez Build Threads 2 09-22-2015 11:17 AM
Mystery Engine Trouble. Halp, mt.net! vehicular General Miata Chat 12 09-14-2015 04:17 PM
Window crank handles aidandj WTB 0 09-13-2015 06:12 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:34 AM.