Dammit...I FAIL - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Closed Thread
 
 
 
LinkBack Thread Tools
Old 04-02-2009, 12:21 AM   #1
Elite Member
Thread Starter
iTrader: (46)
 
Stein's Avatar
 
Join Date: Dec 2007
Location: Nebraska
Posts: 4,812
Total Cats: 138
Default Dammit...I FAIL

Well, just got home from TOWING my car home.

Out for a ride tonight as it has been cold and crappy the last two days so I haven't been driving the car to work as it still doesn't want to start well when it is in the 30's. Finally got into the 50's again so thought I would go for a drive after dinner.

Buzzed around for a bit, couple of boosted runs on the highway. On the last one I thought I heard detonation. Slowed down and heard a knock. Tried to limp it home the last three miles. Knock kept getting louder. Finally a bang. Pulled over on the gravel road and there was a huge puddle. Walked back to where it started and found the part below. Called the wife to get my truck and come get me. Put the tow strap on it and pulled it home.

Blowing your motor-sucks.

Calling your wife to pull you home with the truck and having to explain why it happend-major sucks.

More pics tomorrow of what's left of the pan and subsequent teardown but a teaser pic for ya.
Attached Thumbnails
Dammit...I FAIL-dsc01374.jpg  
Stein is offline  
Old 04-02-2009, 12:27 AM   #2
Elite Member
iTrader: (15)
 
Join Date: Dec 2007
Location: San Antonio, Texas
Posts: 4,889
Total Cats: 28
Default

That looks like a piston rod cap... Damn...
Sorry Stein. I feel your pain. More details when you are ready, like what do you think went wrong?
ZX-Tex is offline  
Old 04-02-2009, 12:34 AM   #3
Senior Member
iTrader: (2)
 
Join Date: Apr 2008
Location: Tallahassee, FL
Posts: 1,378
Total Cats: 0
Default

Lets get the full deal, psi, power, engine, mileage, turbo.

These threads are scaring me more and more.
naarleven is offline  
Old 04-02-2009, 12:35 AM   #4
Elite Member
Thread Starter
iTrader: (46)
 
Stein's Avatar
 
Join Date: Dec 2007
Location: Nebraska
Posts: 4,812
Total Cats: 138
Default

Yeah, I just hope the crank didn't jack the rod/piston into the head and totally FUBAR it. At least that would have salvage value. I have another 99 motor/tranny that I never sold just in case someting like this would ever happen. Just didn't think it would be so soon. I don't know what happened. AFR's have always been good - rich even. 11.5 tapering to 10.8 at redline.

EDIT: It was #4 if that matters. Stock 99, 72K miles, 8 psi T25 zero boost creep ever since installed.
Stein is offline  
Old 04-02-2009, 12:38 AM   #5
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,205
Total Cats: 2,586
Default

Happy april 1
18psi is offline  
Old 04-02-2009, 12:38 AM   #6
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,900
Total Cats: 1,792
Default

i feel good, I havent blown a motor since 6/7/07...but i never had one fail from power overload...
Braineack is offline  
Old 04-02-2009, 12:46 AM   #7
Elite Member
Thread Starter
iTrader: (46)
 
Stein's Avatar
 
Join Date: Dec 2007
Location: Nebraska
Posts: 4,812
Total Cats: 138
Default

Quote:
Originally Posted by 18psi View Post
Happy april 1
Yeah, whatever. I just "happen" to have a totally fucked up Miata rod cap handy.
Stein is offline  
Old 04-02-2009, 12:57 AM   #8
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,205
Total Cats: 2,586
Default

Oh ****, got PM with photo's of more of the carnage and confirmation over the phone with John (stein)...I'm so sorry man
18psi is offline  
Old 04-02-2009, 12:59 AM   #9
Senior Member
iTrader: (2)
 
Join Date: Apr 2008
Location: Tallahassee, FL
Posts: 1,378
Total Cats: 0
Default

Holy ****, 72k + T25 @ 8psi.

**** me
naarleven is offline  
Old 04-02-2009, 12:59 AM   #10
Senior Member
iTrader: (2)
 
Join Date: Apr 2008
Location: Tallahassee, FL
Posts: 1,378
Total Cats: 0
Default

Quote:
Originally Posted by 18psi View Post
Oh ****, got PM with photo's of more of the carnage and confirmation over the phone with John (stein)...I'm so sorry man
Post up more pics of carnage.
naarleven is offline  
Old 04-02-2009, 01:00 AM   #11
Murderator
iTrader: (76)
 
18psi's Avatar
 
Join Date: Apr 2008
Posts: 36,205
Total Cats: 2,586
Default

Only with John's permission
18psi is offline  
Old 04-02-2009, 01:09 AM   #12
Supporting Vendor
iTrader: (31)
 
Savington's Avatar
 
Join Date: Nov 2006
Location: Sunnyvale, CA
Posts: 14,372
Total Cats: 1,333
Default

God dammit **** **** **** **** **** **** **** ****. I need to build this **** before it blows the **** up on me.
Savington is offline  
Old 04-02-2009, 01:27 AM   #13
Elite Member
iTrader: (11)
 
Join Date: Jun 2007
Location: Overland Park, Kansas
Posts: 5,382
Total Cats: 43
Default

****. Sorry to hear. :(
elesjuan is offline  
Old 04-02-2009, 02:55 AM   #14
Elite AbsurdFlow Member
 
Laur3ns's Avatar
 
Join Date: Mar 2008
Location: Enschede, NL
Posts: 2,058
Total Cats: 11
Default

Sorry for your loss.

Did you just recently use a new ECU? Did you dyno tune fuel and spark?
I mean too lean or too much advance can kill any engine in minutes...
Laur3ns is offline  
Old 04-02-2009, 03:19 AM   #15
Elite Member
iTrader: (13)
 
Join Date: Nov 2006
Location: Tigard, Oregon
Posts: 3,908
Total Cats: 0
Default

Quote:
Originally Posted by Savington View Post
God dammit **** **** **** **** **** **** **** ****. I need to build this **** before it blows the **** up on me.

All that track time you've had I'm thinking you're golden. I've got 16K boosted miles and about 6 hours of track time on mine in the last year. Maybe our 94's are a little tougher? I have to admit I'm thinking about built motor too. I just hate putting more money into what used to be a cheap car.

Stuff breaks boosted or not. My last track day an instructor driving a low mile stock 99 lost his engine the first session. Motor sounded like a sack full of hammers. Something significant was broken inside. No boost, no aftermarket anything on that motor. Miata's are reliable but not fool proof.

Stein, breakage sucks *****. Nice you kept that spare!
cueball1 is offline  
Old 04-02-2009, 03:23 AM   #16
Elite Member
iTrader: (10)
 
rccote's Avatar
 
Join Date: Jan 2008
Location: Buffalo NY
Posts: 1,595
Total Cats: 17
Default

**** that's bogus. I'm really curious about what caused this. These threads are starting to pile up.
rccote is offline  
Old 04-02-2009, 08:07 AM   #17
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Delicious and Moist.
Posts: 26,328
Total Cats: 1,926
Default

Quote:
Originally Posted by rccote View Post
I'm really curious about what caused this.
More stress was applied to the part than it was capable of handling.
Joe Perez is offline  
Old 04-02-2009, 08:24 AM   #18
Elite Member
iTrader: (22)
 
Join Date: Dec 2006
Location: Sunny Spanish speaking Non US Caribbean
Posts: 3,257
Total Cats: 3
Default

Sorry to hear it Stein.

Your engine hadn't shown any signs of age? I mean, things like consuming too much oil? that's how mine started. The #2 piston ring began acting up.

No overheating? I'm seriously beginning to hate the stock water temp gauge. I just finished rebuilding my engine (while they were doing it the shop guys fucked up my Autometer's sensor) and I started seeing signs of overheating (too much coolant consumption) but the water temp gauge never showed anything unusual. I bought another one from leatherface and I'm installing it as we speak.

When you install the other engine; do the coolant reroute (at least for peace of mind).
Rafa is offline  
Old 04-02-2009, 09:26 AM   #19
Elite Member
Thread Starter
iTrader: (46)
 
Stein's Avatar
 
Join Date: Dec 2007
Location: Nebraska
Posts: 4,812
Total Cats: 138
Default

Thanks for the show of support guys, and not even one "dibs" on the 99 head!
Stein is offline  
Old 04-02-2009, 09:30 AM   #20
Elite Member
Thread Starter
iTrader: (46)
 
Stein's Avatar
 
Join Date: Dec 2007
Location: Nebraska
Posts: 4,812
Total Cats: 138
Default

Quote:
Originally Posted by 18psi View Post
Only with John's permission
It was late last night and I didn't forward them to my work computer so I don't have them here. Vlad, go ahead and post them up.
Stein is offline  
 
 
Closed Thread

Related Topics
Thread Thread Starter Forum Replies Last Post
91 1.6l turbo complete part out. Tony the Tiger Miata parts for sale/trade 63 12-29-2016 03:23 AM
Prepping my '95 for track asmasm Build Threads 82 05-26-2016 05:37 PM
Bad head gasket or ? shooterschmidty Engine Performance 8 09-30-2015 11:28 PM
MS3 Basic Connection Issues EErockMiata MEGAsquirt 6 09-24-2015 10:49 AM
91 Celica manual trans, is this fucked? Onyxyth Insert BS here 1 09-19-2015 08:27 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:59 AM.