ever seen a stock oil pressure sender freak out? - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 02-08-2010, 06:12 PM   #1
Tour de Franzia
Thread Starter
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default ever seen a stock oil pressure sender freak out?

My 1.6 sender either reads 35-40psi below 2800rpm, or it pegs high from 3k+. I'm running 5w40 at 200* oil temps and its always pegged. Should I be worried? It's always pegged high but I think it showed lower pressures at 4500rpm than it does now.
hustler is offline   Reply With Quote
Old 02-08-2010, 06:42 PM   #2
meatbag
iTrader: (50)
 
gospeed81's Avatar
 
Join Date: Nov 2008
Location: Houston, TX
Posts: 7,357
Total Cats: 26
Default

Mine's been doing very similar recently...
gospeed81 is offline   Reply With Quote
Old 02-08-2010, 06:48 PM   #3
Elite Member
iTrader: (6)
 
Join Date: Nov 2007
Location: Southlake,Texas
Posts: 3,251
Total Cats: 17
Default

Thinner oil?
Bond is offline   Reply With Quote
Old 02-08-2010, 06:50 PM   #4
meatbag
iTrader: (50)
 
gospeed81's Avatar
 
Join Date: Nov 2008
Location: Houston, TX
Posts: 7,357
Total Cats: 26
Default

+1

I'm running thicker oil since I'm burning it, and I was getting too low of pressure (or needle wavering with occasional drops) on my standard 5w30.
gospeed81 is offline   Reply With Quote
Old 02-08-2010, 06:55 PM   #5
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,899
Total Cats: 1,792
Default

Quote:
Originally Posted by hustler View Post
My 1.6 sender either reads 35-40psi below 2800rpm, or it pegs high from 3k+. I'm running 5w40 at 200* oil temps and its always pegged. Should I be worried? It's always pegged high but I think it showed lower pressures at 4500rpm than it does now.
mine had started reading low, like 15psi at idle or 90psi when cold. then when i swapped my block it completely failed, i had to replace it.
Braineack is offline   Reply With Quote
Old 02-08-2010, 07:02 PM   #6
meatbag
iTrader: (50)
 
gospeed81's Avatar
 
Join Date: Nov 2008
Location: Houston, TX
Posts: 7,357
Total Cats: 26
Default

Mine's also got a lot of frack going on as my motor self-destructs, so you may want to disregard my anecdotal evidence.



*this does not mean: have a panic attack about your motor dying
gospeed81 is offline   Reply With Quote
Old 02-08-2010, 07:05 PM   #7
Elite Member
iTrader: (3)
 
Mach929's Avatar
 
Join Date: Oct 2004
Location: lansdale PA
Posts: 2,500
Total Cats: 0
Default

Quote:
Originally Posted by hustler View Post
My 1.6 sender either reads 35-40psi below 2800rpm, or it pegs high from 3k+. I'm running 5w40 at 200* oil temps and its always pegged. Should I be worried? It's always pegged high but I think it showed lower pressures at 4500rpm than it does now.
surprised your car doesn't already have an aftermarker oil pressure sender and gauge
Mach929 is offline   Reply With Quote
Old 02-08-2010, 07:19 PM   #8
Elite Member
iTrader: (1)
 
NA6C-Guy's Avatar
 
Join Date: Feb 2008
Location: Birmingham Alabama
Posts: 8,038
Total Cats: 43
Default

I would think this would be electronic related, not the oil itself. Mine is pretty jumpy and erratic these days, but it's not the oil. It reads anything from 25-40 at idle and anything from 40-pegged at above 2500rpm. All the time it's jumping around. Started after the rebuild.
NA6C-Guy is offline   Reply With Quote
Old 02-09-2010, 09:48 AM   #9
Tour de Franzia
Thread Starter
iTrader: (6)
 
hustler's Avatar
 
Join Date: Jun 2006
Location: Republic of Dallas
Posts: 29,114
Total Cats: 351
Default

Quote:
Originally Posted by Mach929 View Post
surprised your car doesn't already have an aftermarker oil pressure sender and gauge
I doesn't need to be accurate like water or oil temp. However, I may have an Omori soon.
hustler is offline   Reply With Quote
Old 02-09-2010, 02:13 PM   #10
Senior Member
iTrader: (2)
 
dc2696's Avatar
 
Join Date: May 2005
Location: Edmonton Ab, Canada
Posts: 1,176
Total Cats: 13
Default

Mine was doing the same fr the last couple years, replacig it with aftermarket unit for sure
dc2696 is offline   Reply With Quote
Old 02-09-2010, 02:38 PM   #11
Elite Member
iTrader: (15)
 
Join Date: Sep 2007
Location: Incline Village, NV
Posts: 2,073
Total Cats: 5
Default

1. Get a real gauge
2. After throwing the same oil into my new motor, i am seeing 50psi at WOT 15 psi from 3000-7500
3. As long as you have pressure i wouldn't worry.
4. But seriously, get a real gauge
thesnowboarder is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 59 Yesterday 09:00 PM
WTB MP62 (Hotside) (NB2) Rick02R WTB 3 01-03-2016 08:18 PM
Moroso Air Oil Separator Catch Can Aroundcorner Miata parts for sale/trade 2 10-01-2015 04:20 PM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 01:15 PM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:58 PM.