Got the Hydra in... - Miata Turbo Forum - Boost cars, acquire cats.

General Miata Chat A place to talk about anything Miata

Got the Hydra in...

Old 04-30-2007, 12:06 PM
  #1  
Senior Member
Thread Starter
iTrader: (6)
 
nester's Avatar
 
Join Date: Sep 2005
Location: Houston, TX
Posts: 811
Total Cats: 0
Default Got the Hydra in...

Installed the Hydra and messed with it all this weekend..

My AEM wideband and my Hydra wideband are way off in the 14.7 and up range.. not sure what the deal it.. But I'm still tuning in the off boost zones, and sometimes I'll hit a lean spot, feel the car kinda stumble.. The AEM reads 17.9, 18.0 or ---, the hydra will read like 15.2.. on boost, they seem to be very close though..

Did all the calibrations Hydra and FM's documentation suggested, open air, etc..


Only other pressing issue is that my intake air temp sensor is not working the Hydra reads -20 all the time. dunno about that, unless my crimp job on the plug sucks.
nester is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MechE
Race Prep
70
09-12-2015 04:20 PM
mx5-kiwi
MEGAsquirt
5
09-01-2015 09:30 PM
MazDilla
MEGAsquirt
11
02-12-2008 10:04 PM
nester
Miata parts for sale/trade
19
01-02-2008 09:52 PM
hustler
Insert BS here
10
11-09-2007 03:17 PM


Thread Tools
Search this Thread
Quick Reply: Got the Hydra in...


Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.