Intermittent spark. - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 09-17-2008, 11:55 AM   #1
Elite Member
Thread Starter
iTrader: (8)
 
Join Date: Oct 2007
Location: Dallas
Posts: 1,841
Total Cats: 0
Default Intermittent spark.

My brothers car is losing spark. I swapped my ignitor, coils, & ignition to his.
I think the problem may be where the Msd ign control box was spliced into the cas harness. We are going to re-do the last persons splice.

When the CAS goes out is it completely out. Or can it work intermittently?


Basically the car will turn over and over and have no spark. And out of nowhere it starts sparking and runs. Then it may cut out continually or run all day.
It has more trouble when temperatures are cool as well. If the car is cold, you have to turn it over for ever. Then once it starts and warms up. It will start most of the time.

But it has become so severe that we parked the car.

Any sugestions
Toddcod is offline   Reply With Quote
Old 09-17-2008, 02:52 PM   #2
Former Vendor
 
Join Date: Jun 2006
Location: Bell Tuning & Performance
Posts: 1,338
Total Cats: -78
Default

A couple of things to check. But they may not necessarily be the problem.
1. Injectors
2. O2 sensor - Bank 1/Front
a. check voltage to make sure it has power.
b. Make sure it is screwed in completely and does not come loose.
3. Fuel Injection Fuse under the hood.
4. Spark Plugs

What year is the car?
Stephanie
Stephanie Turner is offline   Reply With Quote
Old 09-17-2008, 02:56 PM   #3
Junior Member
iTrader: (5)
 
Join Date: Jan 2006
Posts: 294
Total Cats: 0
Default

I had a problem that was very similar. I changed the CAS and haven't looked back since. The spark just got weaker and weaker until it didn't spark anymore. I can't remember exactly, but the signal coming out of the CAS just got weaker and weaker.
supersuk is offline   Reply With Quote
Old 09-17-2008, 03:15 PM   #4
Elite Member
Thread Starter
iTrader: (8)
 
Join Date: Oct 2007
Location: Dallas
Posts: 1,841
Total Cats: 0
Default

Quote:
Originally Posted by Stephanie Turner View Post
A couple of things to check. But they may not necessarily be the problem.
1. Injectors
2. O2 sensor - Bank 1/Front
a. check voltage to make sure it has power.
b. Make sure it is screwed in completely and does not come loose.
3. Fuel Injection Fuse under the hood.
4. Spark Plugs

What year is the car?
Stephanie
It is a 1990 1.6L.
Toddcod is offline   Reply With Quote
Old 09-17-2008, 03:18 PM   #5
Elite Member
Thread Starter
iTrader: (8)
 
Join Date: Oct 2007
Location: Dallas
Posts: 1,841
Total Cats: 0
Default

Quote:
Originally Posted by supersuk View Post
I had a problem that was very similar. I changed the CAS and haven't looked back since. The spark just got weaker and weaker until it didn't spark anymore. I can't remember exactly, but the signal coming out of the CAS just got weaker and weaker.
Yea it is weird. I grounded a new spark plug to the head and it would not spark. So I wanted my brother to see. And I turned the key and it started sparking and started. And it ran fine for 5 mins and died.
Then it wouldn't start. Everytime it woun't start there is no spark.

And then it would start and die.
I have a spare cas. I may try that.
Toddcod is offline   Reply With Quote
Old 09-17-2008, 03:33 PM   #6
Senior Member
iTrader: (1)
 
Join Date: Jul 2008
Location: Granbury, TX.
Posts: 1,278
Total Cats: 1
Default

Hmmm.....good to know. That is weird. I thought they were a "just quit working piece."
Machismo is offline   Reply With Quote
Old 09-17-2008, 04:23 PM   #7
Former Vendor
 
Join Date: Jun 2006
Location: Bell Tuning & Performance
Posts: 1,338
Total Cats: -78
Default

The CAS can work but still have problems. If there is a wiring issue, it can act like this. You might also check to see if your engine ground strap is secured well.
Stephanie
Stephanie Turner is offline   Reply With Quote
Old 09-17-2008, 05:10 PM   #8
Elite Member
Thread Starter
iTrader: (8)
 
Join Date: Oct 2007
Location: Dallas
Posts: 1,841
Total Cats: 0
Default

Thanks guys, This thing is becoming time consuming. LOL
Toddcod is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
An Old Driver but a newbie in Miata Patriarca Meet and Greet 17 10-13-2015 02:34 PM
Time to start learning and play with tuning The Gleas MEGAsquirt 3 10-01-2015 10:30 AM
Intermittent Bucking Toddzilla MEGAsquirt 12 12-15-2009 11:07 PM
RPM dropping intermittently during warmup akaryrye MEGAsquirt 9 02-07-2009 05:51 PM
More COP Problems (HELP!) elesjuan General Miata Chat 37 10-31-2008 12:08 AM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:22 AM.