MAS and EGR CEL - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 09-09-2007, 05:04 AM   #1
I'm Miserable!
Thread Starter
 
Join Date: Aug 2007
Posts: 45
Total Cats: 0
Default MAS and EGR CEL

Yes, another newb question, maybe someone can help me out. So my car (99 turbo miata on FM piggy back) is finally running right and I was tuning up for 12psi, I got to messing with the profec b s2 and finally got it to hold a steady 12 psi, took my eyes off the tach and **ouch** popped the rev limiter ever so slightly. Now I have a CEL that reads "MAS voltage too high" and "EGR flow insufficient". I can clear the code but as soon as I boost it again it comes back on. So my question is....WTF!?

I dont know how hitting the rev limiter would throw that code, maybe it was just the 12psi, who knows?
yeah_its_boosted is offline   Reply With Quote
Old 09-09-2007, 01:44 PM   #2
I'm Miserable!
Thread Starter
 
Join Date: Aug 2007
Posts: 45
Total Cats: 0
Default

someone has to know something
yeah_its_boosted is offline   Reply With Quote
Old 09-09-2007, 02:01 PM   #3
:(
iTrader: (7)
 
Join Date: Jul 2006
Location: nowhere
Posts: 8,281
Total Cats: 2
Default

Sounds like the MAF was maxed out and the egr showed to little flow.
magnamx-5 is offline   Reply With Quote
Old 09-09-2007, 02:48 PM   #4
Elite Member
iTrader: (3)
 
Join Date: May 2006
Location: Houston, TX
Posts: 2,900
Total Cats: 0
Default

Probably a 5V supply problem... I think the EGR and MAF are tied together.
Arkmage is offline   Reply With Quote
Old 09-09-2007, 03:35 PM   #5
I'm Miserable!
Thread Starter
 
Join Date: Aug 2007
Posts: 45
Total Cats: 0
Default

Quote:
Originally Posted by magnamx-5 View Post
Sounds like the MAF was maxed out and the egr showed to little flow.
What a pal.

But what do you mean a 5v problem, how can I fix it. I mean the car doesnt run weird, I just hate a CEL, it will drive me crazy.
yeah_its_boosted is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Another Cast Manifold Corky Bell Prefabbed Turbo Kits 18 11-22-2016 10:01 PM
Got bad Crank Angle Sensor and Random Misfire codes, but runs fine. Greasyman General Miata Chat 2 09-28-2015 11:44 AM
WTB Begi cast manifold & t25 turbo Heyitsryan WTB 0 09-12-2015 09:47 PM
First to get it out of the way main Meet and Greet 2 09-05-2015 02:03 PM
First to get it out of the way main Meet and Greet 1 09-05-2015 01:39 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 12:02 PM.