Megasquirting but broke a clutch switch? Identify this! - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 03-08-2015, 12:56 PM   #1
Junior Member
Thread Starter
 
Join Date: Jan 2012
Location: Calgary, AB
Posts: 151
Total Cats: -11
Default Megasquirting but broke a clutch switch? Identify this!

Hi All,

I'm in the middle of installing my MS3 and was trying to undo the 10mm bolt on the stock ECU when I cracked this piece. It's plastic but looks like it serves as some sort of signal for my clutch. The dealership is closed today and I won't be able to replace this part unless other manufacturers carry it for some reason.. And this is my only car.. Damnit..

Well hopefully this isn't important..

What is it?

http://imgur.com/PQXagPn,wsNcIxV#0
Chowcow is offline   Reply With Quote
Old 03-08-2015, 12:57 PM   #2
Boost Czar
iTrader: (61)
 
Braineack's Avatar
 
Join Date: May 2005
Location: Chantilly, VA
Posts: 72,854
Total Cats: 1,788
Default

looks like the cover to a relay of sorts.
Braineack is offline   Reply With Quote
Old 03-08-2015, 01:19 PM   #3
Cpt. Slow
iTrader: (25)
 
curly's Avatar
 
Join Date: Oct 2005
Location: Oregon City, OR
Posts: 12,106
Total Cats: 518
Default

I never even knew they labeled the side of the switch, it looks like the right shape though. I think. If the switch still works, I wouldn't worry about it.
curly is offline   Reply With Quote
Old 03-08-2015, 05:40 PM   #4
SadFab CEO
iTrader: (3)
 
hi_im_sean's Avatar
 
Join Date: Sep 2012
Location: your mom's house phoenix, AZ
Posts: 3,903
Total Cats: 612
Default

that is the cover to a reed style, leaf actuated micro switch, specifically one made by omron

Attached Thumbnails
Megasquirting but broke a clutch switch? Identify this!-omron-v-10g2-1c24-k.jpg  
hi_im_sean is offline   Reply With Quote
Old 03-08-2015, 06:24 PM   #5
Junior Member
Thread Starter
 
Join Date: Jan 2012
Location: Calgary, AB
Posts: 151
Total Cats: -11
Default

The switch probably won't work as I have a loose dangling chain from my clutch pedal that used to attach to the switch I'm describing. I'm guessing it has something to do with my cruise control?

Anyone know the function of the switch? I removed it..
Chowcow is offline   Reply With Quote
Old 03-08-2015, 06:56 PM   #6
Elite Member
iTrader: (21)
 
Join Date: Jun 2007
Location: Rochester, NY
Posts: 5,684
Total Cats: 555
Default

Probably the cancel switch.
rleete is offline   Reply With Quote
Old 03-09-2015, 01:57 PM   #7
Elite Member
 
codrus's Avatar
 
Join Date: Mar 2007
Location: Santa Clara, CA
Posts: 3,877
Total Cats: 344
Default

NBs have two clutch switches. There's one at the top (switches as soon as you press the pedal even a tiny bit) to cancel the cruise control, and one at the bottom (needs to be all the way down to switch) for the starter override. I would think NAs would require the same two switches, although I've never looked.

If the former doesn't work, then the car will do stupid things if you push the clutch in with the cruise control enabled. It may also result in idle/etc problems because I think the ECU sees that switch and uses it to modify various settings. If the latter doesn't work then the car won't start. I'm guessing you would have noticed that.

--Ian
codrus is offline   Reply With Quote
Old 03-09-2015, 03:11 PM   #8
Junior Member
Thread Starter
 
Join Date: Jan 2012
Location: Calgary, AB
Posts: 151
Total Cats: -11
Default

I'm wondering if this switch has to do with my starting issues with megasquirt at the moment. I have a basemap that "should" work, but my car isn't passing the cranking stage- which is what you're kind of describing. I guess I'll order the part (2-3 weeks.. fml) and for the time being, try to tape the switch back on... Not sure if that'll do it.

Thanks for your feedback.

I just don't see how the clutch would affect the starting of the car. I can see how it would either prevent the car from starting at all but not create idle issues. Any explanation for that?
Chowcow is offline   Reply With Quote
Old 03-09-2015, 06:58 PM   #9
Elite Member
 
codrus's Avatar
 
Join Date: Mar 2007
Location: Santa Clara, CA
Posts: 3,877
Total Cats: 344
Default

Quote:
Originally Posted by Chowcow View Post
I'm wondering if this switch has to do with my starting issues with megasquirt at the moment. I have a basemap that "should" work, but my car isn't passing the cranking stage- which is what you're kind of describing. I guess I'll order the part (2-3 weeks.. fml) and for the time being, try to tape the switch back on... Not sure if that'll do it.

Thanks for your feedback.

I just don't see how the clutch would affect the starting of the car. I can see how it would either prevent the car from starting at all but not create idle issues. Any explanation for that?
The bottom-of-travel clutch switch affects starting because the OEM starter interlock won't engage the starter unless the clutch is pushed in all the way. This is not a subtle effect and it's unrelated to the Megasquirt.

The top-of-travel clutch switch might affect idle because that's a signal sent to the ECU. Stock ECUs will use that as part of their idle control logic, although I don't know exactly how. AFAIK the Megasquirt doesn't use it except possibly for anti-lag/launch control.

--Ian
codrus is offline   Reply With Quote
Old 03-09-2015, 07:41 PM   #10
Junior Member
Thread Starter
 
Join Date: Jan 2012
Location: Calgary, AB
Posts: 151
Total Cats: -11
Default

Quote:
Originally Posted by codrus View Post
The bottom-of-travel clutch switch affects starting because the OEM starter interlock won't engage the starter unless the clutch is pushed in all the way. This is not a subtle effect and it's unrelated to the Megasquirt.

The top-of-travel clutch switch might affect idle because that's a signal sent to the ECU. Stock ECUs will use that as part of their idle control logic, although I don't know exactly how. AFAIK the Megasquirt doesn't use it except possibly for anti-lag/launch control.

--Ian
So my starting issues can now be attributed to my megasquirt which is currently installed? That eliminates at least one of my problems.

I hope that's what you mean!

Thanks.
Chowcow is offline   Reply With Quote
Old 03-09-2015, 09:48 PM   #11
Elite Member
 
codrus's Avatar
 
Join Date: Mar 2007
Location: Santa Clara, CA
Posts: 3,877
Total Cats: 344
Default

Quote:
Originally Posted by Chowcow View Post
So my starting issues can now be attributed to my megasquirt which is currently installed? That eliminates at least one of my problems.
What I'm saying is that it's unlikely that an intermittent starting issue is caused by a broken clutch switch. I'm not attributing it to the megasquirt, although considering how important the tune is to having a car that starts and idles well that's where I'd start if I were trying to debug it.

--Ian
codrus is offline   Reply With Quote
Old 03-25-2015, 12:23 PM   #12
Junior Member
Thread Starter
 
Join Date: Jan 2012
Location: Calgary, AB
Posts: 151
Total Cats: -11
Default

So just tried out my cruise control and It doesn't work. It was working before the MS3 was installed.

Also, my car cold idles like crap and I haven't been able to fix it with adding PW/ASE/WUE. This might affect the low RPM start.. I'm trying to find a part number for it, but can't figure it out...

Anyone know?
Chowcow is offline   Reply With Quote
Old 03-25-2015, 12:36 PM   #13
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Chicago (Over two miles from Wrigley Field. Fuck the Cubs. Fuck them in their smarmy goat-hole.)
Posts: 26,317
Total Cats: 1,915
Default

Quote:
Originally Posted by Chowcow View Post
So just tried out my cruise control and It doesn't work. It was working before the MS3 was installed.

Also, my car cold idles like crap and I haven't been able to fix it with adding PW/ASE/WUE. This might affect the low RPM start.. I'm trying to find a part number for it, but can't figure it out...

Anyone know?
That's interesting. I thought all Miatas used plunger switches on the clutch and brake.

Anyway, that's an extremely common switch, and easy to purchase. We'll need to see the rest of it to nail down an exact part number (there are a lot of minor style variations), but I'm guessing it's on this page: Snap Action, Limit Switches | Switches | DigiKey

Probably something like this one: V-15G2-1C25-K Omron Electronics Inc-EMC Div | SW875-ND | DigiKey
Joe Perez is online now   Reply With Quote
Old 03-25-2015, 01:45 PM   #14
Junior Member
Thread Starter
 
Join Date: Jan 2012
Location: Calgary, AB
Posts: 151
Total Cats: -11
Default

I was thinking it was this because there are only 2 switches on the clutch according to Mazda.

SWITCH, CLUTCH (FB01-66-4D0) - $34.24 - FB01664D0

But it doesn't look like the Omron at all.. I'll see where I can source this part in Canada.. Going to be a witchhunt.

I'll check my switch to see if a part number can be found on it.

Thanks again
Chowcow is offline   Reply With Quote
Old 03-25-2015, 02:54 PM   #15
SadFab CEO
iTrader: (3)
 
hi_im_sean's Avatar
 
Join Date: Sep 2012
Location: your mom's house phoenix, AZ
Posts: 3,903
Total Cats: 612
Default

Once you figure out the exact style, they are like a dollar from mouser. I might even have a few laying around.

Edit- or digikey
hi_im_sean is offline   Reply With Quote
Old 03-25-2015, 08:51 PM   #16
Junior Member
Thread Starter
 
Join Date: Jan 2012
Location: Calgary, AB
Posts: 151
Total Cats: -11
Default

Here's an updated photo of what the piece looks like. I actually have no idea how to mount it back to the clutch now... The line looks like it hooks right up to my cruise control. I'm guessing this is why my CC doesn't work..
Attached Thumbnails
Megasquirting but broke a clutch switch? Identify this!-clutchswitch.jpg  
Chowcow is offline   Reply With Quote
Old 03-25-2015, 09:32 PM   #17
Boost Pope
iTrader: (8)
 
Joe Perez's Avatar
 
Join Date: Sep 2005
Location: Chicago (Over two miles from Wrigley Field. Fuck the Cubs. Fuck them in their smarmy goat-hole.)
Posts: 26,317
Total Cats: 1,915
Default

Quote:
Originally Posted by Chowcow View Post
Here's an updated photo of what the piece looks like. I actually have no idea how to mount it back to the clutch now... The line looks like it hooks right up to my cruise control. I'm guessing this is why my CC doesn't work..
And here is the exact replacement at digikey:

V-15G3-1C25-K Omron Electronics Inc-EMC Div | SW133-ND | DigiKey

I have very serious doubts as to whether that switch was the OEM part. My guess would be that a previous owner hacked it in as a replacement.
Joe Perez is online now   Reply With Quote
Old 03-27-2015, 12:56 PM   #18
Junior Member
Thread Starter
 
Join Date: Jan 2012
Location: Calgary, AB
Posts: 151
Total Cats: -11
Default

Digikey is amazing! Thanks for the tips guys. I received the part today, now I just have to figure out how to install it back on.. I'll take this time to find a proper spot for the MS3 as well.. It kind of dangles and hits my clutch foot at the moment..
Chowcow is offline   Reply With Quote
Old 03-27-2015, 09:31 PM   #19
Junior Member
Thread Starter
 
Join Date: Jan 2012
Location: Calgary, AB
Posts: 151
Total Cats: -11
Default

Could someone do me a favor and take a picture of their clutch pedal with the attachment to the Omron control switch for me? I'm having trouble mounting it because I'm not sure where the switch broke from. Also, I think the clutch has a direct attachment to the Omron which means I have to remove the standard one that comes with the switch.

Anyone know what tool I could use to remove the long top part? It's the silver bolt thingy in the middle of it.
Attached Thumbnails
Megasquirting but broke a clutch switch? Identify this!-omron.jpg  
Chowcow is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
Need help - Stock Balancer and Fastforward overlay pulleys Frank_and_Beans Supercharger Discussion 13 09-12-2016 09:17 PM
My solution for Oiltemp and Oilpressure input into Megasuirt (MS3) Zaphod MEGAsquirt 41 01-24-2016 01:25 PM
ACT race clutch and AASCO 7lb. aluminum flywheel graexodus Miata parts for sale/trade 5 10-26-2015 02:48 PM
Any pnp megasquirt for 2001 Big_gumby WTB 0 09-30-2015 04:34 PM


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 03:12 PM.