motor losing power at 2200 rpms - Miata Turbo Forum - Boost cars, acquire cats.

Welcome to Miataturbo.net   Members
 


General Miata Chat A place to talk about anything Miata

Reply
 
 
 
LinkBack Thread Tools
Old 10-05-2012, 11:13 AM   #1
Newb
Thread Starter
 
Join Date: Oct 2012
Location: Beaches of NW Florida
Posts: 17
Total Cats: 0
Default motor losing power at 2200 rpms

Hey everyone, I just bought a 1990 4 days ago. The guy i bought it from said it needed a new afm whick i purchased and installed. It ran great for 7 miles then started losing power (fuel or spark?) at 2200 rpms. Put a new tps thinking that would fix it but didn't. I have done the following, cleaned grounding points, dried all connections even though not wet, took ecu out took covers off and cleaned the board, plugs and wires replaced, and a few other small things. When it cuts at at 2200 it starts going again around 2000 rpms. I can't afford to buy parts that aren't going to fix it. It's a non turbo bone stock 1.6 manuel trans. Any help would be greatly appreciated. Thanks Russ.
Dangeruss64 is offline   Reply With Quote
Old 10-05-2012, 11:15 AM   #2
Newb
Thread Starter
 
Join Date: Oct 2012
Location: Beaches of NW Florida
Posts: 17
Total Cats: 0
Default

I also checked timing and cleared dianostics. Timing was off 4 degrees and set back to 10 tdc.
Dangeruss64 is offline   Reply With Quote
Old 10-05-2012, 11:25 AM   #3
AFM Crusader
iTrader: (18)
 
olderguy's Avatar
 
Join Date: Oct 2004
Location: Wayne, NJ
Posts: 4,438
Total Cats: 84
Default

How new are the plug wires? Still a single wire O2 sensor?
olderguy is offline   Reply With Quote
Old 10-05-2012, 11:35 AM   #4
Newb
Thread Starter
 
Join Date: Oct 2012
Location: Beaches of NW Florida
Posts: 17
Total Cats: 0
Default

plug wired sre good and yes single wire o2. I talked to a guy yesterday that said it probably wasn't o2 but i got my suspicions
Dangeruss64 is offline   Reply With Quote
Old 10-06-2012, 03:31 PM   #5
Elite Member
iTrader: (1)
 
Leafy's Avatar
 
Join Date: Jun 2012
Location: NH
Posts: 9,091
Total Cats: 90
Default

Timing off a tooth(s)?
How do you know the plug wires are good? Miata ones fail and still look perfect on the outside.
Leafy is offline   Reply With Quote
Old 10-06-2012, 04:28 PM   #6
Elite Member
iTrader: (5)
 
Join Date: Oct 2007
Location: Canton, Ga
Posts: 1,707
Total Cats: 19
Default

Better check for a messed up crankshaft
Stealth97 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Project Gemini - Turbo Civic on the Cheap Full_Tilt_Boogie Build Threads 57 07-19-2017 05:11 PM
Back to Stock Part Out!! Turbo Parts, MS2 Enhanced 01-05, Suspension, and MOAR! StratoBlue1109 Miata parts for sale/trade 16 10-02-2015 10:39 AM
Going back to stock. Need some 1.6 parts. Trent WTB 2 10-01-2015 01:15 PM
Low oil pressure after 1.8 swap and new turbo setup JesseTheNoob DIY Turbo Discussion 15 09-30-2015 03:44 PM
Are my coils failing? viriiguy General Miata Chat 5 09-28-2015 08:39 PM


Tags
2200 stall

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:53 AM.